summaryrefslogtreecommitdiff
path: root/sci-electronics/labone
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-24 03:01:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-24 03:01:18 +0100
commita5d03e5440b3955446fba6d02de9f53ea4f6efc4 (patch)
treec1ef5c34e37665a48d85a29c5feadadb9622d627 /sci-electronics/labone
parent456fc832c996a122c45240beb68820ab3c2ada40 (diff)
gentoo auto-resync : 24:05:2023 - 03:01:18
Diffstat (limited to 'sci-electronics/labone')
-rw-r--r--sci-electronics/labone/Manifest2
-rw-r--r--sci-electronics/labone/labone-23.02.42414.ebuild97
2 files changed, 99 insertions, 0 deletions
diff --git a/sci-electronics/labone/Manifest b/sci-electronics/labone/Manifest
index d5a5b4ae9655..2e2fe9415b41 100644
--- a/sci-electronics/labone/Manifest
+++ b/sci-electronics/labone/Manifest
@@ -3,5 +3,7 @@ AUX hf2-data-server.conf 146 BLAKE2B 6bdf91b7f003589cba90896493161fea57e7ce32383
AUX labone-data-server 298 BLAKE2B 85a80af471b37c73600d8958cd786aada03ebab26900735678b975a86f3510b4f127109f8b0f9d01cad95161d7ffbc0d310a5aa29485e917dc244eef1edfb89b SHA512 2dd770743dc25b01e0799363930e7e84b785d1639dffed46530d23c50fc07f2f9aa1b82570ce189e6be2fc6a1402498ae4d05234d515b653514e6ae4e7b534d3
AUX labone-data-server.conf 149 BLAKE2B 60c9376c2470bc7026ae858ad23a9e814ff9e45fd9da464c74ffc66994b2674115f45afb368f322d7e18297b990707c7966032993ab7ebe49ec4a0ca44242639 SHA512 7ef09dc2b8f4b9f2c05753cfa275793afd7f396f8513079dc1eec8ddc8c2648b4defc456ad5b23d2ba20b3c5aa725bb9cde3500ce8d88c0b16df6805811e30b3
DIST LabOneLinux64-21.08.20515.tar.gz 399058267 BLAKE2B 624c4dc4a01edb69f9b36a435744d10b3638c91c7ac0c1e9765cf913e605fe32d1935fa131d650f38a5b713df916d92b985ac5f6489b031bba9b6ec8a1370d4a SHA512 f229a885ea91cc518c4819ad76a928829eb1699603ba48fb745d4a99faca116b100831c17a48243922912c68de27b7938387677ffa2e996a122f36c33d0a205c
+DIST LabOneLinux64-23.02.42414.tar.gz 509402101 BLAKE2B 3bd083830b6dd286ba58227fcfaaed9ec3f7c7ceae8c3eb6b92976bb6b13b9a55389a67da4c71897b4a38200b2e833b4f197e738fff17281c3d0f5c7b3f65226 SHA512 5b4dd91f37b2c3212e9c93e7492756e8534f23d85a12af33cae7ce8150fa182286f37e2d4f3ca7369cb13613b24146e1ba0bb5d889db37634e561b0f921be58a
EBUILD labone-21.08.20515-r2.ebuild 2787 BLAKE2B 13d534adf32eef5de2da07d0361f54c1559cc0ae165bb3aeacba4abd6c9e2000f465fe4bba076ba3c29f10736637923636937d9cfa30920708351a895f093f68 SHA512 bba939469cbbb1ef1afd61b4af514a8d1f4d98d89e16ddf643ead3cef517a9adff9f330ee841aae6f2b321d5c08fe462eac946cbed7a4ce9d53bf110e1981f9c
+EBUILD labone-23.02.42414.ebuild 2792 BLAKE2B 00a59771d3904b38334bbbe0ca908e3be7ab3c7543ebdb80f171a207b94398bb920ce295bc9745698b014b32b2902b83487de86388749bc370c5a3e0c463c31e SHA512 7c99f87cc7a7826e36712a9004c5e1e0316879197fcb9eb0df56c073aee32d3db0b831fda4d29b8dae12f14bd8aaefb992b6a255aaf56d9e4db55db122c4c179
MISC metadata.xml 255 BLAKE2B 4126840e4c5ef0d5669e923458adafa3e4e4f23ad9ed34e890a7c44631222c599e932eca4c8653a3abc976d495226245a666d53ccd846aa474b2c965b106024c SHA512 288b2ec4a0f95ab1bc76c893dc96761ba538330df4368de244ba37db87d0dc870c9af76be202c44441c1ccac4ea34454c69471cd41a37068698e82c074d2dde5
diff --git a/sci-electronics/labone/labone-23.02.42414.ebuild b/sci-electronics/labone/labone-23.02.42414.ebuild
new file mode 100644
index 000000000000..cecf87806ce5
--- /dev/null
+++ b/sci-electronics/labone/labone-23.02.42414.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg desktop systemd udev
+
+DESCRIPTION="Platform independent instrument control for Zurich Instruments devices"
+HOMEPAGE="https://www.zhinst.com/labone"
+
+# Seriously...
+SRC_URI="https://pub-a579c9a7a5ee41a2ba57327584974c85.r2.dev/${PV}/LabOneLinux64-${PV}.tar.gz"
+
+LICENSE="zi-labone"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+RESTRICT="mirror bindist"
+IUSE="minimal"
+
+QA_PREBUILT="*"
+
+RDEPEND=""
+
+S=${WORKDIR}/LabOneLinux64-${PV}
+
+src_install() {
+ local application_directory=/opt/zi
+ local installation_directory="${application_directory}/LabOne64-${PV}"
+
+ if ! use minimal ; then
+
+ # the applications
+
+ dodir ${installation_directory}
+ for dir in API DataServer Firmware Documentation WebServer ; do
+ mv "$dir" "${D}${installation_directory}/" || die
+ done
+
+ cp "release_notes_$(ver_cut 1-2).html" "${D}${installation_directory}/" || die
+
+ dosym ../..${installation_directory}/DataServer/ziServer /opt/bin/ziServer
+ dosym ../..${installation_directory}/DataServer/ziDataServer /opt/bin/ziDataServer
+
+ # the services
+
+ # LabOne comes with systemd support.
+
+ local service
+ for service in labone-data-server hf2-data-server ; do
+ sed -e 's:/usr/local/bin/:/opt/bin/:g' -i Installer/systemd/${service}.service || die
+ systemd_dounit Installer/systemd/${service}.service
+ done
+
+ # For OpenRC we need to do our own thing...
+
+ for service in labone-data-server hf2-data-server ; do
+ doinitd "${FILESDIR}/${service}"
+ doconfd "${FILESDIR}/${service}.conf"
+ done
+
+ echo "#!/bin/bash" > "${T}/startziWebServer" || die
+ echo "${installation_directory}/WebServer/ziWebServer -r ${installation_directory}/WebServer/html --ip 127.0.0.1 --server-port 8004 -a 1" '$@ &' >> "${T}/startziWebServer" || die
+ chmod 755 "${T}/startziWebServer" || die
+ exeinto /opt/bin
+ doexe "${T}/startziWebServer"
+ elog For security reasons the startziWebServer script listens on the localhost interface only.
+
+ newicon "${D}${installation_directory}/WebServer/html/images/favicons/firefox_app_128x128.png" zi-labone.png
+
+ make_desktop_entry /opt/bin/startziWebServer "ZI LabOne" zi-labone "Science;Physics;Engineering"
+
+ keepdir /var/log/labone
+ fowners nobody /var/log/labone
+ else
+
+ insinto "${installation_directory}/API/C/lib"
+ doins API/C/lib/*.so
+ insinto "${installation_directory}/API/C/include"
+ doins API/C/include/*.h
+
+ fi
+
+ dosym "../..${installation_directory}/API/C/include/ziAPI.h" "usr/include/ziAPI.h"
+ dosym "../..${installation_directory}/API/C/lib/libziAPI-linux64.so" "usr/$(get_libdir)/libziAPI-linux64.so"
+
+ udev_dorules Installer/udev/55-zhinst.rules
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ udev_reload
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ udev_reload
+}