summaryrefslogtreecommitdiff
path: root/sci-electronics/gspeakers/gspeakers-0.11-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-electronics/gspeakers/gspeakers-0.11-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-electronics/gspeakers/gspeakers-0.11-r2.ebuild')
-rw-r--r--sci-electronics/gspeakers/gspeakers-0.11-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sci-electronics/gspeakers/gspeakers-0.11-r2.ebuild b/sci-electronics/gspeakers/gspeakers-0.11-r2.ebuild
new file mode 100644
index 000000000000..154f156946cf
--- /dev/null
+++ b/sci-electronics/gspeakers/gspeakers-0.11-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+GCONF_DEBUG="no"
+
+inherit autotools eutils flag-o-matic gnome2
+
+DESCRIPTION="GTK based loudspeaker enclosure and crossovernetwork designer"
+HOMEPAGE="http://gspeakers.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-cpp/gtkmm:2.4
+ >=dev-libs/libsigc++-2.6:2
+ dev-libs/libxml2:2
+ || (
+ sci-electronics/gnucap
+ sci-electronics/ngspice
+ sci-electronics/spice )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ sed -i -e "s/-O0//" src/Makefile.am
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+ epatch "${FILESDIR}"/${P}-glib-single-include.patch
+ epatch "${FILESDIR}"/${P}-fix-sigc-includes.patch
+ epatch "${FILESDIR}"/${P}-c++11.patch
+ append-cxxflags '-std=c++11'
+ mv configure.in configure.ac || die
+ eautoreconf
+ gnome2_src_prepare
+}