summaryrefslogtreecommitdiff
path: root/sci-electronics/ghdl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-04 03:03:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-04 03:03:54 +0000
commit3cc82055be7dba177f4aea15af9f5414b532da7e (patch)
tree1eed8bbe7a93b3a0a7d6091ead40e81519978a38 /sci-electronics/ghdl
parent212000bb5eabdfeb9a6e7a9b8f28e2740cae555a (diff)
gentoo auto-resync : 04:11:2024 - 03:03:54
Diffstat (limited to 'sci-electronics/ghdl')
-rw-r--r--sci-electronics/ghdl/Manifest1
-rw-r--r--sci-electronics/ghdl/ghdl-4.1.0.ebuild90
2 files changed, 0 insertions, 91 deletions
diff --git a/sci-electronics/ghdl/Manifest b/sci-electronics/ghdl/Manifest
index 7b37fb1fba6b..7291b26f8130 100644
--- a/sci-electronics/ghdl/Manifest
+++ b/sci-electronics/ghdl/Manifest
@@ -1,5 +1,4 @@
AUX ghdl-4.0.0_pre20231218-no-pyunit.patch 689 BLAKE2B 2df3df07e290240b2e99422fda33d2ccee9f01a5f3c3aa3535e40ab66bf5de95cbef3821a3e31b0f36b82f5bc90e078e9d2f9424ea5226f7c671ce4dec571458 SHA512 9149bb90346b0c97683a4ed7056cecb727f4ff9a5b89f8b4046983475cd40937f363438129304c72199442bcc3ad948f2c86cb38b6bd0d314dba9199f34a37a6
DIST ghdl-4.1.0.tar.gz 7704716 BLAKE2B d69791d947ed11b62fac8e076c3b9e1bad606a0de57e8d5bd67c9a8f7ea0cad73643085efbaaa06fabdd5900366334b63385589da72f4db488f5b27b142a76f8 SHA512 0a3a465f7f8ed7fba9b81b5dec2903bf82731c97a127666e7644286c9ea80078354be4e6bf8947a6ef631b646dc7e8e69dce2d9a467ac36ee03c67d9335a2703
EBUILD ghdl-4.1.0-r1.ebuild 1749 BLAKE2B 21189188192f6049caa4402e101616d295e36c993502220f7bd99543dde09b2e7324fc1d6b2586edc6d2c4bbf3eefeea5d2ba01e206c521fde44d2843111a2be SHA512 edfb6377135a98ae9f44983a6dbf366f50cbbff52f7c24892911b79bf625d4b69c4a639bcb171e728e1d85fd4ff6a067c36840e5b77b41e197194c58b2be770b
-EBUILD ghdl-4.1.0.ebuild 1551 BLAKE2B 88d7bc60d054a48297b5e21d333e9479f7116c6f01cc75c239847c74c5407724ab8883edd483a36cfd4fc760a8e494e4438dc028af117a978f76b230613fa47b SHA512 a7c5bb4e4948cac92aadeff2ffd82642f34d35cfa6d63772a1ac8003238bf2ab30d9d4879c121c0d1b01e5a4f21c6e37995850bd9b36c7a6b1a1548ff6e230eb
MISC metadata.xml 1462 BLAKE2B a403ab50a3463fc26ddfb6ad65aa2cfe9782e98b74cd91fe24ef81678e7c52a2211b0bcad27accc4cd57db281ed23ad5d8697ae69dd8b67c623465949d6d3434 SHA512 4bd4c20a8fbbdaa80a63373f81bd96144e110371403832627aba81a7a95d073ee73922516a6d5c193898affbeb8bd7f1ce9fc4203faa13464cf39ba809c82d5d
diff --git a/sci-electronics/ghdl/ghdl-4.1.0.ebuild b/sci-electronics/ghdl/ghdl-4.1.0.ebuild
deleted file mode 100644
index 7fb1396f35c1..000000000000
--- a/sci-electronics/ghdl/ghdl-4.1.0.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-ADA_COMPAT=( gnat_2021 gcc_13 )
-LLVM_MAX_SLOT=17 # Check "configure" script for supported LLVM versions.
-
-inherit ada edo llvm toolchain-funcs
-
-DESCRIPTION="Open-source analyzer, compiler, and simulator for VHDL 2008/93/87"
-HOMEPAGE="https://ghdl.github.io/ghdl/
- https://github.com/ghdl/ghdl/"
-
-if [[ "${PV}" == *9999* ]] ; then
- inherit git-r3
-
- EGIT_REPO_URI="https://github.com/ghdl/${PN}.git"
-else
- SRC_URI="https://github.com/ghdl/${PN}/archive/v${PV}.tar.gz
- -> ${P}.tar.gz"
-
- KEYWORDS="amd64 ~x86"
-fi
-
-LICENSE="GPL-2+"
-SLOT="0"
-IUSE="llvm"
-REQUIRED_USE="${ADA_REQUIRED_USE}"
-
-RDEPEND="
- ${ADA_DEPS}
- llvm? ( <sys-devel/llvm-$((${LLVM_MAX_SLOT} + 1)):= )
-"
-DEPEND="
- ${RDEPEND}
-"
-BDEPEND="
- dev-util/patchelf
-"
-
-PATCHES=( "${FILESDIR}/${PN}-4.0.0_pre20231218-no-pyunit.patch" )
-
-pkg_setup() {
- ada_pkg_setup
-
- use llvm && llvm_pkg_setup
-}
-
-src_prepare() {
- default
-
- sed -i "s|ar rc|$(tc-getAR) rc|g" Makefile.in || die
-}
-
-src_configure() {
- tc-export CC CXX
-
- local -a myconf=(
- # Build.
- --disable-werror
-
- # Install location.
- --libdir=$(get_libdir)
- --prefix=/usr
-
- # Features.
- --enable-libghdl
- --enable-synth
- )
-
- if use llvm ; then
- myconf+=( --with-llvm-config=llvm-config )
- fi
-
- # Not a autotools script!
- edo sh ./configure "${myconf[@]}"
-}
-
-src_compile() {
- default
-
- patchelf --set-soname libghw.so lib/libghw.so || die
-}
-
-src_install() {
- default
-
- find "${ED}" -type f -name '*.a' -delete || die
-}