summaryrefslogtreecommitdiff
path: root/sci-electronics/fasthenry/fasthenry-3.0.20.07.17.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /sci-electronics/fasthenry/fasthenry-3.0.20.07.17.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'sci-electronics/fasthenry/fasthenry-3.0.20.07.17.ebuild')
-rw-r--r--sci-electronics/fasthenry/fasthenry-3.0.20.07.17.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sci-electronics/fasthenry/fasthenry-3.0.20.07.17.ebuild b/sci-electronics/fasthenry/fasthenry-3.0.20.07.17.ebuild
new file mode 100644
index 000000000000..ee1cef974df8
--- /dev/null
+++ b/sci-electronics/fasthenry/fasthenry-3.0.20.07.17.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Three dimensional inductance computation program, Whiteley Research version"
+HOMEPAGE="http://www.wrcad.com/freestuff.html"
+SRC_URI="http://www.wrcad.com/ftp/pub/fasthenry-$(ver_cut 1-2)wr-$(ver_cut 4)$(ver_cut 5)$(ver_cut 3).tar.gz"
+
+LICENSE="all-rights-reserved"
+RESTRICT="mirror bindist"
+
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}/fasthenry-3.0wr
+
+PATCHES=(
+ "${FILESDIR}/${P}-cflags.patch"
+ "${FILESDIR}/${P}-ldflags.patch"
+ "${FILESDIR}/${P}-ar.patch"
+)
+
+src_compile() {
+ tc-export CC AR
+ emake all
+}
+
+src_install() {
+ dobin bin/fasthenry
+ dobin bin/zbuf
+ dodoc -r doc/*
+ dodoc -r examples
+}