summaryrefslogtreecommitdiff
path: root/sci-chemistry
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-23 20:00:08 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-23 20:00:08 +0000
commitedb8ee6f86e56d25f82a4f088a4504c903aede08 (patch)
tree3670c3d3d18146edbe5ef22d5623329c49fe1806 /sci-chemistry
parent1ffbeeb1643e9197d8a58c65a1d76bbaf3656292 (diff)
gentoo auto-resync : 23:12:2022 - 20:00:08
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/Manifest.gzbin10189 -> 10193 bytes
-rw-r--r--sci-chemistry/votca/Manifest2
-rw-r--r--sci-chemistry/votca/votca-2022.1.ebuild80
3 files changed, 82 insertions, 0 deletions
diff --git a/sci-chemistry/Manifest.gz b/sci-chemistry/Manifest.gz
index fd8bfceebba0..1eba88fb33b4 100644
--- a/sci-chemistry/Manifest.gz
+++ b/sci-chemistry/Manifest.gz
Binary files differ
diff --git a/sci-chemistry/votca/Manifest b/sci-chemistry/votca/Manifest
index e14b3fbd9b5b..6d2c1c0bceca 100644
--- a/sci-chemistry/votca/Manifest
+++ b/sci-chemistry/votca/Manifest
@@ -1,4 +1,6 @@
+DIST votca-2022.1.tar.gz 61692029 BLAKE2B c58023098f596d7c6f301e94883df3e442761b8c1009823ef5a07e788fabb2a0fa572326e0d614f8102104ef5dcec89505da1c911bb703126c123d2a25a2031e SHA512 dda5cbf1835440abd1b0b511275e10e5facfa9f133062ae082cca4f5654e4af0be0b574b87c70004c0d07920519927bac5620b89ce073de9985bdf792f0dd21a
DIST votca-2022.tar.gz 61688862 BLAKE2B a6a8d1c34e2cd992d032730b2669c9ac5489b988fc334f730eaf1a40b275cc2fad8b24f03419510fe9fee7b0ad0bedf43f9b22b44ca1ae0178b16c9b255da53c SHA512 ea5b7405872a2c0c8d6b4b86148a605b5e83207f1953f0b7393dabbb106ac785c50b45462f6271fbfad04c0246704a92199943acc65eb30d7f1a0a6d6ee4ab83
+EBUILD votca-2022.1.ebuild 1870 BLAKE2B 2a2da4de25e4f8e78b01c0e35634ebb3d02e6947da2326a0b13cca2ae1eba7039485f1ea53d63ebdd774ed396dbe0bc627748431c143a61843711771b90f22a4 SHA512 ec0618843098687df15bf63a8ac460957565d08a66fc7ae82bbe844eb7dcdb5ddfef50e4cf81deb3af30f30210c866e62ed93d947951375ecd6e4d22a7f4dfeb
EBUILD votca-2022.ebuild 1868 BLAKE2B e21b0d7f55a69f4ae3176fb7254aa92f7e23eeb99b5561c671f567c60430e0d74cb574e1b39c9ef1ecc144d1f4d6abd976ccfed3e47faa61043498d927cbfc2e SHA512 792da7d299b68ba6584d233d9da974b7bed994f11bdf3e8d038f2df75b86871336801939aea9ea23aabd9bfcb7889fce1b62b3f25e335b0275e67867435ccc26
EBUILD votca-9999.ebuild 1870 BLAKE2B 2a2da4de25e4f8e78b01c0e35634ebb3d02e6947da2326a0b13cca2ae1eba7039485f1ea53d63ebdd774ed396dbe0bc627748431c143a61843711771b90f22a4 SHA512 ec0618843098687df15bf63a8ac460957565d08a66fc7ae82bbe844eb7dcdb5ddfef50e4cf81deb3af30f30210c866e62ed93d947951375ecd6e4d22a7f4dfeb
MISC metadata.xml 579 BLAKE2B fc22a14bfa99c926b2c5b2071a10b6dd78baab670551c817c4c4f2e5e6a2e13c5fa216fe7a2aa455f15fbf1c8ae488a06b99960830a2d4fb6a82a6a0a277e233 SHA512 89a2c88dc5dc5e06ccd4e1830caa58e0d74f93e1742f4658ed27b6f41be3bd6924da47dc70cd7fcdce9837ceac4012dfeca39e8bf19d0451f044568d00743539
diff --git a/sci-chemistry/votca/votca-2022.1.ebuild b/sci-chemistry/votca/votca-2022.1.ebuild
new file mode 100644
index 000000000000..0962e065f91d
--- /dev/null
+++ b/sci-chemistry/votca/votca-2022.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 cmake python-single-r1
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/votca/votca.git"
+else
+ if [[ ${PV} = *_rc[1-9] ]]; then
+ MY_PV="${PV%%_rc*}-rc.${PV##*_rc}"
+ else
+ MY_PV="${PV}"
+ fi
+ SRC_URI="https://github.com/votca/votca/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux"
+ S="${WORKDIR}/votca-${MY_PV}"
+fi
+
+DESCRIPTION="Versatile Object-oriented Toolkit for Coarse-graining Applications"
+HOMEPAGE="https://www.votca.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="+gromacs test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !sci-libs/votca-tools
+ !sci-chemistry/votca-csg
+ !sci-chemistry/votca-xtp
+ ${PYTHON_DEPS}
+ app-shells/bash:*
+ >=dev-cpp/eigen-3.3
+ dev-libs/boost:=
+ dev-libs/expat
+ sci-libs/fftw:3.0=
+ dev-lang/perl
+ gromacs? ( sci-chemistry/gromacs:=[gmxapi-legacy(+)] )
+ sci-libs/hdf5[cxx]
+ sci-libs/libxc
+ sci-libs/libint:2
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( README.rst NOTICE.rst CHANGELOG.rst )
+
+src_prepare() {
+ # espressopp was removed from gentoo
+ rm -r ./csg-tutorials/spce/ibi_espressopp || die
+ python_fix_shebang .
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_TESTING=$(usex test)
+ -DCMAKE_DISABLE_FIND_PACKAGE_GROMACS=$(usex !gromacs)
+ -DBUILD_CSGAPPS=ON
+ -DINSTALL_RC_FILES=OFF
+ -DCMAKE_DISABLE_FIND_PACKAGE_MKL=ON
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Please read and cite:"
+ einfo "VOTCA-XTP, J. Chem. Theo. Comp. 14, 6353 (2018)"
+ einfo "https://doi.org/10.1021/acs.jctc.8b00617"
+ einfo
+ einfo "VOTCA, J. Chem. Theory Comput. 5, 3211 (2009). "
+ einfo "https://dx.doi.org/10.1021/ct900369w"
+ einfo
+}