summaryrefslogtreecommitdiff
path: root/sci-chemistry
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-20 01:14:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-20 01:14:49 +0100
commitbc4457d8e0e53a2e43c4254d08053ba9708663e1 (patch)
tree4f8809f23d683eed73ef800d99ce7aa628a82527 /sci-chemistry
parent5f593f75391c28294f0dffa4dd1df280a4d8df73 (diff)
gentoo auto-resync : 20:06:2023 - 01:14:49
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/GromacsWrapper/GromacsWrapper-0.8.4.ebuild40
-rw-r--r--sci-chemistry/GromacsWrapper/Manifest2
-rw-r--r--sci-chemistry/Manifest.gzbin9515 -> 9508 bytes
3 files changed, 42 insertions, 0 deletions
diff --git a/sci-chemistry/GromacsWrapper/GromacsWrapper-0.8.4.ebuild b/sci-chemistry/GromacsWrapper/GromacsWrapper-0.8.4.ebuild
new file mode 100644
index 000000000000..e5c508fd6ca1
--- /dev/null
+++ b/sci-chemistry/GromacsWrapper/GromacsWrapper-0.8.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+if [[ ${PV} = *9999* ]]; then
+ scm_eclass=git-r3
+ EGIT_REPO_URI="https://github.com/Becksteinlab/${PN}.git"
+ EGIT_BRANCH="develop"
+ SRC_URI=""
+else
+ scm_eclass=vcs-snapshot
+ SRC_URI="https://github.com/Becksteinlab/${PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+inherit distutils-r1 ${scm_eclass}
+
+DESCRIPTION="Python framework for Gromacs"
+HOMEPAGE="https://gromacswrapper.readthedocs.io"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ sci-libs/numkit[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( >=dev-python/pandas-0.17[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest
diff --git a/sci-chemistry/GromacsWrapper/Manifest b/sci-chemistry/GromacsWrapper/Manifest
index 0297af286564..20f6d340c98d 100644
--- a/sci-chemistry/GromacsWrapper/Manifest
+++ b/sci-chemistry/GromacsWrapper/Manifest
@@ -1,3 +1,5 @@
DIST GromacsWrapper-0.8.2.tar.gz 1954926 BLAKE2B c05995667f925a7519e07e59519e985693effa2fd511d228d236bff978d05430d422003e1360f9fda26564e40bb69183ae8e9b7334e0427c2b177f019df38a6a SHA512 b8a3e7da43eaabaf0fe12f4c06ff80f018847f9386c16eb66c96b3840c66b79d02ee47e675c08ed81df0ef495261c3b557d64c62caac0e484f661ef6b3a5be73
+DIST GromacsWrapper-0.8.4.tar.gz 1955167 BLAKE2B 59f0301263eefaa4d7c139b34a48172c218a76f0f9488477d6203d9cd732098468dae5a73ff46aa74eb2b4433268c77bc265e506129e4c14a357042453d5f97f SHA512 822edc33c77ca4dbfbc1e4172686744345ed3c0d2305f4b19abab15576a1433bbb3b23b96f637398ad4f72cd5414d96ee531ab4a329d3acb462d90b95437a6a5
EBUILD GromacsWrapper-0.8.2.ebuild 911 BLAKE2B bb0f003e877d03904ac5bcce4c73c103eb008670491070e593bbda3d5c5471c2cb766b020626c0dbf3f43694321f71b7d16a1a70b92abe6bb5b014f494ae1506 SHA512 c53c908443c871a87386c48195df4f052d0a211a3d16b298e2f82ac2f73e3078a6d2784c17e22f93598d2e0c80cffe31713b13b390600c4d7e036ddea0c0d390
+EBUILD GromacsWrapper-0.8.4.ebuild 911 BLAKE2B 827ac820482bd41895e02a218041fb1668899d7c80e95ee51021a92d6f7fe36452d1012330118266958f8313694b9c655cc32ddf995d62f3b08aad508c912301 SHA512 6d0f23fcc82cfd0097768a98a1d5755fb003437734f2c6ac90ccff21aa8a8c69bac8f7c0dd4803711e249ff66e513b906394394b71313b2a48f9f0bc37b2ce7e
MISC metadata.xml 483 BLAKE2B 1d8a7e888d8b95bd229ef72894ba02f583e3e3958f9cd5733ab6b466312bac0b0f5a9004135caa37a3ef137e8782fa93ff4bb90f35f31c058d8c528025b193d0 SHA512 70e5dc653ff21a0395b946e5f3548320d2abb8c63ae9f3ce04be6768e20b02ce55a612a2ad12b6c2262529ab753ca9fda02d9bdae7f6ac859bca49bbbad6f75f
diff --git a/sci-chemistry/Manifest.gz b/sci-chemistry/Manifest.gz
index 5e6ae377a829..f895ac43983b 100644
--- a/sci-chemistry/Manifest.gz
+++ b/sci-chemistry/Manifest.gz
Binary files differ