summaryrefslogtreecommitdiff
path: root/sci-chemistry
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /sci-chemistry
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/Manifest.gzbin17549 -> 17714 bytes
-rw-r--r--sci-chemistry/gmxapi/Manifest3
-rw-r--r--sci-chemistry/gmxapi/gmxapi-0.0.7.1.ebuild60
-rw-r--r--sci-chemistry/gmxapi/metadata.xml12
4 files changed, 75 insertions, 0 deletions
diff --git a/sci-chemistry/Manifest.gz b/sci-chemistry/Manifest.gz
index 1cd00da0c495..7eedd16905fe 100644
--- a/sci-chemistry/Manifest.gz
+++ b/sci-chemistry/Manifest.gz
Binary files differ
diff --git a/sci-chemistry/gmxapi/Manifest b/sci-chemistry/gmxapi/Manifest
new file mode 100644
index 000000000000..2fbb4efa04bc
--- /dev/null
+++ b/sci-chemistry/gmxapi/Manifest
@@ -0,0 +1,3 @@
+DIST gmxapi-0.0.7.1.tar.gz 671400 BLAKE2B 5db024bceaed262fc1bd2ef35c0c24a31eff12abde7766ba0eea9d5aabe04c435cdf3c79c04d7932f2110de837a0d06e1f66239f22ba6f313410ed8c9d899788 SHA512 4103d67be3c869907613ec74fc46f14b15242ad93a973fc984dbb25e79bb0bb697d9d2ad9b67a8da2500e5a89b8f78ea1ef1632455af29830e11c2bf1f11bc44
+EBUILD gmxapi-0.0.7.1.ebuild 1239 BLAKE2B 3ee41035a390d32da209882d49e05ed017b697dc568e4a401b024208e34ea56235560d4b5b5605684eb5bb73a7ef88a90705cc62e446322600ab77cfa44e2c50 SHA512 9d09c4faa0997764e07cc33fb4521e248a9e3f74f9ee209457277611a0cc7e0fc19a4836dbeb44cfc98dae8d68b69163859c8f18ca680286b000c56ccc381cb7
+MISC metadata.xml 374 BLAKE2B d93e2ad2f09971909382ad65fc5f5033487979b0694f9dc656439573973f55ce1865e5a30584e55e1c48fdd93898601ac2b11e269fb2b1c5adc3ff8dde66f35d SHA512 1c61c58e1cfbbb42342f7a87625e0044e51523f7a2f7270ecfea537c622965e64195fc88eb8f70fac648a0154a19f4a852b88383de1dcd6e17ff0ac0dc6e22d8
diff --git a/sci-chemistry/gmxapi/gmxapi-0.0.7.1.ebuild b/sci-chemistry/gmxapi/gmxapi-0.0.7.1.ebuild
new file mode 100644
index 000000000000..babdf4029762
--- /dev/null
+++ b/sci-chemistry/gmxapi/gmxapi-0.0.7.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MAKE_MAKEFILE_GENERATOR="ninja"
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit cmake-utils python-r1
+
+DESCRIPTION="Gromacs API bindings"
+HOMEPAGE="https://github.com/kassonlab/gmxapi"
+SRC_URI="https://github.com/kassonlab/gmxapi/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ >=sci-chemistry/gromacs-2019:="
+RDEPEND="
+ ${DEPEND}
+ sci-libs/scikits[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+"
+BDEPEND=""
+
+src_configure() {
+ my_impl_src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_STRIP="${EPREFIX}/bin/true"
+ -DCMAKE_INSTALL_PREFIX="${ED%/}/usr"
+ -DPYTHON_EXECUTABLE="${EPREFIX}/usr/bin/${EPYTHON}"
+ -DGMXAPI_INSTALL_PATH="${EPREFIX}/usr/$(get_libdir)/${EPYTHON}/site-packages/gmx"
+ )
+
+ cmake-utils_src_configure
+ }
+
+ python_foreach_impl my_impl_src_configure
+}
+
+src_compile() {
+ python_foreach_impl cmake-utils_src_make
+}
+
+src_install() {
+ my_impl_src_install() {
+ cd "${BUILD_DIR}" || die
+ cmake-utils_src_install
+ python_optimize
+ }
+
+ python_foreach_impl my_impl_src_install
+}
diff --git a/sci-chemistry/gmxapi/metadata.xml b/sci-chemistry/gmxapi/metadata.xml
new file mode 100644
index 000000000000..7daa2ce7e5f8
--- /dev/null
+++ b/sci-chemistry/gmxapi/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>alexxy@gentoo.org</email>
+ <name>Alexey Shvetsov</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-chemistry@gentoo.org</email>
+ <name>Gentoo Chemistry Project</name>
+ </maintainer>
+</pkgmetadata>