summaryrefslogtreecommitdiff
path: root/sci-chemistry
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-25 01:28:26 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-25 01:28:26 +0100
commit9fce2d9787c37a690336f5e345a49d83ee60bc8a (patch)
tree0dabdf3dfaf12e3782b5551f1c84f30f19d22bec /sci-chemistry
parentd2f5fa9c5505a5c3df8170b498e890f50dfc9553 (diff)
gentoo auto-resync : 25:06:2023 - 01:28:26
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/Manifest.gzbin9508 -> 9508 bytes
-rw-r--r--sci-chemistry/pymol/Manifest1
-rw-r--r--sci-chemistry/pymol/pymol-2.5.0-r3.ebuild98
3 files changed, 99 insertions, 0 deletions
diff --git a/sci-chemistry/Manifest.gz b/sci-chemistry/Manifest.gz
index f895ac43983b..3b7eb5325779 100644
--- a/sci-chemistry/Manifest.gz
+++ b/sci-chemistry/Manifest.gz
Binary files differ
diff --git a/sci-chemistry/pymol/Manifest b/sci-chemistry/pymol/Manifest
index 1d04a0b60c5e..918c3cb629db 100644
--- a/sci-chemistry/pymol/Manifest
+++ b/sci-chemistry/pymol/Manifest
@@ -1,4 +1,5 @@
DIST pymol-1.8.4.0.png.xz 19528 BLAKE2B f3d23d4cedca3d8bb96b20646a548da4be570697e3346a11b01c5c3599b536ba4697be08472dfa8a4f6533167defc1a37a1de332931a73857319cb28fd42cd2b SHA512 40bb0d3f226476f6e047b5361956aad955232a97641474765eaa5204f0539aee3810e0266213618a45364f9f31f6eb18380b17e0c79f64065f7b62a9016caa7c
DIST pymol-2.5.0.tar.gz 10470268 BLAKE2B ad3721432001053be93afe755f531ae47348213b042e84dae33cd79580428c9ac3d00629afa0222e4081807dc80e2dd69c3963a457666b5975b6263b988d02d9 SHA512 19f21b8f735fda5314abf202d56f3c81c7251bf6ef0df73ccee534d9c08035f4ef6155ffb68e09d7717a0fb5ba7289bbfa440691bea4cec0de7199c9e858ea91
EBUILD pymol-2.5.0-r2.ebuild 2628 BLAKE2B 7912d2351535a97c6bd115edf5294ab40c928819f88b3789b27db8414d5ca41569c5849cfdab35c33233179c07b2dfed3521376ebb2579a302d89510e8d784d4 SHA512 e7898cbd163da09bb50d98d04ac6e0d1b2c426c017e7cdb397c63dabc8aa13470980da16d7c0923961938859f46751a02b51dcb17cc0dd6335c099da5c4bb659
+EBUILD pymol-2.5.0-r3.ebuild 2596 BLAKE2B cca285e7f62737e5230fe0ec2fbf6345fea71383ce5e284ae58d30b4e3f7d1532d52396caa695ac86cdfa030cc16b9bd8eaa96f4ec3dcf2b6d0369354cd14d60 SHA512 ad9841c45a5a9e5f6da207f60203d67f2234c6030ca84378c882b3270f668738853ebe6d16f925155c2f0463fa29eeb1af2e745fa1cd96b773214a5e64793ee5
MISC metadata.xml 495 BLAKE2B 32d321e92c7e7c226747660c314f5cff9aabf9ee41c8a864064432ac9554879db7bf60640993dadae6e00a9b7d1367cb8ab228b63b8797ca84e5618eeeb192cc SHA512 36ef956d111c76182c70c81a830885f540fb2710f696b2711837d4bf1055a8792226f38b827f389a3a3861f259bae1394d6da50c2b33a0ddb4e6940262e1b25d
diff --git a/sci-chemistry/pymol/pymol-2.5.0-r3.ebuild b/sci-chemistry/pymol/pymol-2.5.0-r3.ebuild
new file mode 100644
index 000000000000..92415ecd58a6
--- /dev/null
+++ b/sci-chemistry/pymol/pymol-2.5.0-r3.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit desktop flag-o-matic xdg distutils-r1
+
+DESCRIPTION="A Python-extensible molecular graphics system"
+HOMEPAGE="https://www.pymol.org/"
+SRC_URI="
+ https://dev.gentoo.org/~pacho/${PN}/${PN}-1.8.4.0.png.xz
+ https://github.com/schrodinger/pymol-open-source/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ "
+LICENSE="BitstreamVera BSD freedist HPND OFL public-domain UoI-NCSA" #844991
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="+netcdf web"
+
+DEPEND="
+ dev-cpp/msgpack-cxx
+ dev-libs/mmtf-cpp
+ dev-python/pyopengl[${PYTHON_USEDEP}]
+ dev-python/PyQt5[opengl,${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pmw[${PYTHON_USEDEP}]
+ media-libs/freetype:2
+ media-libs/glew:0=
+ media-libs/glm
+ media-libs/libpng:0=
+ media-video/mpeg-tools
+ sys-libs/zlib
+ netcdf? ( sci-libs/netcdf:0= )
+"
+RDEPEND="${DEPEND}
+ sci-chemistry/chemical-mime-data
+"
+
+S="${WORKDIR}"/${PN}-open-source-${PV}
+
+python_prepare_all() {
+ sed \
+ -e "s:\"/usr:\"${EPREFIX}/usr:g" \
+ -e "/ext_comp_args.*+=/s:\[.*\]$:\[\]:g" \
+ -i setup.py || die
+
+ sed \
+ -e "s:/opt/local:${EPREFIX}/usr:g" \
+ -e '/ext_comp_args/s:\[.*\]:[]:g' \
+ -i setup.py || die
+ sed \
+ -e "s:\['msgpackc'\]:\['msgpack'\]:g" \
+ -i setup.py || die
+
+ append-cxxflags -std=c++0x
+
+ use !netcdf && mydistutilsargs=( --no-vmd-plugins )
+
+ distutils-r1_python_prepare_all
+}
+
+python_install() {
+ distutils-r1_python_install \
+ --pymol-path="${EPREFIX}/usr/share/pymol"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ sed \
+ -e '1i#!/usr/bin/env python' \
+ "${D}/$(python_get_sitedir)"/pymol/__init__.py > "${T}"/${PN} || die
+
+ python_foreach_impl python_doscript "${T}"/${PN}
+
+ # These environment variables should not go in the wrapper script, or else
+ # it will be impossible to use the PyMOL libraries from Python.
+ cat >> "${T}"/20pymol <<- EOF || die
+ PYMOL_PATH="${EPREFIX}/usr/share/pymol"
+ PYMOL_DATA="${EPREFIX}/usr/share/pymol/data"
+ PYMOL_SCRIPTS="${EPREFIX}/usr/share/pymol/scripts"
+ EOF
+
+ doenvd "${T}"/20pymol
+
+ newicon "${WORKDIR}"/${PN}-1.8.4.0.png ${PN}.png
+ make_desktop_entry "${PN} %u" PyMol ${PN} \
+ "Graphics;Education;Science;Chemistry;" \
+ "MimeType=chemical/x-pdb;chemical/x-mdl-molfile;chemical/x-mol2;chemical/seq-aa-fasta;chemical/seq-na-fasta;chemical/x-xyz;chemical/x-mdl-sdf;"
+
+ if ! use web; then
+ rm -rf "${D}/$(python_get_sitedir)/web" || die
+ fi
+
+ rm -f "${ED}"/usr/share/${PN}/LICENSE || die
+}