summaryrefslogtreecommitdiff
path: root/sci-chemistry
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-21 19:09:35 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-21 19:09:35 +0100
commit963e79dcc85b2d1ff6167b5558b885d19cb0a6ad (patch)
treefc27f7984ca9e329255af0408d2a14313b1b6468 /sci-chemistry
parent6260b15e6431fe568f4e548f696e150d467cd7f2 (diff)
gentoo resync : 21.07.2018
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/Manifest.gzbin17395 -> 17569 bytes
-rw-r--r--sci-chemistry/nmrdepaker/Manifest3
-rw-r--r--sci-chemistry/nmrdepaker/metadata.xml7
-rw-r--r--sci-chemistry/nmrdepaker/nmrdepaker-1.0.ebuild33
4 files changed, 43 insertions, 0 deletions
diff --git a/sci-chemistry/Manifest.gz b/sci-chemistry/Manifest.gz
index 44dfbce86655..2024a2fe38dc 100644
--- a/sci-chemistry/Manifest.gz
+++ b/sci-chemistry/Manifest.gz
Binary files differ
diff --git a/sci-chemistry/nmrdepaker/Manifest b/sci-chemistry/nmrdepaker/Manifest
new file mode 100644
index 000000000000..bc0f06db9c2d
--- /dev/null
+++ b/sci-chemistry/nmrdepaker/Manifest
@@ -0,0 +1,3 @@
+DIST nmrdepaker-1.0.tar.gz 2233765 BLAKE2B 9b638a36fc50d7c020d56833b6ca78d7079ad357f42431088c4c0735b7e9ce63a0e6318915ec751b42e6628c0da76b93ca16ffea1ffe6b311480e8d278ce1a1a SHA512 9d1a9048a85f85eacaeeb582c5550345efa673b1f517dad121e2b2e19125f93e71a26f2f8240ea9b8a06489814eb833e7b3653f882a46bad699b01fd1aa4299f
+EBUILD nmrdepaker-1.0.ebuild 794 BLAKE2B 3dc1817313f90d1e232fba5839917ee64f78cf97bb8c094e28dfe4d656a91db31d16618637e1897729a944e3fc6a1c9de95530bea53a6c0666bbeeabd32d1dc8 SHA512 48e4de3f0c960e33057d252c2fc0dc48dfc45b7973f5989da5b22bec5f35a802ffced2c871ac5fd6d4880d4eb662783935279036093b0b06d7738e397690397f
+MISC metadata.xml 216 BLAKE2B 0fbfa16661345362ff89f87adc0bb42fc5f5c9145cdedb36f3f537b39af4023b91c4dfb0d8e83a4f9ac963141f594ba8ae678371c338d992a96e02c11fd84195 SHA512 628a69805356b7458edaa2297901224178b016477a937f77e692a78ce3e7a0b6d2d7b4c4b7e70d0185d7112e6a59a5131e07d8c950e90b9c8722471d7511afc6
diff --git a/sci-chemistry/nmrdepaker/metadata.xml b/sci-chemistry/nmrdepaker/metadata.xml
new file mode 100644
index 000000000000..020b40648ee8
--- /dev/null
+++ b/sci-chemistry/nmrdepaker/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>pacho@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-chemistry/nmrdepaker/nmrdepaker-1.0.ebuild b/sci-chemistry/nmrdepaker/nmrdepaker-1.0.ebuild
new file mode 100644
index 000000000000..5ccd2c4508b6
--- /dev/null
+++ b/sci-chemistry/nmrdepaker/nmrdepaker-1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+DISTUTILS_SINGLE_IMPL="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit desktop distutils-r1
+
+DESCRIPTION="Program to perform NMR spectra 'De-Pake-ing' and moment calculation"
+HOMEPAGE="https://launchpad.net/nmrdepaker"
+SRC_URI="https://launchpad.net/${PN}/${PV}/${PV}/+download/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3+"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/matplotlib-0.98.5[gtk2,${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.2[${PYTHON_USEDEP}]
+ >=dev-python/pygtk-2.12:2[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/nmrdpaker-${PV}"
+
+src_install() {
+ distutils-r1_src_install
+
+ newicon lib/data/images/unused/nmrfriend-buddy.svg ${PN}.svg
+ make_desktop_entry ${PN}
+}