summaryrefslogtreecommitdiff
path: root/sci-chemistry
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-30 17:36:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-30 17:36:28 +0100
commit7014a5a3ea0feffab9701fdd6b64cc7667a985af (patch)
treef2cbbaa8bb9209cd15208721103228336149b799 /sci-chemistry
parent7a86906b67693cc65671d3e1476835d3a7e13092 (diff)
gentoo resync : 30.06.2019
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/Manifest.gzbin17227 -> 17228 bytes
-rw-r--r--sci-chemistry/ghemical/Manifest3
-rw-r--r--sci-chemistry/ghemical/files/3.0.0-fix-gcc9.patch37
-rw-r--r--sci-chemistry/ghemical/ghemical-3.0.0.ebuild28
4 files changed, 53 insertions, 15 deletions
diff --git a/sci-chemistry/Manifest.gz b/sci-chemistry/Manifest.gz
index cd635dc327b8..dda3daa5f1c7 100644
--- a/sci-chemistry/Manifest.gz
+++ b/sci-chemistry/Manifest.gz
Binary files differ
diff --git a/sci-chemistry/ghemical/Manifest b/sci-chemistry/ghemical/Manifest
index b7a28786abd5..b551bd472773 100644
--- a/sci-chemistry/ghemical/Manifest
+++ b/sci-chemistry/ghemical/Manifest
@@ -1,4 +1,5 @@
AUX 2.99.2-docs.patch 785 BLAKE2B c731e7366ad44dde7c8754dc6e450e26436f69f4dda5547c61e73d4aa2da69be66cf46204481b1726a7ca746712f0a35c3e689f9da99d4376bc62097512958ec SHA512 0d8754b31eeec184a0d3becb75d3c69c2e922abbe00c175c8cb23d7ea96838896db2da90de45653a7612a041975975f062d289d7d362f6f1abae1d916dbc4b89
+AUX 3.0.0-fix-gcc9.patch 2020 BLAKE2B 40cb4ff6b6b245178aca446a37d9be8876b136b3b0473e41997f538c79c1f47be7a6a940ab97d4f945b1ec7126c6c15ea02ec4bbe0565fcb1623ceb589a1a51a SHA512 9b4764bf0704f9db587d07495b59402c2db87a5cfef0e3f1182f6428fa0b6e25081126714cd47b42bebe7243b5e78fa5a33cd0b5989a5235d01bc0f27ac281a6
DIST ghemical-3.0.0.tar.gz 2196716 BLAKE2B 62008667c58cb058beb8eb3946bb96fb03aceff7cc93f64aecc697a7648946936208063b419aca57f740d5760a90d923d81f8cc8d80fb68bdf924b23cd2061b3 SHA512 d4dd0b063a4dea33fa7430e77a2da253c74079fd8b5f21e8c2b5da1383f3689b93305417e1bf0d4908b87c91afb33c3266dd6bd6fbcd768cc98614a3f730ee94
-EBUILD ghemical-3.0.0.ebuild 1353 BLAKE2B 5037472809fb5ff199c6683d4db73bd2c86ebd1764f4c2263bbcb5fb0910c12d768692451f7a8a27dc5307023f5a710b1cac933da16f211705d5744db8129028 SHA512 790b807c3e9e33230a752187cb362336de8f2f953e5bc6cbe834c53a85cd74509449c4e20e1fd0cc22f9e092c44bb4f24c57cf2a96ec38cb7059188a68f5237e
+EBUILD ghemical-3.0.0.ebuild 1304 BLAKE2B 518deae5395eb251fb9710ea31dd69a25cce77a70b495de50c3d8e1c19ab3451e1b17fc66ec4d3526654d80c1e49a8ea44b1a080bb281fddf1b633481d910fcd SHA512 772abfdf8ee8f0bf5de652157ba54953090a553b67c4dbbc246cbe47ad6182dddf89c20d3f67f544fa7b68e0f5938f4e55049db6a6984dfbcbd6b748f83a35b8
MISC metadata.xml 851 BLAKE2B 119f8bdb334c7e1391c821aa99b59e9433ea1856a79e5216d1d35fa1349b36dff1288a3fb816af9547d451a95d8266889df7e6a79cf73748094fce7876125074 SHA512 bde362ad42f9648cd8e5f32e1c9b9e10159bf9b850a86e80012f067530d6e5912bfc54eb22c170a8eeb0a8ba705db4ecc3c0559b431eaee8ea474d4f9c82de93
diff --git a/sci-chemistry/ghemical/files/3.0.0-fix-gcc9.patch b/sci-chemistry/ghemical/files/3.0.0-fix-gcc9.patch
new file mode 100644
index 000000000000..d3d80bbd00ba
--- /dev/null
+++ b/sci-chemistry/ghemical/files/3.0.0-fix-gcc9.patch
@@ -0,0 +1,37 @@
+https://bugs.gentoo.org/687450
+
+project.h:210:14: error: friend declaration of ‘bool ReadGPR_OLD(project&, std::istream&, bool, bool)’ specifies default arguments and isn’t a definition [-fpermissive]
+ 210 | friend bool ReadGPR_OLD(project &, istream &, bool, bool = false); ///< this is for the very old version.
+ | ^~~~~~~~~~~
+
+--- a/src/project.h
++++ b/src/project.h
+@@ -122,6 +122,12 @@
+ graphical user interface.
+ */
+
++class project;
++bool ReadGPR_OLD(project &, istream &, bool, bool = false);
++bool ReadGPR_v100(project &, istream &, bool, bool = false);
++bool ReadGPR_v110(project &, istream &, bool, bool = false);
++bool ReadGPR(project &, istream &, bool, bool = false);
++
+ class project :
+ public custom_transformer_client,
+ public model
+@@ -207,11 +213,11 @@
+
+ // methods for file I/O : ReadGPR and WriteGPR are friend functions so that it would be easier to "borrow" them elsewhere...
+ // ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
+- friend bool ReadGPR_OLD(project &, istream &, bool, bool = false); ///< this is for the very old version.
+- friend bool ReadGPR_v100(project &, istream &, bool, bool = false); ///< this is for the version 1.00.
+- friend bool ReadGPR_v110(project &, istream &, bool, bool = false); ///< this is for the version 1.10.
++ friend bool ReadGPR_OLD(project &, istream &, bool, bool); ///< this is for the very old version.
++ friend bool ReadGPR_v100(project &, istream &, bool, bool); ///< this is for the version 1.00.
++ friend bool ReadGPR_v110(project &, istream &, bool, bool); ///< this is for the version 1.10.
+ /// This is an input function for the v1.11 ghemical file format.
+- friend bool ReadGPR(project &, istream &, bool, bool = false);
++ friend bool ReadGPR(project &, istream &, bool, bool);
+
+ friend void WriteGPR_v100(project &, ostream &); ///< this is for the version 1.00.
+ /// This is an output function for the v1.11 ghemical file format.
diff --git a/sci-chemistry/ghemical/ghemical-3.0.0.ebuild b/sci-chemistry/ghemical/ghemical-3.0.0.ebuild
index 5704b7df145c..477c41439c28 100644
--- a/sci-chemistry/ghemical/ghemical-3.0.0.ebuild
+++ b/sci-chemistry/ghemical/ghemical-3.0.0.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit autotools desktop
@@ -18,17 +18,20 @@ RDEPEND="
dev-libs/glib:2
gnome-base/libglade:2.0
sci-chemistry/mpqc
- >=sci-libs/libghemical-3.0.0
- >=x11-libs/liboglappth-1.0.0
+ >=sci-libs/libghemical-3.0.0:=
+ >=x11-libs/liboglappth-1.0.0:=
virtual/opengl
- x11-libs/pango
+ x11-libs/pango:0=
x11-libs/gtk+:2
- x11-libs/gtkglext
+ x11-libs/gtkglext:0=
openbabel? ( sci-chemistry/openbabel )"
DEPEND="${RDEPEND}
virtual/pkgconfig"
-PATCHES=( "${FILESDIR}"/2.99.2-docs.patch )
+PATCHES=(
+ "${FILESDIR}"/2.99.2-docs.patch
+ "${FILESDIR}"/3.0.0-fix-gcc9.patch
+)
src_prepare() {
default
@@ -39,11 +42,8 @@ src_configure() {
# With amd64, if you want gamess I recommend adding gamess and gtk-gamess to package.provided for now.
# Change the built-in help browser.
- if use seamonkey ; then
- sed -i -e 's|mozilla|seamonkey|g' src/gtk_app.cpp || die "sed failed for seamonkey!"
- else
- sed -i -e 's|mozilla|firefox|g' src/gtk_app.cpp || die "sed failed for firefox!"
- fi
+ sed -e "s|mozilla|$(usex seamonkey seamonkey firefox)|g" \
+ -i src/gtk_app.cpp || die "sed failed for $(usex seamonkey seamonkey firefox)!"
econf \
$(use_enable openbabel) \
@@ -51,6 +51,6 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${D}" install
- make_desktop_entry /usr/bin/ghemical Ghemical /usr/share/ghemical/${PV}/pixmaps/ghemical.png
+ default
+ make_desktop_entry ghemical Ghemical /usr/share/ghemical/${PV}/pixmaps/ghemical.png
}