summaryrefslogtreecommitdiff
path: root/sci-chemistry
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-18 11:19:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-18 11:19:06 +0100
commit5142c1d68ca78d43985ab47bc3ae7c19954a9945 (patch)
tree182748d0a64002a4e471e2e857128fa71f401903 /sci-chemistry
parent95a97c3f0b0d048aaf9e183702a1d06b30415b35 (diff)
gentoo auto-resync : 18:09:2022 - 11:19:06
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/Manifest.gzbin10191 -> 10191 bytes
-rw-r--r--sci-chemistry/chemex/Manifest2
-rw-r--r--sci-chemistry/chemex/chemex-2022.0.1.ebuild48
3 files changed, 50 insertions, 0 deletions
diff --git a/sci-chemistry/Manifest.gz b/sci-chemistry/Manifest.gz
index fd097313d879..34e31440f73b 100644
--- a/sci-chemistry/Manifest.gz
+++ b/sci-chemistry/Manifest.gz
Binary files differ
diff --git a/sci-chemistry/chemex/Manifest b/sci-chemistry/chemex/Manifest
index 3d67d625423c..9df3200797ae 100644
--- a/sci-chemistry/chemex/Manifest
+++ b/sci-chemistry/chemex/Manifest
@@ -1,3 +1,5 @@
DIST chemex-2021.4.0_p6.tar.gz 2395324 BLAKE2B adb08fdebe816b66359c8a567d7f7a4600715015e6f9b86b568cb8e3cd5e66b040895c09688a956cedd398a7c56a6d3a73d77f647a2f4e83280a91879a6184d0 SHA512 7d20ae73a2cf52f9d21b875cd661cefc14ce36ff603402e5dacad3e21bcb0bdb28f8f111414691b99f93196a971215d0beec3fff07535d3d781b4e7bb6782c52
+DIST chemex-2022.0.1.tar.gz 2840066 BLAKE2B 05e3cd048a996b85e9a88297180bdd6e0b972619f5ac734d10a5744e7ab28fa2080bf6d6b53b69d04192ca420a24014f7eded0668ec716218ca4cc4877875ec9 SHA512 c2b49d83d618e69e43737b9d8b6a16de4fc46b481b2c65aaa4110bf425cd71bd5347240e7336855ec294ea126dd036262535645fca93ae352616f1a71b11e698
EBUILD chemex-2021.4.0_p6.ebuild 1292 BLAKE2B 2264c354a978cb6e2cb77431aa491d18cb96883aa03dc06781265060b13045f26a6181a6ab19bbc81cf84dcac39ad6b5899af067917066d1db246a3a44229e87 SHA512 dbb95167c9615e44627387d5a599520bff593739e9406089f8daea0355fa309f98e27d0c297c8241db5dfe8673adfa92bf055109ac51aa83f29856a8b0e17826
+EBUILD chemex-2022.0.1.ebuild 1399 BLAKE2B 2b70699cf42eef7c72af2fbce5f5b9ad9a7569465c7f90e4523af0819ae413e57df676197acaa1337a95b072dbb45d63da8b1e7590772bd8f55c9994845e5466 SHA512 22ea8bdbfa85dc3dcf948ce62580f212d17ce7f0ac691d55d9afc123892c4ff6ccbe7b3335cc04a7f53718de6b925ee8ce3fe0e8d766b3c15c08ef75fcc86189
MISC metadata.xml 217 BLAKE2B f8189b02494f180dac078dcd5c275d3c795f20f360f8b172c66065a2d937e396b24b8631bba4cd8567d60285ce89fc77b9539f2233bf33899c820613c48c33ba SHA512 f0c9e5b3d281fecd21b1e23a6f44c94c1c0b3220de46a177d35932111b7f1ab4399061c42833ac1ee9bd0324b139fc8db66e0d2890224d607bd3be38ae469be9
diff --git a/sci-chemistry/chemex/chemex-2022.0.1.ebuild b/sci-chemistry/chemex/chemex-2022.0.1.ebuild
new file mode 100644
index 000000000000..073cdcbe2dac
--- /dev/null
+++ b/sci-chemistry/chemex/chemex-2022.0.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+DISTUTILS_SINGLE_IMPL="yes"
+PYTHON_COMPAT=( python3_{9..10} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+
+inherit distutils-r1
+
+DESCRIPTION="Program to fit chemical exchange induced shift and relaxation data"
+HOMEPAGE="https://github.com/gbouvignies/chemex"
+SRC_URI="https://github.com/gbouvignies/ChemEx/archive/refs/tags/v${PV/_p/-dev}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+IUSE="test"
+
+#RESTRICT="!test? ( test )"
+# FIXME: Restrict until tests are readded https://github.com/gbouvignies/ChemEx/issues/51
+RESTRICT="test"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/asteval-0.9.25[${PYTHON_USEDEP}]
+ >=dev-python/cachetools-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/lmfit-1.0.3[${PYTHON_USEDEP}]
+ >=dev-python/matplotlib-3.5.3[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.23.3[${PYTHON_USEDEP}]
+ >=dev-python/pydantic-1.10.2[${PYTHON_USEDEP}]
+ >=dev-python/rapidfuzz-2.8.0[${PYTHON_USEDEP}]
+ >=dev-python/rich-12.5.1[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.9.1[${PYTHON_USEDEP}]
+ >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
+ ')
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
+
+S="${WORKDIR}/ChemEx-${PV/_p/-dev}"
+
+src_prepare() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION="${PV}"
+ distutils-r1_src_prepare
+}