summaryrefslogtreecommitdiff
path: root/sci-chemistry
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-10-01 20:54:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-10-01 20:54:53 +0100
commit391b5b359a346aff490103da7dddc85047f83830 (patch)
tree29eea460a0bd7e1ff21d43b9d6df9af4d8a175e1 /sci-chemistry
parentc719fdcee603a5a706a45d10cb598762d56a727d (diff)
gentoo resync : 01.10.2021
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/Manifest.gzbin10830 -> 10832 bytes
-rw-r--r--sci-chemistry/chemex/Manifest2
-rw-r--r--sci-chemistry/chemex/chemex-2021.4.0_p2.ebuild43
3 files changed, 45 insertions, 0 deletions
diff --git a/sci-chemistry/Manifest.gz b/sci-chemistry/Manifest.gz
index efa4ea389a2a..5a44c21e64d0 100644
--- a/sci-chemistry/Manifest.gz
+++ b/sci-chemistry/Manifest.gz
Binary files differ
diff --git a/sci-chemistry/chemex/Manifest b/sci-chemistry/chemex/Manifest
index 4b31f32b5258..e4c35fa87574 100644
--- a/sci-chemistry/chemex/Manifest
+++ b/sci-chemistry/chemex/Manifest
@@ -1,3 +1,5 @@
DIST chemex-2018.10.3.tar.gz 546696 BLAKE2B d283cfb94118686f1974780249641e0ea6f86cdb854c4a256897e361a300a94506813a5035ee2f300fca13263e8452b77e7a0817436cbd620ba16d801a541af7 SHA512 784bd03b354724d6aa52d663c6f661f865d4ef7ca345573bc8aae9ef63e5dbb3e65abba364de3ff441b78adfa588344c718809c5880b3fc70d8ed24be06a0826
+DIST chemex-2021.4.0_p2.tar.gz 2384471 BLAKE2B 1eb609c4e4ad9ac0f7cac8ab523e72e8ab9c12d40671fd598cd26b8de2a3d6e68dfdcaee9202521fc583068f591377842b3e7b9f0e1f95e6cba8da9b0c6d63a4 SHA512 568072eaf0d1c666de2aedacc50cd98da15631e0ef15ba60414be671ac97a50967e5b4d6d00340b1263f730b3a803ccc8995fbb86cfc47517b9521c9920641c8
EBUILD chemex-2018.10.3.ebuild 1007 BLAKE2B 9b231e246e6401185db827f7cc808be6c1955a569f00b156b7b3ef43645cb51596865551df05c176bfa916128dd40953d933a54e7c10548c37fb08acbb8fb62c SHA512 82f4719818573b63cbdc8d7ffac0968204357f705655e327df0866ea6296c03fb38b8b05133b301fb88fdbaec693814c55c6fea935f7dc4a507eeee5fe0493f3
+EBUILD chemex-2021.4.0_p2.ebuild 1184 BLAKE2B a7ab020a416e46f232ce5b9bd140d7af6c925b8e0da5b2dfe629e7f50533692700c183cf1068be6fa0cee7cd3141eee6f684a936fea9b034f0a68b8f0f080358 SHA512 06067c09038bcc2629ac272a5005acd1f11fce5014ceb2fb9eb8fa9f7c6d900d9ccdc07a90e54fde11e5399baed2b12def1facdfaf7e929e603e6c334b463a04
MISC metadata.xml 217 BLAKE2B f8189b02494f180dac078dcd5c275d3c795f20f360f8b172c66065a2d937e396b24b8631bba4cd8567d60285ce89fc77b9539f2233bf33899c820613c48c33ba SHA512 f0c9e5b3d281fecd21b1e23a6f44c94c1c0b3220de46a177d35932111b7f1ab4399061c42833ac1ee9bd0324b139fc8db66e0d2890224d607bd3be38ae469be9
diff --git a/sci-chemistry/chemex/chemex-2021.4.0_p2.ebuild b/sci-chemistry/chemex/chemex-2021.4.0_p2.ebuild
new file mode 100644
index 000000000000..8b5e04b8b082
--- /dev/null
+++ b/sci-chemistry/chemex/chemex-2021.4.0_p2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+DISTUTILS_SINGLE_IMPL="yes"
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+
+inherit distutils-r1
+
+DESCRIPTION="Program to fit chemical exchange induced shift and relaxation data"
+HOMEPAGE="https://github.com/gbouvignies/chemex"
+SRC_URI="https://github.com/gbouvignies/chemex/archive/${PV/_p/-dev}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/asteval-0.9.11[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/lmfit-1.0.2[${PYTHON_USEDEP}]
+ >=dev-python/matplotlib-3.4.2[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.21.0[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.7.0[${PYTHON_USEDEP}]
+ >=dev-python/tomlkit-0.7.2[${PYTHON_USEDEP}]
+ >=dev-python/tqdm-4.61.1[${PYTHON_USEDEP}]
+ ')
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
+
+S="${WORKDIR}/ChemEx-${PV/_p/-dev}"
+
+src_prepare() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION="${PV}"
+ distutils-r1_src_prepare
+}