summaryrefslogtreecommitdiff
path: root/sci-chemistry
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /sci-chemistry
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/MDAnalysis/MDAnalysis-2.0.0.ebuild37
-rw-r--r--sci-chemistry/MDAnalysis/Manifest2
-rw-r--r--sci-chemistry/Manifest.gzbin11019 -> 11021 bytes
-rw-r--r--sci-chemistry/mdtraj/Manifest2
-rw-r--r--sci-chemistry/mdtraj/mdtraj-1.9.7.ebuild42
5 files changed, 83 insertions, 0 deletions
diff --git a/sci-chemistry/MDAnalysis/MDAnalysis-2.0.0.ebuild b/sci-chemistry/MDAnalysis/MDAnalysis-2.0.0.ebuild
new file mode 100644
index 000000000000..aee4e82b683e
--- /dev/null
+++ b/sci-chemistry/MDAnalysis/MDAnalysis-2.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A python library to analyze and manipulate molecular dynamics trajectories"
+HOMEPAGE="https://www.mdanalysis.org"
+SRC_URI="mirror://pypi/M/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+# TODO: fix this
+# ImportError: MDAnalysis not installed properly. This can happen if your C extensions have not been built.
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/numpy-1.16.0[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.0.0[${PYTHON_USEDEP}]
+ >=sci-biology/biopython-1.71[${PYTHON_USEDEP}]
+ >=dev-python/networkx-1.0[${PYTHON_USEDEP}]
+ >=dev-python/GridDataFormats-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/joblib-0.12[${PYTHON_USEDEP}]
+ >=dev-python/matplotlib-1.5.1[${PYTHON_USEDEP}]
+ >=dev-python/mmtf-python-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/tqdm-4.43.0[${PYTHON_USEDEP}]
+ >=dev-python/gsd-1.9.3[${PYTHON_USEDEP}]
+ dev-python/threadpoolctl[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}"
+
+distutils_enable_tests nose
diff --git a/sci-chemistry/MDAnalysis/Manifest b/sci-chemistry/MDAnalysis/Manifest
index a308ba17a972..58c58ab114ef 100644
--- a/sci-chemistry/MDAnalysis/Manifest
+++ b/sci-chemistry/MDAnalysis/Manifest
@@ -1,3 +1,5 @@
DIST MDAnalysis-1.0.0.tar.gz 19552874 BLAKE2B dab625a898d71a67a37ac5b58eb23ded9487f475e3c76f6c335a0ed5b32a43785d0473d089fcfc56c07263d82248bf5ee7b50c513441b10fc97f97b49411cc5f SHA512 4a001f45695308dd5f296bd2850d5d585c065e6b0f55efca65d91e452d78c85f13fd614eca0176a8d330e14a1c9e8ccbb919c3d4ae995b1945d09dc3ad687195
+DIST MDAnalysis-2.0.0.tar.gz 3436654 BLAKE2B b29734dd61bfa1e4e1d6ead0eb9a2d00869d1adce18edf95b9368bdcc16b0d71d0d6536a7df48787034a623bf52585e1636842dcaaa9dde08a69576868c1657b SHA512 037eb3c709b9ddbdb2ba9b26a6632ff99a95331c3968176573076e4e208c8644c3ea262e1e9880f185eb080ff90180d887444cab0dfbfad04fc254d87f1ff986
EBUILD MDAnalysis-1.0.0.ebuild 1115 BLAKE2B ab8aae2678843840557bfde1866890cbe671cab0f670d1dc253523d070e231b44268d803b8c3c03648d8536f2cf6a734affc8fbcbb9ae62956deb60d1254b19c SHA512 7099a21fcfef94938f5c2b7bc590fbebadeb94ccc35f73f36abc470038c7aa45ea5563390eb09db9162f2060a57ebba69a2c984c2c8b560247f03acb8b446c4c
+EBUILD MDAnalysis-2.0.0.ebuild 1128 BLAKE2B e51e404e7254e614abab6856948939b5673d13940cf60d5e6dc77d08e97a401d4af00e56cf90ed9bbfca0acd319f9d328a4479c222fc5ccc0a5ddb8e41788f56 SHA512 6029cd5e527333da9aa7cb52560436eaa7424a87a3c22499f6aeb99b402525dd87a43ae7487a669df67890942f7bfd4d6d561366d002e2c0138e3f2e35f02601
MISC metadata.xml 497 BLAKE2B ddd8c6379dfe6b6fe33160d31bda254774e0c8eb5f862cc51560097efc5c273fa972388c6fe8fb1bbedc11ab125a5487bb1d19002489be967fa3e8e209d7cc81 SHA512 03c1eb9bef1bc10d600169b221c65c87794f8b9bf8d0efb1dc6ddaa61a09d665722ed7d32087e3137b36aa7256b76371b9ce2cc92b34b1ed7d1c78ede6550287
diff --git a/sci-chemistry/Manifest.gz b/sci-chemistry/Manifest.gz
index 44e11544063e..d1dabc99537d 100644
--- a/sci-chemistry/Manifest.gz
+++ b/sci-chemistry/Manifest.gz
Binary files differ
diff --git a/sci-chemistry/mdtraj/Manifest b/sci-chemistry/mdtraj/Manifest
index f63d847c79c7..61bcdcf2433a 100644
--- a/sci-chemistry/mdtraj/Manifest
+++ b/sci-chemistry/mdtraj/Manifest
@@ -1,3 +1,5 @@
DIST mdtraj-1.9.4.tar.gz 2133297 BLAKE2B c1507246bf0c8d7f6753f3d505f940e6f2f001361e42f10c9775647a7e6b58edf2d3953a8e48932f6bf9ad90b27e1baf30df6a7c1a590e49a860175822a25360 SHA512 55f67546db20ce63da3af2231df459e9983e15a65da960784613f746dcce820fe6b0deffbb21b528e93fc6cf674dc7a25ee11110894d2a89e5504e20d200ca38
+DIST mdtraj-1.9.7.tar.gz 2087085 BLAKE2B 430b42eddee0be8beba47994efd16515727970ac7acb36007c9b153cdb474551e5ea228f78a194fa9672d5b169753a9db3c090412bf749b3f1e9323bad9f52de SHA512 5dc9d474909a160e0b1d7989325e8190d1c593087f0130854094eb9c49bc00fd631ea19142d396d49aa7a3dadddaf535b5e811f7574ffff36f0cd22f14691067
EBUILD mdtraj-1.9.4.ebuild 1040 BLAKE2B ae63c3005eb964eb055b110db6da88f5b488e2c4ed4caa566fe2d4557b69d229e21b7e493f2e2360d1f8dea4d4237e511e7a8d6b5827302b7ed3ebc33d5820ba SHA512 f3eae0d7bfc5d59ab6b3b2d9ff9d81c406e15f1d5dc7249382a928b4d378b722f758890d28e112f5659de4ba15d0a9eba4a8488610ccaf1d43885b5a96eddd07
+EBUILD mdtraj-1.9.7.ebuild 1129 BLAKE2B 365d4270b3b932118db8333682e87b17c638b1a6e71a36ae51518a9878af45803c7d66ae761b0b2003fee5de786aeb7f74934803d5896e744a7e4bbec72103c8 SHA512 38953d4025116c2c4674d0d30a812b2aa03abca91756949eb5dde4a689049dd7855fe0ee35d775e935f24ec4489245969815e31061ee602af2d702bd54b25f43
MISC metadata.xml 260 BLAKE2B 14d3d7872b9a3cb341301daf85c6b037c567163317516100d5af08e7ae02970252f210e90118d5df9e0cf6e0b3560add3a7894d379609b864e60dfdda3036423 SHA512 973385fccdcb0ccc36e00a09dc85204cf15081b8b61bc20e02d7d1311cb05af4927f01aac36ec93275158f5b990874ca03ab7d381cf6ee6f5e30bc4926d2f045
diff --git a/sci-chemistry/mdtraj/mdtraj-1.9.7.ebuild b/sci-chemistry/mdtraj/mdtraj-1.9.7.ebuild
new file mode 100644
index 000000000000..0dcd8ceb970c
--- /dev/null
+++ b/sci-chemistry/mdtraj/mdtraj-1.9.7.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read, write and analyze MD trajectories with only a few lines of Python code"
+HOMEPAGE="http://mdtraj.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/astunparse[${PYTHON_USEDEP}]
+ dev-python/astor[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/pytables[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/jupyter_client[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ sci-libs/scikit-learn[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare_all() {
+ sed -e "s:re.match('build.*(mdtraj.*)', output_dir).group(1):'.':g" \
+ -i basesetup.py || die
+ distutils-r1_python_prepare_all
+}