summaryrefslogtreecommitdiff
path: root/sci-chemistry/votca/votca-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /sci-chemistry/votca/votca-9999.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'sci-chemistry/votca/votca-9999.ebuild')
-rw-r--r--sci-chemistry/votca/votca-9999.ebuild16
1 files changed, 13 insertions, 3 deletions
diff --git a/sci-chemistry/votca/votca-9999.ebuild b/sci-chemistry/votca/votca-9999.ebuild
index 6a1ae090460b..0962e065f91d 100644
--- a/sci-chemistry/votca/votca-9999.ebuild
+++ b/sci-chemistry/votca/votca-9999.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+PYTHON_COMPAT=( python3_{8..10} )
-inherit bash-completion-r1 cmake
+inherit bash-completion-r1 cmake python-single-r1
if [[ ${PV} == *9999 ]]; then
inherit git-r3
@@ -25,19 +26,21 @@ HOMEPAGE="https://www.votca.org/"
LICENSE="Apache-2.0"
SLOT="0"
IUSE="+gromacs test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RESTRICT="!test? ( test )"
RDEPEND="
!sci-libs/votca-tools
!sci-chemistry/votca-csg
!sci-chemistry/votca-xtp
+ ${PYTHON_DEPS}
app-shells/bash:*
>=dev-cpp/eigen-3.3
dev-libs/boost:=
dev-libs/expat
sci-libs/fftw:3.0=
dev-lang/perl
- gromacs? ( sci-chemistry/gromacs:= )
+ gromacs? ( sci-chemistry/gromacs:=[gmxapi-legacy(+)] )
sci-libs/hdf5[cxx]
sci-libs/libxc
sci-libs/libint:2
@@ -47,6 +50,13 @@ BDEPEND="virtual/pkgconfig"
DOCS=( README.rst NOTICE.rst CHANGELOG.rst )
+src_prepare() {
+ # espressopp was removed from gentoo
+ rm -r ./csg-tutorials/spce/ibi_espressopp || die
+ python_fix_shebang .
+ cmake_src_prepare
+}
+
src_configure() {
local mycmakeargs=(
-DENABLE_TESTING=$(usex test)