summaryrefslogtreecommitdiff
path: root/sci-chemistry/votca-csgapps/votca-csgapps-1.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /sci-chemistry/votca-csgapps/votca-csgapps-1.6.ebuild
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'sci-chemistry/votca-csgapps/votca-csgapps-1.6.ebuild')
-rw-r--r--sci-chemistry/votca-csgapps/votca-csgapps-1.6.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sci-chemistry/votca-csgapps/votca-csgapps-1.6.ebuild b/sci-chemistry/votca-csgapps/votca-csgapps-1.6.ebuild
new file mode 100644
index 000000000000..463cba8e0e38
--- /dev/null
+++ b/sci-chemistry/votca-csgapps/votca-csgapps-1.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_MAKEFILE_GENERATOR="ninja"
+
+inherit cmake-utils
+
+if [ "${PV}" != "9999" ]; then
+ SRC_URI="https://github.com/${PN/-//}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
+ S="${WORKDIR}/${P#votca-}"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN/-//}.git"
+ KEYWORDS=""
+fi
+
+DESCRIPTION="Extra applications for votca-csg"
+HOMEPAGE="http://www.votca.org"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-cpp/eigen-3.3
+ ~sci-chemistry/${PN%apps}-${PV}"
+
+DEPEND="${RDEPEND}"
+
+DOCS=( README.md )