summaryrefslogtreecommitdiff
path: root/sci-chemistry/pymol
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /sci-chemistry/pymol
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'sci-chemistry/pymol')
-rw-r--r--sci-chemistry/pymol/Manifest2
-rw-r--r--sci-chemistry/pymol/pymol-2.5.0.ebuild113
2 files changed, 115 insertions, 0 deletions
diff --git a/sci-chemistry/pymol/Manifest b/sci-chemistry/pymol/Manifest
index 3a4f34fe7be6..b87dd02aeb4c 100644
--- a/sci-chemistry/pymol/Manifest
+++ b/sci-chemistry/pymol/Manifest
@@ -1,5 +1,7 @@
AUX pymol-2.4.0-fix_bug119.patch 1078 BLAKE2B 78ed2953dcb20197de0a06c2c9c4c9f59be79cecbedfc910e7e530e5ad58452aab0da8540f4a4737023a3d56eba51530dfb1f2dfd59cdaf91192b6cd90383610 SHA512 ff4adb6de9c03f165e062698fe6359ab187ccf7cccba05c2e90363b44a53e5d4371e4942f21f26dd89ca8d1b7f9865f48e18f7d9a0214a5c6f453bee0ab49bb7
DIST pymol-1.8.4.0.png.xz 19528 BLAKE2B f3d23d4cedca3d8bb96b20646a548da4be570697e3346a11b01c5c3599b536ba4697be08472dfa8a4f6533167defc1a37a1de332931a73857319cb28fd42cd2b SHA512 40bb0d3f226476f6e047b5361956aad955232a97641474765eaa5204f0539aee3810e0266213618a45364f9f31f6eb18380b17e0c79f64065f7b62a9016caa7c
DIST pymol-2.4.0.tar.gz 10552539 BLAKE2B 34e31dce99c1e838b00389c3d7c29657534dd037349769bd6c8cb17028cfaaa856d5729760d3768fd43f61086cac30749a864fb4156c14eda07f9027430f0523 SHA512 2b19294197d58a808bf7bb7fa9f829c2ec582ba47a4380783a2b1eedda2ce4118cd398e01885db8c449e7fd5e4c08a1c40508e679ef42d8e183a6a52b031c02a
+DIST pymol-2.5.0.tar.gz 10470268 BLAKE2B ad3721432001053be93afe755f531ae47348213b042e84dae33cd79580428c9ac3d00629afa0222e4081807dc80e2dd69c3963a457666b5975b6263b988d02d9 SHA512 19f21b8f735fda5314abf202d56f3c81c7251bf6ef0df73ccee534d9c08035f4ef6155ffb68e09d7717a0fb5ba7289bbfa440691bea4cec0de7199c9e858ea91
EBUILD pymol-2.4.0-r1.ebuild 3106 BLAKE2B ca3e75218437da7eecb7f6cd4feb737386cfed4a002121659cf4147f141fc380dac3d3c18b9a0ea1dd3d614dd05df391545b3cad65905d1d7a52beace3c54b97 SHA512 cd03c112d9210fa24206de44e55dc8ed1bfde7a51c4278902355f01fd5d5846fb12afb3318796c9e4f57b1e5e7cae58812cf81267d9c7f776c5a35f6a0eb3082
+EBUILD pymol-2.5.0.ebuild 3092 BLAKE2B 911add60f71e41659a1bf0754fa1e263ed3b8bb1222b83401ed192db2c4679629b41ec4476e552e23d0c7f85063adcc4380be16cd920a50ce1ba5ef7ee4da1c1 SHA512 2326993a095b2dda7de7b0049d192a57c5a4e28cd323629344e8723090c621fe10b1e767c50c50a3941d2241bb06a7c393210c0093bf0d5810e20419737ca30e
MISC metadata.xml 439 BLAKE2B 68df7dfc8ca3d4d4b18b419532bade69491f2e9362f10ae2397c804132b7fc9cd08dcf9703c0a89c44588c570e0c0c1bb9bffb7394d51faf1283142dbc5f70b3 SHA512 f5a3eded9b12fa715ba2e6e10b41c75d9bd823ca0dd40acbffc3f5bfc4b36c687f720b1a4e119b4540a31faf849985778cbd72b0b2cd35af8c52ca0f808d71e4
diff --git a/sci-chemistry/pymol/pymol-2.5.0.ebuild b/sci-chemistry/pymol/pymol-2.5.0.ebuild
new file mode 100644
index 000000000000..a7fc5fdc127c
--- /dev/null
+++ b/sci-chemistry/pymol/pymol-2.5.0.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit desktop optfeature flag-o-matic xdg distutils-r1
+
+DESCRIPTION="A Python-extensible molecular graphics system"
+HOMEPAGE="https://www.pymol.org/"
+SRC_URI="
+ https://dev.gentoo.org/~pacho/${PN}/${PN}-1.8.4.0.png.xz
+ https://github.com/schrodinger/pymol-open-source/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ "
+RESTRICT="mirror"
+LICENSE="PSF-2.2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="+netcdf web"
+
+DEPEND="
+ dev-libs/msgpack[cxx]
+ dev-libs/mmtf-cpp
+ dev-python/pyopengl[${PYTHON_USEDEP}]
+ dev-python/PyQt5[opengl,${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pmw[${PYTHON_USEDEP}]
+ media-libs/freetype:2
+ media-libs/glew:0=
+ media-libs/glm
+ media-libs/libpng:0=
+ media-video/mpeg-tools
+ sys-libs/zlib
+ netcdf? ( sci-libs/netcdf:0= )
+"
+RDEPEND="${DEPEND}
+ sci-chemistry/chemical-mime-data
+"
+
+S="${WORKDIR}"/${PN}-open-source-${PV}
+
+python_prepare_all() {
+ sed \
+ -e "s:\"/usr:\"${EPREFIX}/usr:g" \
+ -e "/ext_comp_args.*+=/s:\[.*\]$:\[\]:g" \
+ -i setup.py || die
+
+ sed \
+ -e "s:/opt/local:${EPREFIX}/usr:g" \
+ -e '/ext_comp_args/s:\[.*\]:[]:g' \
+ -i setup.py || die
+ sed \
+ -e "s:\['msgpackc'\]:\['msgpack'\]:g" \
+ -i setup.py || die
+
+ append-cxxflags -std=c++0x
+
+ use !netcdf && mydistutilsargs=( --no-vmd-plugins )
+
+ distutils-r1_python_prepare_all
+}
+
+python_install() {
+ distutils-r1_python_install \
+ --pymol-path="${EPREFIX}/usr/share/pymol"
+
+# File is not created as apbs was dropped from the tree
+# https://bugs.gentoo.org/790629
+# sed \
+# -e '1d' \
+# -e "/APBS_BINARY_LOCATION/s:None:\"${EPREFIX}/usr/bin/apbs\":g" \
+# -e "/APBS_PSIZE_LOCATION/s:None:\"$(python_get_sitedir)/pdb2pqr/src/\":g" \
+# -e "/APBS_PDB2PQR_LOCATION/s:None:\"$(python_get_sitedir)/pdb2pqr/\":g" \
+# -i "${D}/$(python_get_sitedir)"/pmg_tk/startup/apbs_tools.py || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ sed \
+ -e '1i#!/usr/bin/env python' \
+ "${D}/$(python_get_sitedir)"/pymol/__init__.py > "${T}"/${PN} || die
+
+ python_foreach_impl python_doscript "${T}"/${PN}
+
+ # These environment variables should not go in the wrapper script, or else
+ # it will be impossible to use the PyMOL libraries from Python.
+ cat >> "${T}"/20pymol <<- EOF || die
+ PYMOL_PATH="${EPREFIX}/usr/share/pymol"
+ PYMOL_DATA="${EPREFIX}/usr/share/pymol/data"
+ PYMOL_SCRIPTS="${EPREFIX}/usr/share/pymol/scripts"
+ EOF
+
+ doenvd "${T}"/20pymol
+
+ newicon "${WORKDIR}"/${PN}-1.8.4.0.png ${PN}.png
+ make_desktop_entry ${PN} PyMol ${PN} \
+ "Graphics;Education;Science;Chemistry;" \
+ "MimeType=chemical/x-pdb;chemical/x-mdl-molfile;chemical/x-mol2;chemical/seq-aa-fasta;chemical/seq-na-fasta;chemical/x-xyz;chemical/x-mdl-sdf;"
+
+ if ! use web; then
+ rm -rf "${D}/$(python_get_sitedir)/web" || die
+ fi
+
+ rm -f "${ED}"/usr/share/${PN}/LICENSE || die
+}
+
+#pkg_postinst() {
+# xdg_pkg_postinst
+# optfeature "Electrostatic calculations" sci-chemistry/apbs sci-chemistry/pdb2pqr
+#}