summaryrefslogtreecommitdiff
path: root/sci-chemistry/pymol
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-29 16:53:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-03-29 16:53:27 +0100
commit1173ad5704ce725916e0c332416aff326d850d06 (patch)
treed48d60977ce19864893dfb2222bf2982ffb4262a /sci-chemistry/pymol
parent8c364c784966be1700ea39ae45028f3e9be9cae0 (diff)
gentoo resync : 29.03.2018
Diffstat (limited to 'sci-chemistry/pymol')
-rw-r--r--sci-chemistry/pymol/Manifest2
-rw-r--r--sci-chemistry/pymol/pymol-2.1.0.ebuild113
2 files changed, 115 insertions, 0 deletions
diff --git a/sci-chemistry/pymol/Manifest b/sci-chemistry/pymol/Manifest
index bc83c2581583..caab27d47ddf 100644
--- a/sci-chemistry/pymol/Manifest
+++ b/sci-chemistry/pymol/Manifest
@@ -1,6 +1,8 @@
DIST pymol-1.8.4.0.png.xz 19528 BLAKE2B f3d23d4cedca3d8bb96b20646a548da4be570697e3346a11b01c5c3599b536ba4697be08472dfa8a4f6533167defc1a37a1de332931a73857319cb28fd42cd2b SHA512 40bb0d3f226476f6e047b5361956aad955232a97641474765eaa5204f0539aee3810e0266213618a45364f9f31f6eb18380b17e0c79f64065f7b62a9016caa7c
DIST pymol-v1.8.4.0.tar.bz2 8717344 BLAKE2B a4cfb95eb40a3cd3da5b8cfd4acac7255997f9a3e49ef7e7e1d4c13f36e4aace462a054c326bbaadbc99f22286be878a6d5c518149760b5c939ce9362d4b8cc3 SHA512 73a810adfc31adaf0f3fa25512084882c87b0782c8af716ac0203a5b5b7f0b9fedfbce3d129bffef7b52044e92b0542e683966b2acf961c4dac17fbba72dd7fe
DIST pymol-v1.8.6.0.tar.bz2 8717164 BLAKE2B ddcabb81e15b2409ee551900ed09daaf681c7ef0e196eecea36773c131586f6379cd41c50bfa9df8f396ddb1a5da761e8b3409e9656a8f6ac7a87818f4375895 SHA512 bd08e6890382af1503d6af16b27b43af09b372a1229cc9d8e2de311873918b5e7b06e8a2365ce73a5f52cb31ac795f5d91b2ae6ef62890d9c2bf0ea25f856658
+DIST pymol-v2.1.0.tar.bz2 8779083 BLAKE2B 819846a9963ddf3953f53e29a8396ed104dbdafc55fe39ad91363366c7647af3ad833704aff3d4c11f39829545500e00bb18916b6963de4b986423adf700845c SHA512 67175c0668a13826febcb73f7c62a43cfa03a7f86bb80113d52fb337e7d29008684c03163fc06338c4d68edd9246ffcf63aec1ee3110ae91c8a71ef24ab7b605
EBUILD pymol-1.8.4.0-r1.ebuild 3009 BLAKE2B a076dd994e90f886e65cbb5b3f976e75eacd0a6f153c1b9417c476b53d2169495b08b6d3361ab5fcb55102a2e93a86b7f0ac6d0f25bca947f6b13f52dadde6bd SHA512 c696905b2e28c28249bf458e37dfe05237b307e3af1727fe17ebfd6a818322e6f9dc947d720df7ee29d694fe6501791f3a2f6fdc554a8e7dd43adf9727c8ece8
EBUILD pymol-1.8.6.0.ebuild 3052 BLAKE2B ae4d3949ad0361672356ec1178b980b5e4b036c305cfd9a9db9a47664800ae7ec2c00c7b91f1e8596c2e27c190e4c2329dddb2d4b14bf80f6362db12d45bd037 SHA512 f065ffbdade1cc02734a35f6f785670417e113299ec6b92d1b9c7ffdaaeba0ca5353dcc0ae09e206eb1a83474487db89234ab22c65c0a75e768e7b4cb5982f86
+EBUILD pymol-2.1.0.ebuild 3113 BLAKE2B 2cdc4bc06a8a5be05ff6671291c230e0f337a3f13c3ee3daac07d79ed9d16b876aa46c83a83314ef2f81a8c3af8bc55b18f2ed27af433a5290cf029ac0210f0d SHA512 94697712a0476c9f98e188494d921d91d8b768cd04fea3158e5cec6dcf535e4762f8b68ec71258f8597cc0439ffa218c1cfbc0f674d4bba51e7cf9300559a438
MISC metadata.xml 439 BLAKE2B 68df7dfc8ca3d4d4b18b419532bade69491f2e9362f10ae2397c804132b7fc9cd08dcf9703c0a89c44588c570e0c0c1bb9bffb7394d51faf1283142dbc5f70b3 SHA512 f5a3eded9b12fa715ba2e6e10b41c75d9bd823ca0dd40acbffc3f5bfc4b36c687f720b1a4e119b4540a31faf849985778cbd72b0b2cd35af8c52ca0f808d71e4
diff --git a/sci-chemistry/pymol/pymol-2.1.0.ebuild b/sci-chemistry/pymol/pymol-2.1.0.ebuild
new file mode 100644
index 000000000000..f29f29694f28
--- /dev/null
+++ b/sci-chemistry/pymol/pymol-2.1.0.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="tk"
+
+inherit distutils-r1 eutils xdg-utils flag-o-matic versionator
+
+DESCRIPTION="A Python-extensible molecular graphics system"
+HOMEPAGE="http://www.pymol.org/"
+SRC_URI="
+ https://dev.gentoo.org/~jlec/distfiles/${PN}-1.8.4.0.png.xz
+ mirror://sourceforge/project/${PN}/${PN}/$(get_version_component_range 1)/${PN}-v${PV}.tar.bz2
+ "
+# git archive -v --prefix=${P}/ master -o ${P}.tar.xz
+RESTRICT="mirror"
+LICENSE="PSF-2.2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="web"
+
+DEPEND="
+ dev-libs/msgpack[cxx]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pyopengl[${PYTHON_USEDEP}]
+ media-libs/freeglut
+ media-libs/freetype:2
+ media-libs/glew:0=
+ media-libs/libpng:0=
+ media-video/mpeg-tools
+ sys-libs/zlib
+ virtual/python-pmw[${PYTHON_USEDEP}]
+ !sci-chemistry/pymol-apbs-plugin[${PYTHON_USEDEP}]
+ web? ( !dev-python/webpy[${PYTHON_USEDEP}] )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${PN}
+
+python_prepare_all() {
+ sed \
+ -e "s:\"/usr:\"${EPREFIX}/usr:g" \
+ -e "/ext_comp_args.*+=/s:\[.*\]$:\[\]:g" \
+ -e "/import/s:argparse:argparseX:g" \
+ -i setup.py || die
+
+ sed \
+ -e "s:/opt/local:${EPREFIX}/usr:g" \
+ -e '/ext_comp_args/s:\[.*\]:[]:g' \
+ -i setup.py || die
+ sed \
+ -e "s:\['msgpackc'\]:\['msgpack'\]:g" \
+ -i setup.py || die
+
+ append-cxxflags -std=c++0x
+
+ distutils-r1_python_prepare_all
+}
+
+python_install() {
+ distutils-r1_python_install \
+ --pymol-path="${EPREFIX}/usr/share/pymol"
+
+ sed \
+ -e '1d' \
+ -e "/APBS_BINARY_LOCATION/s:None:\"${EPREFIX}/usr/bin/apbs\":g" \
+ -e "/APBS_PSIZE_LOCATION/s:None:\"$(python_get_sitedir)/pdb2pqr/src/\":g" \
+ -e "/APBS_PDB2PQR_LOCATION/s:None:\"$(python_get_sitedir)/pdb2pqr/\":g" \
+ -i "${D}/$(python_get_sitedir)"/pmg_tk/startup/apbs_tools.py || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ sed \
+ -e '1i#!/usr/bin/env python' \
+ "${D}/$(python_get_sitedir)"/pymol/__init__.py > "${T}"/${PN} || die
+
+ python_foreach_impl python_doscript "${T}"/${PN}
+
+ # These environment variables should not go in the wrapper script, or else
+ # it will be impossible to use the PyMOL libraries from Python.
+ cat >> "${T}"/20pymol <<- EOF
+ PYMOL_PATH="${EPREFIX}/usr/share/pymol"
+ PYMOL_DATA="${EPREFIX}/usr/share/pymol/data"
+ PYMOL_SCRIPTS="${EPREFIX}/usr/share/pymol/scripts"
+ EOF
+
+ doenvd "${T}"/20pymol
+
+ newicon "${WORKDIR}"/${PN}-1.8.4.0.png ${PN}.png
+ make_desktop_entry ${PN} PyMol ${PN} \
+ "Graphics;Education;Science;Chemistry;" \
+ "MimeType=chemical/x-pdb;chemical/x-mdl-molfile;chemical/x-mol2;chemical/seq-aa-fasta;chemical/seq-na-fasta;chemical/x-xyz;chemical/x-mdl-sdf;"
+
+ if ! use web; then
+ rm -rf "${D}/$(python_get_sitedir)/web" || die
+ fi
+
+ rm -f "${ED}"/usr/share/${PN}/LICENSE || die
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ optfeature "Electrostatic calculations" sci-chemistry/apbs sci-chemistry/pdb2pqr
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}