summaryrefslogtreecommitdiff
path: root/sci-chemistry/pymol-plugins-promol/pymol-plugins-promol-3.0.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-chemistry/pymol-plugins-promol/pymol-plugins-promol-3.0.2-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-chemistry/pymol-plugins-promol/pymol-plugins-promol-3.0.2-r1.ebuild')
-rw-r--r--sci-chemistry/pymol-plugins-promol/pymol-plugins-promol-3.0.2-r1.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/sci-chemistry/pymol-plugins-promol/pymol-plugins-promol-3.0.2-r1.ebuild b/sci-chemistry/pymol-plugins-promol/pymol-plugins-promol-3.0.2-r1.ebuild
new file mode 100644
index 000000000000..bda6bd694819
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-promol/pymol-plugins-promol-3.0.2-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1
+
+DESCRIPTION="Fast and accurate regognition of active sites"
+HOMEPAGE="http://www.rit.edu/cos/ezviz/ProMOL_dl.html"
+SRC_URI="http://www.rit.edu/cos/ezviz/ProMOL.zip -> ${P}.zip"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+LICENSE="all-rights-reserved"
+IUSE=""
+
+RESTRICT="mirror bindist"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ virtual/python-pmw[${PYTHON_USEDEP}]
+ sci-chemistry/pymol[${PYTHON_USEDEP}]"
+DEPEND=""
+
+S="${WORKDIR}/ProMOL Folder"
+
+src_prepare() {
+ python_copy_sources
+ preparation() {
+ cd "${BUILD_DIR}" || die
+ sed \
+ -e "s:./modules/pmg_tk/startup:${EPREFIX}/$(python_get_sitedir)/pmg_tk/startup/ProMol:g" \
+ -i ProMOL_302.py || die
+ }
+ python_foreach_impl preparation
+}
+
+src_install(){
+ dodoc *doc
+ dohtml -r Thanks.html EDMHelp.htm Help
+
+ installation() {
+ cd "${BUILD_DIR}" || die
+ python_moduleinto pmg_tk/startup/ProMol
+ python_domodule PDB_List AminoPics Motifs *GIF pdb_entry_type.txt Master.txt Scripts
+ python_moduleinto pmg_tk/startup
+ python_domodule *.py
+ dosym ../../../../../../share/doc/${PF}/html/Help \
+ $(python_get_sitedir)/pmg_tk/startup/ProMol/Help
+ dosym ../../../../../../share/doc/${PF}/html/Thanks.html \
+ $(python_get_sitedir)/pmg_tk/startup/ProMol/Thanks.html
+ dosym ../../../../../../share/doc/${PF}/html/EDMHelp.htm \
+ $(python_get_sitedir)/pmg_tk/startup/ProMol/EDMHelp.htm
+ }
+ python_foreach_impl installation
+}