summaryrefslogtreecommitdiff
path: root/sci-chemistry/pymol-plugins-bni-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-chemistry/pymol-plugins-bni-tools
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-chemistry/pymol-plugins-bni-tools')
-rw-r--r--sci-chemistry/pymol-plugins-bni-tools/Manifest5
-rw-r--r--sci-chemistry/pymol-plugins-bni-tools/metadata.xml11
-rw-r--r--sci-chemistry/pymol-plugins-bni-tools/pymol-plugins-bni-tools-0.27.ebuild37
3 files changed, 53 insertions, 0 deletions
diff --git a/sci-chemistry/pymol-plugins-bni-tools/Manifest b/sci-chemistry/pymol-plugins-bni-tools/Manifest
new file mode 100644
index 000000000000..dfb798d76f48
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-bni-tools/Manifest
@@ -0,0 +1,5 @@
+DIST bni-tools-027.zip 33753 SHA256 9ddb9785146b12c5c2ff03d34262fec8ff04bfaa9c56ec4665bac5e33879cd7c SHA512 9c0ef1ca5bbb3040192ab2668f354f947e93d42c91a0cfdde5d05be273e6ba9f29ec3c6ee86367f18d87316282b4e0141183b8d6259bd36d44010b7bbb7666e5 WHIRLPOOL 7e14a2ef86009237f53e28f6ac95b56687dd7275e8bd8a856c4d408a6c57cffb7131cb9a505d01da7b2f58bf20bae9b400e478d994bb04f9e799ecf09a60edd3
+EBUILD pymol-plugins-bni-tools-0.27.ebuild 912 SHA256 a0395a390016e3de6821357ac0c48cfe8848bfbc3fb763d1c3a081298da6dee6 SHA512 4e685c3c1c96849cf7f5144fa3ac6114c943e4feb2d66f2797f2b611150d06d1849a140ffc8a8ba50d20dd9ee032392c38c144ebc52576666229854ff21544dc WHIRLPOOL 81fdbe4f624a6992f4517803d858e0b3a0caa62b8fdb9f9b6cf3536e8691252869f3c3379cdbc2ca6fcbe076d4d5f675cadcdcc3102d7b8ff5f220c0297660c3
+MISC ChangeLog 3066 SHA256 deb9e8ebcd8866e508bfd3f44a110f7a8e62041e30a589ef174f2a6c2035cf7a SHA512 2507e6a2e57cde067f844e1153f9eee2ae8f8d5ff859175976e4b828569ba53512f0867cd8bb4d9fcba407cc8247507b9d27377b97ef9fae7596c1b9b1599801 WHIRLPOOL 5846319e6a66e39d07d6f4dc1d1ffa1baf4e2ea5e636b78a9b38180cafd2d46124aaccacd925de5aeebc52993402124d93a1c0c01bd79694da0f888516cab207
+MISC ChangeLog-2015 745 SHA256 aa56e68f8e3f788d6925006664023d51a35dab5916544c3c28f2ff454850f014 SHA512 d580832679bfd4ff10032ecb549db06150bd9b28db05cea03957b2b775282b921a47485516d3fc52c6cad06da4b4264c8ea6d8316276ec34361a1c900fa3a87b WHIRLPOOL 80a7712e994ba0d74ec8ec70517c78a2fafaeed62c6f37445c0b72a3d122119e7527b1cbe6a57e03d6eafad78e2c2f904a22b46332bca3b4d36cc92dbfc6690c
+MISC metadata.xml 354 SHA256 3589352b3a0262edff58e2131c426fe772eb3bbefb24b7ac40b97135c51f3e13 SHA512 b5f667e6315a0841a28c45fcd7c218d0b5c5e0ad3cdd63870001f1fcd2e4adf598d2b1270a77aa71c1d5d2fe985ca1d98d4c3f88cd540740e67f3469709a94a8 WHIRLPOOL ecd12ea2220fdcb3985fdc253e4ee25e3e6822275a242a0fc754de46f7eb057026ab4e0f1088cb1768d857d9f1afdb06509e40c54710cf4fc439377d0aee6cf7
diff --git a/sci-chemistry/pymol-plugins-bni-tools/metadata.xml b/sci-chemistry/pymol-plugins-bni-tools/metadata.xml
new file mode 100644
index 000000000000..0f732a212193
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-bni-tools/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-chemistry@gentoo.org</email>
+ <name>Gentoo Chemistry Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">bni-tools</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-chemistry/pymol-plugins-bni-tools/pymol-plugins-bni-tools-0.27.ebuild b/sci-chemistry/pymol-plugins-bni-tools/pymol-plugins-bni-tools-0.27.ebuild
new file mode 100644
index 000000000000..1de68c64d64f
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-bni-tools/pymol-plugins-bni-tools-0.27.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1 versionator
+
+MY_PN="${PN#pymol-plugins-}"
+MY_P="${MY_PN}-$(delete_version_separator 1)"
+MY_P_DOT="${MY_PN}-${PV}"
+
+DESCRIPTION="Gives Pymol additional functionalities and presets to the PyMOL GUI"
+HOMEPAGE="http://bni-tools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_PN}/${MY_P_DOT}/${MY_P}.zip"
+
+LICENSE="CNRI"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ sci-chemistry/pymol[${PYTHON_USEDEP}]"
+DEPEND="${PYTHON_DEPS}
+ app-arch/unzip"
+
+S="${WORKDIR}"
+
+src_install() {
+ python_moduleinto pmg_tk/startup
+ python_foreach_impl python_domodule bni-tools.py
+ python_foreach_impl python_optimize
+ dodoc readme.txt
+ dohtml ShortCommandDescription.html
+}