summaryrefslogtreecommitdiff
path: root/sci-chemistry/propka
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
commitb8c7370a682e4e29cda623222d17a790c01c3642 (patch)
treef6caa14689bd00a5760eadaa381ff41e50ef3c1b /sci-chemistry/propka
parent8a4997a7e2d1e36c089d4d76935b5a902d98d3d0 (diff)
gentoo auto-resync : 07:08:2024 - 12:37:20
Diffstat (limited to 'sci-chemistry/propka')
-rw-r--r--sci-chemistry/propka/Manifest2
-rw-r--r--sci-chemistry/propka/propka-3.5.1.ebuild28
2 files changed, 30 insertions, 0 deletions
diff --git a/sci-chemistry/propka/Manifest b/sci-chemistry/propka/Manifest
index dc5a1eddff6a..2c45708435b7 100644
--- a/sci-chemistry/propka/Manifest
+++ b/sci-chemistry/propka/Manifest
@@ -1,3 +1,5 @@
DIST propka-3.4.0.gh.tar.gz 363641 BLAKE2B 87f495ba69028593cf3ebf98ed33da0944f7a3833f2d08cae4f0a0b5cbe2f3a67e9812685b896a7d89c88ba25653861f135dbac53dc6df7af426a290bacb3d22 SHA512 2ce431c66374d0692acb7504661caa870ab6460ace3a6478f88c1d46a7bfcd82c748bf153a1ce2ea6d1611bc4bbf2351c4f5149f4578e5f8a9f9ec8385298fe9
+DIST propka-3.5.1.gh.tar.gz 376176 BLAKE2B ef4f5f51a6d08da566aa8dc4d2ec73ca028137031dbe49ca329589fe9ceb7cdda672cac755735a11bed79db1f31be5401b083239214177c2d459207ae998ae29 SHA512 3a9a7fd773700850f14c3ef1cc4ef7614242ea1191001fdca6afd44953486f208cbc067b84752c89e97e82ef6bac5561907b2aeafbee80c4d83cbf3ab443aaa2
EBUILD propka-3.4.0.ebuild 750 BLAKE2B 811914f17aaa8c9ba8779d4267ecc372c7397394ccf87bb6ea25159759248861da362c13d1e70a991ddd08783c9d4c8c9edb59b99aaac0e253f99935ed2666ee SHA512 e5d23bb7cff54dfc009435da11de8f7e73e2da41e908d4efde1f722a15e2af2d3e5c126fdeb59c5177349a64e6fdeb18cd407a7bd9a6aad3cbeaa3ab6ec04312
+EBUILD propka-3.5.1.ebuild 751 BLAKE2B b3db6aebf5bcf519ae9f248b854d92defe476233d311601ac158763e07ed757ad74542ead5507f7d81de2f356c59efce29f8c501922de544189b51431595b5c8 SHA512 15ff70d3711166276c7b548ebddccf6684942d095fd941e093bd027d55d9bf632c70e50ed045e9a00f8a3ec577927018444c2b38f686c7e772894b01b3d6117d
MISC metadata.xml 417 BLAKE2B 89fda735965e8ae53eb86dfd438137e7770718b5601d5cd753cce9a03001419e53404dde70fed53d37ccf407265ee387accb26640bb4fce479e01ff141702b70 SHA512 5a9f942fa28e679ee5e1795fddf91661c35c55df79e0d9b742353ad265057ceb030ef15d3bb218ad5e8217c61d462aa09206e261c14dc363e6d6bfc3d20c6500
diff --git a/sci-chemistry/propka/propka-3.5.1.ebuild b/sci-chemistry/propka/propka-3.5.1.ebuild
new file mode 100644
index 000000000000..2c9eb2ee4f27
--- /dev/null
+++ b/sci-chemistry/propka/propka-3.5.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="pKa-value prediction of ionizable groups in protein and protein-ligand complexes"
+HOMEPAGE="https://github.com/jensengroup/propka"
+SRC_URI="https://github.com/jensengroup/propka/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Do not install the tests
+ sed -e "/exclude/s:scripts:\', \'tests:g" \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+}