summaryrefslogtreecommitdiff
path: root/sci-chemistry/propka
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-chemistry/propka
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-chemistry/propka')
-rw-r--r--sci-chemistry/propka/Manifest5
-rw-r--r--sci-chemistry/propka/metadata.xml8
-rw-r--r--sci-chemistry/propka/propka-3.1_p140511.ebuild37
3 files changed, 50 insertions, 0 deletions
diff --git a/sci-chemistry/propka/Manifest b/sci-chemistry/propka/Manifest
new file mode 100644
index 000000000000..acfaf1d3b1f5
--- /dev/null
+++ b/sci-chemistry/propka/Manifest
@@ -0,0 +1,5 @@
+DIST propka-3.1_p140511.tar.xz 151284 SHA256 42b4f6b98bbbefa11fba5e603aa33f1747362746c1170c9958ad408dc34e39af SHA512 c2938af41ed386e267cd045b14e34779889b3c206016d747b68c400f2c8b37bd50cc3b74d055d931476065ac6817a2dd2cb87d68de9911adfff1c8e34a667fc3 WHIRLPOOL 0553ef5f519d41af508885f1900a68627fcf3fb2f901c5d1cef54fe6a5774ef08caf42bf5e80f08cba4c76c9e330be89502e648cf5604aca411c168d4ecda6fa
+EBUILD propka-3.1_p140511.ebuild 818 SHA256 568917ebba9f4d9159aa144edf44b2348a5d4f561aaade1e63b5b1ebadb61182 SHA512 11067e38fe55d39e0379f739db6385d28e6bdb45545d61607c3e2f4d5780235eb0959c40d5c2f4ef0e2a7965c169c720cb27be9ef445f272953d308479a2f430 WHIRLPOOL ea3c5b02706c489e67da1e61ab09c3d8bb9086a5641ad964045ac69500c58c28c1185c49926af4dc3f1b42607203bc6d6bd48458ec9204a7f3c7953e7865d4e6
+MISC ChangeLog 2610 SHA256 c4511975ad37b4b6ed1779889eb129f2621575c5ccc7f8caefaa64ab2818449f SHA512 bd703eadda91df30582ec6c8a40a00297ed44a8cf0dbbb969bddad363148b0f76663a8bb03c4f0c5a9b31fd8327982a3749360d0d85784da621899bcf31c6627 WHIRLPOOL 31ce537bca57194da805ad7706b67ba81927ee9e1a0c40516236b5317734e33893275e5f6d310227d3e94c05434537fb12b4fec7da2631ee368176c7b39c1211
+MISC ChangeLog-2015 688 SHA256 b179256c54c4904ae62f71c291d2ebac533f046b69bc0c5d85bd86336b14fbe1 SHA512 303e4f21cc7dd8c15ad8fce70675a745dbf605ad99c6158f46eafbbc10f6507dc330ab2f2143b1ca0dcaa5bcdbff3415b1b2d54896bf9dc721db7bb668b18696 WHIRLPOOL 20382d843673c78962219392e1e60a1827259b61856e93118520d12a8d612804099879651fa239f0dfde46dda2503b5109a7be77b0fb2b3cd90d2aa629a46e38
+MISC metadata.xml 271 SHA256 70036ea85140f86ed670bc2791c9de861c4b6164755ee36a2560d1c812ec13f6 SHA512 3e6e6047a29e07123b81279cae1de17bc4bd4c3d7d8a8d26560114a18185f473d038fc220fa81c7213fa203ce197bad8b1c272d9b7e41cd770a953fa6308ff92 WHIRLPOOL 1ccb964819c99258af550a41c6712ba8ebdecbec1c821106de2f22c37b1c981cd4f324856a8014b08bd186bcd2a7fa45a7e772cc15705d1a39016b5229e77269
diff --git a/sci-chemistry/propka/metadata.xml b/sci-chemistry/propka/metadata.xml
new file mode 100644
index 000000000000..8937bad0b175
--- /dev/null
+++ b/sci-chemistry/propka/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-chemistry@gentoo.org</email>
+ <name>Gentoo Chemistry Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-chemistry/propka/propka-3.1_p140511.ebuild b/sci-chemistry/propka/propka-3.1_p140511.ebuild
new file mode 100644
index 000000000000..2d34b8da5d5f
--- /dev/null
+++ b/sci-chemistry/propka/propka-3.1_p140511.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Prediction of the pKa values of ionizable groups in proteins and protein-ligand complexes"
+HOMEPAGE="http://propka.ki.ku.dk/"
+SRC_URI="https://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="all-rights-reserved"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RESTRICT="mirror bindist"
+
+python_prepare_all() {
+ sed -e "/exclude/s:scripts:\', \'Tests:g" \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cd Tests || die
+ ${PYTHON} runtest.py || die
+}
+
+python_install_all() {
+ dosym ${PN}31 /usr/bin/${PN}
+ distutils-r1_python_install_all
+}