summaryrefslogtreecommitdiff
path: root/sci-chemistry/pdbmat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-chemistry/pdbmat
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-chemistry/pdbmat')
-rw-r--r--sci-chemistry/pdbmat/Manifest6
-rw-r--r--sci-chemistry/pdbmat/files/CMakeLists.txt14
-rw-r--r--sci-chemistry/pdbmat/metadata.xml24
-rw-r--r--sci-chemistry/pdbmat/pdbmat-3.89.ebuild31
4 files changed, 75 insertions, 0 deletions
diff --git a/sci-chemistry/pdbmat/Manifest b/sci-chemistry/pdbmat/Manifest
new file mode 100644
index 000000000000..c204ee8a4130
--- /dev/null
+++ b/sci-chemistry/pdbmat/Manifest
@@ -0,0 +1,6 @@
+AUX CMakeLists.txt 414 SHA256 3892dbed23bf2283ce369dc5a2d89c0eded875d615704532fb038ccbe2c90436 SHA512 d539a6cc947cf6f16d634ccc5e2c0f1783f000564cc78c2103c1bcbc8619cb7f0d97a461ffa91ab3fb7d4dbe11102614983456c9bd8597a2f4d9f9a6538185ff WHIRLPOOL b8b64d1e3e1b1972513f2fdfc7fee647c7622ef34589c3cbdd53ab6a00e551315f188b1d9f2f5e4ac35a1ee9ea0b307bb84cfc9dd6af13a4ba0d595113bf46aa
+DIST pdbmat-3.89.tar.gz 124727 SHA256 98f75acd3da3f172213de0688825abad8b3a59c516b5b4ac411a494f6d355f72 SHA512 2c7f8f32344fe1abc662878c2556c10bd6671e683787231827399866f485389c3a63253b00d5a5bdbe8d0b8b779891e846962c9372d927b94c45f0fac59a4fb6 WHIRLPOOL 62f0b8cb2a99797d49c427a085ad24b41e045ba96433cb8c1769c614402cf729737b2335fcb356ad42de1e24079eadccd2c3db6eaa8ff062eb1249a13723b7f0
+EBUILD pdbmat-3.89.ebuild 649 SHA256 ee2383f446330b652796d60983775cdab35c80b50ce4b13d719bcc0ed247c112 SHA512 22e5765e35daab42e8c013ee1a2ddc8b08318d215c1eea6def16ff0559be4f5d521ed85f73fc82fbac3d0a0ae06fc07935bb666fdccf47f1268316a668b1f3e7 WHIRLPOOL 0e57acdfd15e14fc9992db67e248bbb2cd7caf98c0033ea257f001cfe77cce9c1d247954830f301b44a0212c122306a77d3ef4c3a14cb50371504351274cd5d4
+MISC ChangeLog 2590 SHA256 50db9413836098e902c20b1aee592f339aa666e9f5f251303374b0373bcee9d3 SHA512 2d0f080506e33382fc88d7fd6780e08abb7ecf1c5ab6643632020b9c8a4049cba9cb1631c357deeaa887e05de8652ca3065910d5f362a7cf85e302763f2cccc9 WHIRLPOOL b08416978b2e8f8991c8a718d0a24d2f0ba97d24a2204767920399a37237e6f52c6031ba69117cde3e04dba8fa596d5d0786a4f60591544fb1276fb178355172
+MISC ChangeLog-2015 829 SHA256 30fb3dea3b7f1ad5269cde35e3dd5728a328bb5d7a0c8f65623619f87e94be38 SHA512 ca6b9615ea017ae19fe1716fa80655ca0c91416f3951b1e1fa5655f0a95f64a925392396e51ef40cc7d3b389789cf4bc00951360f754407a93d76bbba2356e1b WHIRLPOOL b61c47824d21c03323663b660a9de1ff5a2003fa9947bd3ff22ccb60e6a9d8605a4c946cea446ee67fb094528efb4d93d0f5a4114c00169408b0d483f4e85aa3
+MISC metadata.xml 1091 SHA256 13df1e320c0cb4ed41f204b582cbcdc6c97bbbca8f3192845b4c88aa72266e5b SHA512 1316419ffe8d75ae6596e456563f2a8eec3b734cc4e54c0b6708adf71ac355dae4ee1934ff1f7e44071e70f3c1b3796cb51b144d84fdd8367cac2ca8d3f70542 WHIRLPOOL 8031fbe75de764c3380b2c8d875b277d8a02590bf00077ab49983a85a6db01c9dbbd5ac47c2ef6e36f38a8a7dc8cd995b5a5a7b62a69afa7913e1f488d045c6f
diff --git a/sci-chemistry/pdbmat/files/CMakeLists.txt b/sci-chemistry/pdbmat/files/CMakeLists.txt
new file mode 100644
index 000000000000..2f1937d84b3f
--- /dev/null
+++ b/sci-chemistry/pdbmat/files/CMakeLists.txt
@@ -0,0 +1,14 @@
+cmake_minimum_required (VERSION 2.6)
+project (PDBMAT Fortran)
+
+option (EXAMPLES "Instal additional example files" OFF)
+
+add_executable(diagstd diagstd.f)
+add_executable(pdbmat pdbmat.f)
+
+install (TARGETS diagstd pdbmat DESTINATION bin)
+install (FILES diagstd.README pdbmat.README DESTINATION share/doc/pdbmat)
+
+if ( EXAMPLES )
+ install (DIRECTORY ../Try_ENM2011 DESTINATION share/pdbmat/examples)
+endif (EXAMPLES)
diff --git a/sci-chemistry/pdbmat/metadata.xml b/sci-chemistry/pdbmat/metadata.xml
new file mode 100644
index 000000000000..5116112c89eb
--- /dev/null
+++ b/sci-chemistry/pdbmat/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-chemistry@gentoo.org</email>
+ <name>Gentoo Chemistry Project</name>
+ </maintainer>
+ <longdescription>
+A fortran program in which Tirion's model (also called the Elastic Network
+Model) is implemented. Within the frame of this model, atoms (particles)
+less than cutoff (angstroms) away from each others are linked by springs of
+same strength. Alternatively, a list of interacting atoms can be given to the
+program.
+Requirements: a file with the coordinates of the system, in PDB (Protein Data
+Bank) or "x y z mass" format.
+
+Output: the hessian (the mass-weighted second derivatives of energy matrix),
+in the "i j non-zero-ij-matrix-element" format.
+
+Diagstd, a fortran program with a standard diagonalization routine, can next
+be used in order to obtain the corresponding normal modes of the system. If
+the system is large, the RTB approximation can prove usefull (see below).
+</longdescription>
+</pkgmetadata>
diff --git a/sci-chemistry/pdbmat/pdbmat-3.89.ebuild b/sci-chemistry/pdbmat/pdbmat-3.89.ebuild
new file mode 100644
index 000000000000..6c14461b5019
--- /dev/null
+++ b/sci-chemistry/pdbmat/pdbmat-3.89.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils fortran-2
+
+DESCRIPTION="Calculate Tirion's model from pdb structures"
+HOMEPAGE="http://ecole.modelisation.free.fr/modes.html"
+SRC_URI="http://ecole.modelisation.free.fr/enm2011.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="CeCILL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+S="${WORKDIR}"/Source_ENM2011
+
+src_prepare() {
+ cp "${FILESDIR}"/CMakeLists.txt . || die
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DEXAMPLES=$(usex examples)
+ )
+
+ cmake-utils_src_configure
+}