summaryrefslogtreecommitdiff
path: root/sci-chemistry/mars/mars-1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-chemistry/mars/mars-1.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-chemistry/mars/mars-1.2.ebuild')
-rw-r--r--sci-chemistry/mars/mars-1.2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sci-chemistry/mars/mars-1.2.ebuild b/sci-chemistry/mars/mars-1.2.ebuild
new file mode 100644
index 000000000000..5fd849dc4cb1
--- /dev/null
+++ b/sci-chemistry/mars/mars-1.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+MY_P="${P}_linux"
+
+DESCRIPTION="Robust automatic backbone assignment of proteins"
+HOMEPAGE="http://www.mpibpc.mpg.de/groups/zweckstetter/_links/software_mars.htm"
+SRC_URI="http://www.mpibpc.mpg.de/groups/zweckstetter/_software_files/_${PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="all-rights-reserved"
+IUSE="examples"
+
+RDEPEND="sci-biology/psipred"
+DEPEND=""
+
+RESTRICT=mirror
+
+S="${WORKDIR}"/${MY_P}
+
+QA_PREBUILT="opt/mars/*"
+
+src_install() {
+ dobin bin/runmars*
+
+ exeinto /opt/${PN}/
+ doexe bin/{${PN},calcJC-S2,runmars*,*.awk} *.awk
+ insinto /opt/${PN}/
+ doins bin/*.{tab,txt}
+ if use examples; then
+ insinto /usr/share/${PN}/
+ doins -r examples
+ fi
+
+ cat >> "${T}"/23mars <<- EOF
+ MARSHOME="${EPREFIX}/opt/${PN}"
+ EOF
+
+ doenvd "${T}"/23mars
+}