summaryrefslogtreecommitdiff
path: root/sci-chemistry/hollow/hollow-1.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-chemistry/hollow/hollow-1.2-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-chemistry/hollow/hollow-1.2-r1.ebuild')
-rw-r--r--sci-chemistry/hollow/hollow-1.2-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sci-chemistry/hollow/hollow-1.2-r1.ebuild b/sci-chemistry/hollow/hollow-1.2-r1.ebuild
new file mode 100644
index 000000000000..9c421e26b2bb
--- /dev/null
+++ b/sci-chemistry/hollow/hollow-1.2-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1
+
+DESCRIPTION="Production of surface images of proteins"
+HOMEPAGE="http://hollow.sourceforge.net/"
+#SRC_URI="mirror://sourceforge/${P}.zip"
+SRC_URI="http://hollow.sourceforge.net/${P}.zip"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-3"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ sci-chemistry/pymol[${PYTHON_USEDEP}]"
+DEPEND="${PYTHON_DEPS}
+ app-arch/unzip"
+
+src_install() {
+ python_setup
+ esvn_clean
+ python_foreach_impl python_domodule pdbstruct
+ python_moduleinto ${PN}
+ python_foreach_impl python_domodule *.py hollow.txt
+
+ python_foreach_impl python_newscript ${PN}.py ${PN}
+
+ dodoc README
+ python_optimize
+}