summaryrefslogtreecommitdiff
path: root/sci-chemistry/gromacs/gromacs-2021.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-21 01:52:56 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-21 01:52:56 +0000
commitb46782805d0eed36ce9685f7e9abf25671f24d7d (patch)
tree4b7992f7355b710c35a7c4bfff9b57eb64e4c8b5 /sci-chemistry/gromacs/gromacs-2021.9999.ebuild
parentd4d7098dcb2f9dd257109bbcb55fd40beda1b78d (diff)
gentoo auto-resync : 21:12:2022 - 01:52:55
Diffstat (limited to 'sci-chemistry/gromacs/gromacs-2021.9999.ebuild')
-rw-r--r--sci-chemistry/gromacs/gromacs-2021.9999.ebuild12
1 files changed, 4 insertions, 8 deletions
diff --git a/sci-chemistry/gromacs/gromacs-2021.9999.ebuild b/sci-chemistry/gromacs/gromacs-2021.9999.ebuild
index 44a39087816b..31f880174588 100644
--- a/sci-chemistry/gromacs/gromacs-2021.9999.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2021.9999.ebuild
@@ -22,16 +22,16 @@ if [[ ${PV} = *9999* ]]; then
inherit git-r3
else
SRC_URI="
- http://ftp.gromacs.org/gromacs/${PN}-${PV/_/-}.tar.gz
+ https://ftp.gromacs.org/gromacs/${PN}-${PV/_/-}.tar.gz
doc? ( https://ftp.gromacs.org/manual/manual-${PV/_/-}.pdf )
- test? ( http://ftp.gromacs.org/regressiontests/regressiontests-${PV/_/-}.tar.gz )"
+ test? ( https://ftp.gromacs.org/regressiontests/regressiontests-${PV/_/-}.tar.gz )"
KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux ~x64-macos"
fi
ACCE_IUSE="cpu_flags_x86_sse2 cpu_flags_x86_sse4_1 cpu_flags_x86_fma4 cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_x86_avx512f cpu_flags_arm_neon"
DESCRIPTION="The ultimate molecular dynamics simulation package"
-HOMEPAGE="http://www.gromacs.org/"
+HOMEPAGE="https://www.gromacs.org/"
# see COPYING for details
# https://repo.or.cz/w/gromacs.git/blob/HEAD:/COPYING
@@ -76,6 +76,7 @@ REQUIRED_USE="
|| ( single-precision double-precision )
doc? ( !build-manual )
cuda? ( single-precision )
+ opencl? ( single-precision )
cuda? ( !opencl )
mkl? ( !blas !fftw !lapack )
${PYTHON_REQUIRED_USE}"
@@ -187,11 +188,6 @@ src_configure() {
if use fftw; then
fft_opts=( -DGMX_FFT_LIBRARY=fftw3 )
- elif use mkl && has_version "=sci-libs/mkl-10*"; then
- fft_opts=( -DGMX_FFT_LIBRARY=mkl
- -DMKL_INCLUDE_DIR="${MKLROOT}/include"
- -DMKL_LIBRARIES="$(echo /opt/intel/mkl/10.0.5.025/lib/*/libmkl.so);$(echo /opt/intel/mkl/10.0.5.025/lib/*/libiomp*.so)"
- )
elif use mkl; then
local bits=$(get_libdir)
fft_opts=( -DGMX_FFT_LIBRARY=mkl