summaryrefslogtreecommitdiff
path: root/sci-chemistry/elem/elem-1.0.3-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-chemistry/elem/elem-1.0.3-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-chemistry/elem/elem-1.0.3-r2.ebuild')
-rw-r--r--sci-chemistry/elem/elem-1.0.3-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sci-chemistry/elem/elem-1.0.3-r2.ebuild b/sci-chemistry/elem/elem-1.0.3-r2.ebuild
new file mode 100644
index 000000000000..5a9a8c132cf3
--- /dev/null
+++ b/sci-chemistry/elem/elem-1.0.3-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit toolchain-funcs
+
+DESCRIPTION="periodic table of the elements"
+HOMEPAGE="http://elem.sourceforge.net/"
+SRC_URI="mirror://sourceforge/elem/${PN}-src-${PV}-Linux.tgz"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~sparc ~x86"
+SLOT="0"
+IUSE=""
+
+DEPEND="x11-libs/xforms"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -e 's:\(^LIBS = .*\):\1 -lXpm:' \
+ -e "s:\${FLAGS} -o elem:\$(LDFLAGS) &:" \
+ -i Makefile || die #336190
+ sed -e "/string.h/ i #include <stdlib.h>" \
+ -i elem_cb.c || die #implicit exit()
+}
+
+src_compile () {
+ emake COMPILER="$(tc-getCC)" FLAGS="${CFLAGS}" all || die "Build failed."
+}
+
+src_install () {
+ dobin elem elem-de elem-en || die
+ dohtml -r doc/* || die
+}