summaryrefslogtreecommitdiff
path: root/sci-chemistry/autodock
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-17 14:07:47 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-17 14:07:47 +0000
commit7c9730bcb62df7cbf8248c5db9a478aac52c60ea (patch)
tree3521ee333c83fb6c7ff14d0a0a2d742464e88767 /sci-chemistry/autodock
parent29394d0921808a94a409f01eff49f681651de5d5 (diff)
gentoo auto-resync : 17:02:2023 - 14:07:46
Diffstat (limited to 'sci-chemistry/autodock')
-rw-r--r--sci-chemistry/autodock/Manifest2
-rw-r--r--sci-chemistry/autodock/autodock-4.2.6.ebuild38
2 files changed, 16 insertions, 24 deletions
diff --git a/sci-chemistry/autodock/Manifest b/sci-chemistry/autodock/Manifest
index 3c54d983af4c..0d730f7dbef4 100644
--- a/sci-chemistry/autodock/Manifest
+++ b/sci-chemistry/autodock/Manifest
@@ -1,4 +1,4 @@
AUX autodock-4.2.6-buildsystem.patch 1480 BLAKE2B 3f1884ee05e062cb630b43fe3e8ecf6f827ada23d5d3060a5bb3d7e854f7c5e2d2b1f7a476c4effcdcbab4292b33fae093474773a31a6995465d00dbbb721246 SHA512 9c5b05f4831049c2c064358df26124526973110ddd31ffa7930f185694f9258dfce648085a96f05a2173aa61b4cdcda7a6fe170a56160708e031fb248f9e6bbe
DIST autodocksuite-4.2.6-src.tar.gz 35438010 BLAKE2B 88e036ecc0492fb83f31b90fd0983ec57d889a61d17249f672a3e30e942f6c329dc2494088a8fc7c5bc39a5bdbb38fb1514f1750c7145374f202a928d477faa9 SHA512 75b8878f948c4f6bc28adb442997192dad0c36bbede2fd698623903cb27b06b4df3ba038bfc70fc13b4bdee864fd2344f0f7208be2020da4e01a00b842b46bbb
-EBUILD autodock-4.2.6.ebuild 2337 BLAKE2B 3302c9d3690f3faf97ef2265512de2c31b0b83752ed92375ecc822e42125eb50324a97197131b5280c71e1a165d1052f4250d06ed412d0b86034464168e9ef49 SHA512 3f215c0d54059f77da1623a9d5602e81e652d84382b327c3deee86f8cdb2d5392476d62288452881977f1582fa36474c648e7e519b5cf7fd7d1a926778697941
+EBUILD autodock-4.2.6.ebuild 2206 BLAKE2B 0e457f425fac2908df23e03bf31865e985b0fdb85bdc2014e10bcbef1a00dbbf957b986eda9e7d9cce443cd9bbb1a8118076f3b7e3990eb02c86c559566c9bb3 SHA512 aef41ca8df16042995b25b6a3a07bb207fae458e60b97ec5d1b6918944540b500d9cf798cda52a8f2e12a2a6e9c5531e4565c03bc49a8e4210df1d96aec56102
MISC metadata.xml 272 BLAKE2B 531e98b72776bbe9126811b70943add0f6f43141b01cb75b17ac2c8d1cfb6a9b349022fd411894d2b8eeb0612a73db10aed4ba71f9624bd6dbd172a05fca2c76 SHA512 04f5575703aaaa95e575460ae3de428d3da173b3b741ab52b4aad31e381fef78b325f49f99622ec26a65024437759ea013fc525bd63ee553003c71afcc40d10c
diff --git a/sci-chemistry/autodock/autodock-4.2.6.ebuild b/sci-chemistry/autodock/autodock-4.2.6.ebuild
index b4dce2e439b4..ba012304d26e 100644
--- a/sci-chemistry/autodock/autodock-4.2.6.ebuild
+++ b/sci-chemistry/autodock/autodock-4.2.6.ebuild
@@ -1,12 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-# Tests require python2
-#PYTHON_COMPAT=( python2_7 )
-
-inherit autotools readme.gentoo-r1 #python-any-r1
+inherit autotools readme.gentoo-r1
MY_PN="autodocksuite"
MY_P="${MY_PN}-${PV}"
@@ -14,23 +11,18 @@ MY_P="${MY_PN}-${PV}"
DESCRIPTION="A suite of automated docking tools"
HOMEPAGE="http://autodock.scripps.edu/"
SRC_URI="http://autodock.scripps.edu/downloads/autodock-registration/tars/dist$(ver_rs 1- '')/${MY_P}-src.tar.gz"
+S="${WORKDIR}/src"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-
-IUSE="examples openmp" #test
-#RESTRICT="!test? ( test )"
+IUSE="examples openmp"
+# Tests require python2
+RESTRICT="test"
# False positives caused by nested configure scripts
QA_CONFIGURE_OPTIONS=".*"
-RDEPEND=""
-DEPEND=""
-#DEPEND="test? ( ${PYTHON_DEPS} )"
-
-S="${WORKDIR}/src"
-
DISABLE_AUTOFORMATTING="yes"
DOC_CONTENTS="
The AutoDock development team requests all users to fill out the
@@ -76,15 +68,15 @@ src_compile() {
emake -C autogrid
}
-#src_test() {
-# elog "Testing autodock"
-# cd "${S}/autodock/Tests" || die
-# cp ../*.dat . || die
-# ${EPYTHON} test_autodock4.py || die "AutoDock tests failed."
-# einfo "Testing autogrid"
-# cd "${S}/autogrid/Tests" || die
-# ${EPYTHON} test_autogrid4.py || die "AutoGrid tests failed."
-#}
+src_test() {
+ elog "Testing autodock"
+ cd "${S}/autodock/Tests" || die
+ cp ../*.dat . || die
+ ${EPYTHON} test_autodock4.py || die "AutoDock tests failed."
+ einfo "Testing autogrid"
+ cd "${S}/autogrid/Tests" || die
+ ${EPYTHON} test_autogrid4.py || die "AutoGrid tests failed."
+}
src_install() {
if use openmp; then