summaryrefslogtreecommitdiff
path: root/sci-chemistry/autodock/files/autodock-4.2.6-buildsystem.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-chemistry/autodock/files/autodock-4.2.6-buildsystem.patch
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-chemistry/autodock/files/autodock-4.2.6-buildsystem.patch')
-rw-r--r--sci-chemistry/autodock/files/autodock-4.2.6-buildsystem.patch44
1 files changed, 44 insertions, 0 deletions
diff --git a/sci-chemistry/autodock/files/autodock-4.2.6-buildsystem.patch b/sci-chemistry/autodock/files/autodock-4.2.6-buildsystem.patch
new file mode 100644
index 000000000000..ae44ffeb3159
--- /dev/null
+++ b/sci-chemistry/autodock/files/autodock-4.2.6-buildsystem.patch
@@ -0,0 +1,44 @@
+ src/autodock/Makefile.am | 6 +++---
+ src/autogrid/Makefile.am | 4 ++--
+ 2 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/src/autodock/Makefile.am b/src/autodock/Makefile.am
+index 799a3c4..911897b 100644
+--- a/src/autodock/Makefile.am
++++ b/src/autodock/Makefile.am
+@@ -459,7 +459,8 @@ endif
+
+ BUILT_SOURCES = $(autodock4_SOURCES) default_parameters.h
+
+-AM_CXXFLAGS = -O3 # Agressive optimization
++AM_CXXFLAGS =
++#AM_CXXFLAGS = -O3 # Agressive optimization
+ #AM_CXXFLAGS = -g # debug
+
+ # if gnu c++ compiler
+@@ -488,8 +489,7 @@ endif
+ AM_CPPFLAGS = -DNOSQRT \
+ -DUSE_DOUBLE \
+ -DUSE_8A_NBCUTOFF \
+- -DUSE_INT_AS_FOURBYTELONG \
+- -O3
++ -DUSE_INT_AS_FOURBYTELONG
+ # AM_LDFLAGS = -g # -g is MP debug
+
+
+diff --git a/src/autogrid/Makefile.am b/src/autogrid/Makefile.am
+index b531099..b78b380 100644
+--- a/src/autogrid/Makefile.am
++++ b/src/autogrid/Makefile.am
+@@ -94,9 +94,9 @@ autogrid4_SOURCES = main.cpp \
+ BUILT_SOURCES = default_parameters.h
+
+
+-AM_CFLAGS = -Wall -O3 # All warnings, Agressive optimization
++AM_CFLAGS = -Wall # All warnings, Agressive optimization
+
+-AM_CPPFLAGS = -Wall -O3 -I $(srcdir) -I$(srcdir)/../autodock # All warnings, Agressive optimization
++AM_CPPFLAGS = -Wall -I $(srcdir) -I$(srcdir)/../autodock # All warnings, Agressive optimization
+ AM_CPPFLAGS += -Wno-write-strings # increase compatibility with pre 4.x compilers for string handling
+ # M Pique - add USE_8A_NBCUTOFF
+ AM_CPPFLAGS += -DUSE_8A_NBCUTOFF