summaryrefslogtreecommitdiff
path: root/sci-chemistry/aria
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-chemistry/aria
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-chemistry/aria')
-rw-r--r--sci-chemistry/aria/Manifest5
-rw-r--r--sci-chemistry/aria/aria-2.3.2_p20130826.ebuild88
-rw-r--r--sci-chemistry/aria/metadata.xml8
3 files changed, 101 insertions, 0 deletions
diff --git a/sci-chemistry/aria/Manifest b/sci-chemistry/aria/Manifest
new file mode 100644
index 000000000000..79b9b94a8bd1
--- /dev/null
+++ b/sci-chemistry/aria/Manifest
@@ -0,0 +1,5 @@
+DIST aria2.3.2_08.26.2013.tar.gz 1878602 SHA256 b9b892de2070a77812733faf4b6a1dbec4bba6dec80e5630088cab8b11cbfaf0 SHA512 a6d8c45218f5d494174587a5f8f1feec940ac8cc4cd7b707dac65b2378219ecf27967e70807e6cb7ae22a7d4aec7239af763f077ad7183c078b1991cac71bc3e WHIRLPOOL 59c0b79fab40201d903c484bf63e8339c235207306efc848965d260c02b00c9a408297df0f211cf45f30d13ec35175bf7d566bb5c6d59b944eb22d9aacf0384d
+EBUILD aria-2.3.2_p20130826.ebuild 1918 SHA256 11bf3ea780ec7d1d36cbddf069a529b9686bf5ac4d5fee62fdfa08e1e33d0dfa SHA512 97f30da0e83cee0e9ed20c0d81b020fa55d3b62c60f25014b4b83888e3004f01b94216ba13257b8fe2fb92156391f3c08845d6f1cf5684739a1fc6d412ecd712 WHIRLPOOL 3488b567dac571b2af63b7e16dc885a90e465fc970f8795dfc7146cde59a8a30146f76b8e7430a6d5552af03c82b77de8f9877c05f4669cd0f029bae65adaa41
+MISC ChangeLog 2835 SHA256 c6b6bcb19baf6a9585efd50ae0334fd10b7f0659ce81eafe031ea90fae924a62 SHA512 fa68904e18078d6a686304309a2518a1ad99481bc6522c6e65c0f3dcf8e4aabd161ed604d47863e00601a14ad6114aaf46e7eaec9b4131ec0b53806bb989fe08 WHIRLPOOL 6cf1ed79e98234ad17fa7a45cca57509053a87056c4ce873cc863e6745296bc55ddbc5b2a459ce8747c5ebdcddb375206875bc9ef17f855e8ab86df822188fef
+MISC ChangeLog-2015 3528 SHA256 4c5587b2f95197300a51bbabf99a75b5de5d3a55b957b46ac4789070691e2062 SHA512 ff6a65fba911bb08ff0d86bb464402b424fe670ec55e462f31c14bca5561c9a934c153654034eb1c9885dd7221c8b5b819e3730c6e920b1e4ff09e0ca6a9cbae WHIRLPOOL 98241b5b155e081994c9200062c319757185ebf2e895e711bbc9766df1164cbf15cbc8f0f66f3fc358405e47fde2b29605b3239c045a7e0779f51303534d86ad
+MISC metadata.xml 271 SHA256 70036ea85140f86ed670bc2791c9de861c4b6164755ee36a2560d1c812ec13f6 SHA512 3e6e6047a29e07123b81279cae1de17bc4bd4c3d7d8a8d26560114a18185f473d038fc220fa81c7213fa203ce197bad8b1c272d9b7e41cd770a953fa6308ff92 WHIRLPOOL 1ccb964819c99258af550a41c6712ba8ebdecbec1c821106de2f22c37b1c981cd4f324856a8014b08bd186bcd2a7fa45a7e772cc15705d1a39016b5229e77269
diff --git a/sci-chemistry/aria/aria-2.3.2_p20130826.ebuild b/sci-chemistry/aria/aria-2.3.2_p20130826.ebuild
new file mode 100644
index 000000000000..84f75d11ed6e
--- /dev/null
+++ b/sci-chemistry/aria/aria-2.3.2_p20130826.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="tk"
+
+inherit eutils python-single-r1 versionator
+
+MY_P="${PN}$(get_version_component_range 1-2 ${PV})"
+DATE="08.26.2013"
+
+DESCRIPTION="Automated NOE assignment and NMR structure calculation"
+HOMEPAGE="http://aria.pasteur.fr/"
+SRC_URI="http://aria.pasteur.fr/archives/${MY_P}.2_${DATE}.tar.gz"
+
+SLOT="0"
+LICENSE="cns"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-tcltk/tix
+ dev-lang/tk:0=
+ >=dev-python/numpy-1.1[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP},tk]
+ >=sci-chemistry/cns-1.2.1-r7[aria,openmp]
+ >=sci-chemistry/ccpn-2.2[${PYTHON_USEDEP}]
+ sci-chemistry/clashlist
+ sci-chemistry/procheck
+ sci-libs/clashscore-db"
+DEPEND="${RDEPEND}"
+
+RESTRICT="fetch"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_nofetch(){
+ einfo "Go to http://aria.pasteur.fr/archives/aria2.3.2.tar.gz/view, download ${A}"
+ einfo "and place it in ${DISTDIR}"
+}
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_test(){
+ export CCPNMR_TOP_DIR=$(python_get_sitedir)
+ export PYTHONPATH=.:${CCPNMR_TOP_DIR}/ccpn/python
+ ${PYTHON} check.py || die
+}
+
+src_install(){
+ python_moduleinto ${PN}
+ python_domodule src aria2.py
+ python_moduleinto ${PN}/cns
+ python_domodule cns/{protocols,toppar,src/helplib}
+
+ if use examples; then
+ insinto /usr/share/${P}/
+ doins -r examples
+ fi
+
+ # ENV
+ cat >> "${T}"/20aria <<- EOF
+ ARIA2="$(python_get_sitedir)/${PN}"
+ EOF
+
+ doenvd "${T}"/20aria
+
+ # Launch Wrapper
+ cat >> "${T}"/aria <<- EOF
+ #!/bin/sh
+ export CCPNMR_TOP_DIR="$(python_get_sitedir)"
+ export PYTHONPATH="$(python_get_sitedir)/ccpn/python"
+ exec "${PYTHON}" -O "\${ARIA2}"/aria2.py \$@
+ EOF
+
+ dobin "${T}"/aria
+ dosym aria /usr/bin/aria2
+
+ dodoc README
+ python_optimize "${D}/$(python_get_sitedir)"
+}
diff --git a/sci-chemistry/aria/metadata.xml b/sci-chemistry/aria/metadata.xml
new file mode 100644
index 000000000000..8937bad0b175
--- /dev/null
+++ b/sci-chemistry/aria/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-chemistry@gentoo.org</email>
+ <name>Gentoo Chemistry Project</name>
+ </maintainer>
+</pkgmetadata>