summaryrefslogtreecommitdiff
path: root/sci-chemistry/PyMca
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-chemistry/PyMca
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-chemistry/PyMca')
-rw-r--r--sci-chemistry/PyMca/Manifest6
-rw-r--r--sci-chemistry/PyMca/PyMca-4.6.2-r1.ebuild40
-rw-r--r--sci-chemistry/PyMca/files/PyMca-4.6.2-gentoo.patch16
-rw-r--r--sci-chemistry/PyMca/metadata.xml22
4 files changed, 84 insertions, 0 deletions
diff --git a/sci-chemistry/PyMca/Manifest b/sci-chemistry/PyMca/Manifest
new file mode 100644
index 000000000000..db219019680b
--- /dev/null
+++ b/sci-chemistry/PyMca/Manifest
@@ -0,0 +1,6 @@
+AUX PyMca-4.6.2-gentoo.patch 538 SHA256 cd9170ba6219c4fb78aed0bbb972da452255a95b361117dc9942e8dce86b381f SHA512 cdc3cbe8264310748ef065cf07b1d1d8c9b39f560a6317924a34c795c4a62fceba7de0847c9a325133fe87acdbedf4ec7b75583402cb1a6aac0b4ff6437337e4 WHIRLPOOL 096b537ee484e447017c3cb846d0eb5875225558c10efed3a9236aa78d55cec8e18f595aba27eb9dfb1fa025792b108340d278e80f7f90c2eef75f5cd78a36cf
+DIST pymca4.6.2-src.tgz 15979581 SHA256 c50d3a54cad633bac3ec361d1b3b63a78292f1ad4ed976e5206665edd76bc32d SHA512 e33188b446c399e50cf65ebca4bfeef34e1b7d99c331f670dc41ca204284fbba996a1c83bd12a2410a9972927aa9c92b42b5374c58c924b3a8583d4f37be6528 WHIRLPOOL 47f0491aa0e470661bea1aa247d1db730f1db7266f1d2be2272d08f203faa2a084bcb40d579861365ace26d2f94abe03485183eed03139ad7b697cf57bfa5324
+EBUILD PyMca-4.6.2-r1.ebuild 955 SHA256 e5f9bc774c1a9257b4a63c2df8f88fd91885bad97c0eda4d38be508619d2f3a0 SHA512 3f4c7c35cd9efadb5fac06bc0ef000d8687b77630d3d7165df4c1dfcb8e60d2ed1ce17332646041a7668bb699c23cd7555bd0e7a638e84dac60ddef2316aea8d WHIRLPOOL ccf020cede7f4769e75d0806ac9dea67e4252be13e875e5d5459d0f355e3ef86c11c23de56aad903d0bf36e860cf51936d56350bba2aa525206271b763759f74
+MISC ChangeLog 2719 SHA256 3ec0ac52be69ecd61c301767cc28044aaadad7428a07c92867e650e72c3d5a43 SHA512 dc6114341951756fab7ea5ffad6946806e6dc66f916deef04aa983eb675d4f78ceffe4f8b6cc6db7dcf06f0f8da6cae0cb2793d088d51b329e236a2aa4a955ab WHIRLPOOL d5e806ac7fbc4be68f668b07d9b5eaa4eb3ad7f6844c3fdc8620c48d2efce0b4aa95935789315b1e589d7eabfd7c21cad4f342848966638b54b1d355fcf886a9
+MISC ChangeLog-2015 1258 SHA256 73b1bc98a54fa96f00c678d3c7bce9052acc38eeb27bf045ddca2bdadb614307 SHA512 310a562adb6407a849c303020f680dc86c403fb9e7197afdab5a15dcdbd0fc76194baf51bf60002862679d76b568981438931f5f14b8d31572713b59bdc2aa69 WHIRLPOOL 8aa527f339006ee7aaf0161129811b9d4cdc8c3577fb2a6c5c73a759ed229de7173644984dfb87bd336767f1bc33abab800d3e94bef4b1dca279b9dbadab7379
+MISC metadata.xml 858 SHA256 a82d6768ea0415df92baa043ae0486040f70d99dd305879db54da5ccd84ec4ab SHA512 bc8e357b6c327c215134e6535de7d6349a8498efa9e5a0a156e7f760f8c9376e8c7c8dbdd83ae2ed0861def6b0cbd6f072be67199dce6eb2de5391c7b743a651 WHIRLPOOL 41b7345552bb2214d583f1f12fb7f136562e605e9f94a3e71dfadea7a2b0713cef3572c0a08dbf218011c713b4e1d93c7c1f44d499e9491cad8c6e1cd95998ca
diff --git a/sci-chemistry/PyMca/PyMca-4.6.2-r1.ebuild b/sci-chemistry/PyMca/PyMca-4.6.2-r1.ebuild
new file mode 100644
index 000000000000..1f2caf4c70f0
--- /dev/null
+++ b/sci-chemistry/PyMca/PyMca-4.6.2-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PV="${PV/_}"
+
+DESCRIPTION="X-ray Fluorescence Toolkit"
+HOMEPAGE="http://pymca.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/pymca/pymca/${PN}${PV/_p1}/pymca${MY_PV}-src.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="X hdf5 matplotlib"
+
+DEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pyopengl[${PYTHON_USEDEP}]
+ dev-python/sip[${PYTHON_USEDEP}]
+ virtual/opengl
+ X? (
+ dev-python/PyQt4[${PYTHON_USEDEP}]
+ dev-python/pyqwt[${PYTHON_USEDEP}]
+ )
+ hdf5? ( dev-python/h5py[${PYTHON_USEDEP}] )
+ matplotlib? ( dev-python/matplotlib[${PYTHON_USEDEP}] )"
+RDEPEND="${DEPEND}"
+
+#S="${WORKDIR}/${PN}${MY_PV}"
+
+python_prepare_all() {
+ local PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+ export SPECFILE_USE_GNU_SOURCE=1
+ distutils-r1_python_prepare_all
+}
diff --git a/sci-chemistry/PyMca/files/PyMca-4.6.2-gentoo.patch b/sci-chemistry/PyMca/files/PyMca-4.6.2-gentoo.patch
new file mode 100644
index 000000000000..81dfaf038fa6
--- /dev/null
+++ b/sci-chemistry/PyMca/files/PyMca-4.6.2-gentoo.patch
@@ -0,0 +1,16 @@
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index 0a77cdf..e7ba643 100644
+--- a/setup.py
++++ b/setup.py
+@@ -55,7 +55,7 @@ packages = ['PyMca','PyMca.PyMcaPlugins', 'PyMca.tests']
+ py_modules = []
+
+ # Specify all the required PyMca data
+-data_files = [(PYMCA_DATA_DIR, ['LICENSE.GPL',
++data_files = [(PYMCA_DATA_DIR, [
+ 'PyMca/PyMcaData/Scofield1973.dict',
+ 'changelog.txt',
+ 'PyMca/PyMcaData/McaTheory.cfg',
diff --git a/sci-chemistry/PyMca/metadata.xml b/sci-chemistry/PyMca/metadata.xml
new file mode 100644
index 000000000000..4067b2f8b26a
--- /dev/null
+++ b/sci-chemistry/PyMca/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-chemistry@gentoo.org</email>
+ <name>Gentoo Chemistry Project</name>
+ </maintainer>
+ <longdescription>
+The PyMca Toolkit is a collection of Python tools for visualization and
+analysis of energy-dispersive X-ray fluorescence data. It builds its graphic
+interface and plotting routines on top of the C++ libraries Qt and Qwt
+through their respective Python bindings PyQt and PyQwt. Nevertheless,
+the data analysis routines can be used independently of any graphical
+interface.
+</longdescription>
+ <use>
+ <flag name="matplotlib">Support for plotting through matplotlib</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">pymca</remote-id>
+ </upstream>
+</pkgmetadata>