summaryrefslogtreecommitdiff
path: root/sci-chemistry/GromacsWrapper
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /sci-chemistry/GromacsWrapper
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'sci-chemistry/GromacsWrapper')
-rw-r--r--sci-chemistry/GromacsWrapper/GromacsWrapper-0.8.0.ebuild11
-rw-r--r--sci-chemistry/GromacsWrapper/Manifest3
-rw-r--r--sci-chemistry/GromacsWrapper/files/GromacsWrapper-0.8.0-tests-package.patch11
3 files changed, 23 insertions, 2 deletions
diff --git a/sci-chemistry/GromacsWrapper/GromacsWrapper-0.8.0.ebuild b/sci-chemistry/GromacsWrapper/GromacsWrapper-0.8.0.ebuild
index b80d49a156d5..b1ef5b96a7f5 100644
--- a/sci-chemistry/GromacsWrapper/GromacsWrapper-0.8.0.ebuild
+++ b/sci-chemistry/GromacsWrapper/GromacsWrapper-0.8.0.ebuild
@@ -30,5 +30,14 @@ BDEPEND="
dev-python/six[${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/matplotlib[${PYTHON_USEDEP}]
- sci-libs/numkit[${PYTHON_USEDEP}]"
+ sci-libs/numkit[${PYTHON_USEDEP}]
+ test? ( >=dev-python/pandas-0.17[${PYTHON_USEDEP}] )
+"
RDEPEND="${DEPEND}"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ # https://github.com/Becksteinlab/GromacsWrapper/issues/182
+ "${FILESDIR}"/${P}-tests-package.patch
+)
diff --git a/sci-chemistry/GromacsWrapper/Manifest b/sci-chemistry/GromacsWrapper/Manifest
index a32e2fcfe299..eb977dabdc95 100644
--- a/sci-chemistry/GromacsWrapper/Manifest
+++ b/sci-chemistry/GromacsWrapper/Manifest
@@ -1,3 +1,4 @@
+AUX GromacsWrapper-0.8.0-tests-package.patch 594 BLAKE2B 6b2c7c1aebebfbb5222c84e67805806aae714b8c96cbaad568b7ecb2959e38d504ea5a18a1de4bfcbfeea4488b04182d1cdbd0664511bfeb3cae2bd27534e8f7 SHA512 92b0232092ee9230050c114906ea61136d03de7b417d7267ef194c751bc801ab6f35d882681c36bb28949cddbea5e3c1c413df6ec949a073fcccd59b5433fefa
DIST GromacsWrapper-0.8.0.tar.gz 1205837 BLAKE2B 3627e56df0dc6ba86caac67795416c7c8c187aaa4fac545600d17dcd799cb153feaab61a0f0632e051c4e9c0b4cd74f8e165156873e36bc53571bec78e5fca61 SHA512 da7215216c9a2b52094bb7e43e04f1b429c4893ba67b4bd850fe68e99f338813392fd9d0aa1b19d3398c694be964bc2badbf1b3623420da929ee4abcef18026f
-EBUILD GromacsWrapper-0.8.0.ebuild 805 BLAKE2B c9da6368860e869a1f04ffc41397fb2992f8dbe28853bcab466d695efaedd7dae686d52f66e31433d39b643e1cddb693f39006991eb4eefd26819268f272d6c5 SHA512 e073d97ecb08684ef9b2631cca3693708ea291e2bb423930eeea31f8107e03b466ce8cd3321bea1faf12665572af2ceb070edeed3cbc789aac69ea6b5a043bdb
+EBUILD GromacsWrapper-0.8.0.ebuild 1005 BLAKE2B 22614a2f5ad1dcb8620062bbde91237e0c137f86f6868d90f2bd7dd1d45e4e3e6a31cb6dee86d14fadff3170d8bad2d629210290809343efcaedc40454bf2fff SHA512 34a182a20c407e8cf78344d813e9129bb175941c0513f86cbc66fbea5cd5e3bc53c8a0cdd6ebea0ef24fb3cbdd52b1f0ada94ed50de1bf30d831ca63c392e481
MISC metadata.xml 482 BLAKE2B 2745b575ac325e9f8c53d53026ca0c67201f1519725c572813c0ad281b4a39399cbf93176e816646aa83f829c0981ee4457e3ab2232ed095f76d5a2068840912 SHA512 4f2efb8d263f20e50928e0c6f0913c65da746b5253a14658273c830b7f95ecc15620f92e87db9670adfd92792e96cc352af528ed4fa1e874977a744d2e15c6bf
diff --git a/sci-chemistry/GromacsWrapper/files/GromacsWrapper-0.8.0-tests-package.patch b/sci-chemistry/GromacsWrapper/files/GromacsWrapper-0.8.0-tests-package.patch
new file mode 100644
index 000000000000..ee28e09e7741
--- /dev/null
+++ b/sci-chemistry/GromacsWrapper/files/GromacsWrapper-0.8.0-tests-package.patch
@@ -0,0 +1,11 @@
+--- a/setup.py.old 2020-06-06 21:50:25.432740405 +0200
++++ b/setup.py 2020-06-06 21:50:43.109010442 +0200
+@@ -35,7 +35,7 @@
+ 'Topic :: Scientific/Engineering :: Chemistry',
+ 'Topic :: Software Development :: Libraries :: Python Modules',
+ ],
+- packages=find_packages(exclude=['tests','scripts','extras','doc/examples']),
++ packages=find_packages(exclude=['tests','tests.*','scripts','extras','doc/examples']),
+ scripts = [
+ 'scripts/gw-join_parts.py',
+ 'scripts/gw-merge_topologies.py',