summaryrefslogtreecommitdiff
path: root/sci-calculators
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
commitb2be182d49eea46686b5cf2680d457df61e89dc4 (patch)
treec66442ced2011c5ca81c3114cc51041e314c6d33 /sci-calculators
parente23cdda4dbb0c83b9e682ab5e916085a35203da5 (diff)
gentoo resync : 30.06.2018
Diffstat (limited to 'sci-calculators')
-rw-r--r--sci-calculators/Manifest.gzbin3033 -> 3034 bytes
-rw-r--r--sci-calculators/units/Manifest3
-rw-r--r--sci-calculators/units/files/units-2.17-network-sandbox.patch11
-rw-r--r--sci-calculators/units/units-2.17.ebuild63
4 files changed, 77 insertions, 0 deletions
diff --git a/sci-calculators/Manifest.gz b/sci-calculators/Manifest.gz
index e404e88e6cda..9c348dda195b 100644
--- a/sci-calculators/Manifest.gz
+++ b/sci-calculators/Manifest.gz
Binary files differ
diff --git a/sci-calculators/units/Manifest b/sci-calculators/units/Manifest
index c8ef3aeee5fe..3bcf69ed2abb 100644
--- a/sci-calculators/units/Manifest
+++ b/sci-calculators/units/Manifest
@@ -1,3 +1,6 @@
+AUX units-2.17-network-sandbox.patch 469 BLAKE2B 800ffebb2bf096fac9ca94672caa457a08ddbe98e85cd3c195c149215de8753aa72fec618ccf4bdf584002c507cc53532ee92af6e8097c7fa2573628de34b17c SHA512 f54fb5d006263f89ff8c376f100066d79883b68a30441e8665ca4d8a6aa061e5c697c715ccb93c67a692145a44a441862039e5249e4795159f1c43a12ffe1c97
DIST units-2.16.tar.gz 1178197 BLAKE2B 6de569cd70c8067be053c5acb0885f898b76252bf6bafbea5f8b4972eca0acb13adfb4b2bc70ef0a3df747ee31084076fea3d3199922f0c44fc8c6d08232192b SHA512 afca2bf313208db2d0a3f4e96fed7bb86a3e96030b420e1cfa68a140499b9a8f2ef8c166c1d608d03c9ca6260199569a67c67c623d8c6a4b8d52e9d5cb6e3091
+DIST units-2.17.tar.gz 1185070 BLAKE2B 44db938b214596058cdfaeda7fd8d70161221c196a0971b5a0e03331e30fdeb52db85ab43b721f25efd755f4baee4f92aa6204a85d38703a31ec7cac0cefd689 SHA512 e4114f7dc0e40146f969375511c5d930497cb9502306ef82feac78c8e09a03e84ed0b582ff82e2878beae41702c9612f7a3d28fc6e9ed2cfae708f9feb8b737b
EBUILD units-2.16.ebuild 1301 BLAKE2B c2c88bf299514de215d2a14f446a4e119a81d392102bf690314e5c6117fc6440dc7095f1173b7a8f4f37169b765e02bd771bc4fc8f8f2f6b97652fcf7520f525 SHA512 78696d32f52f9590f8e31f8989a67d35f034bea82c564f5d6d1e2f360f4f5d429f22f99fb167158376a613d5bc258819608332feabc02a8cd01b70823de94ee2
+EBUILD units-2.17.ebuild 1411 BLAKE2B 38458bff4085643b793b6e65ad0ae6d18cddbab7a8e6aba78d4fe59f009612cffc1736d3ede883b58c7e660bc5b9e29cc33a65be11db0a9238af6bb150192e34 SHA512 a5b27e4b285ff4f8e841fe55dbdb7b03a21ce00b06873a86285898da49fe73d3b1e129ca78aa2d64445c1df9fc080a2cf6c1550bcd6cc62466971f2337ee36e7
MISC metadata.xml 341 BLAKE2B 60596aa39a0a3810573ced2896624fe01b49ed1138c942969bcd97884078cf69ace3d6cb4d0121de7d548da422a4b823982dc2771dea21817c207285b402ad2a SHA512 b32fc161804c8cd09f6b67923911ddfbdc9c5ba6e5dc61e951bbbe6fd54dd495209c519ead1dd46cb62cf5fd90978472f0d58ed2b66cc079c3ca91a36d22e822
diff --git a/sci-calculators/units/files/units-2.17-network-sandbox.patch b/sci-calculators/units/files/units-2.17-network-sandbox.patch
new file mode 100644
index 000000000000..e457610e430a
--- /dev/null
+++ b/sci-calculators/units/files/units-2.17-network-sandbox.patch
@@ -0,0 +1,11 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -107,7 +107,7 @@
+ -e "s@/usr/bin/python@$(PYTHON)@" \
+ $(srcdir)/units_cur > units_cur_inst
+
+-install-support: definitions.units units_cur_inst currency-units-update
++install-support: definitions.units units_cur_inst
+ $(MKDIR_P) $(DESTDIR)@UDAT@ $(DESTDIR)$(bindir) $(DESTDIR)@CDAT@
+ $(INSTALL_DATA) $(srcdir)/definitions.units $(DESTDIR)@UDAT@definitions.units
+ -rm -f $(DESTDIR)@UDAT@currency.units
diff --git a/sci-calculators/units/units-2.17.ebuild b/sci-calculators/units/units-2.17.ebuild
new file mode 100644
index 000000000000..01fbb74ef39d
--- /dev/null
+++ b/sci-calculators/units/units-2.17.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit eutils python-single-r1
+
+DESCRIPTION="Unit conversion program"
+HOMEPAGE="https://www.gnu.org/software/units/units.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="FDL-1.3 GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+units_cur"
+REQUIRED_USE="units_cur? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ sys-libs/readline:=
+ units_cur? (
+ ${PYTHON_DEPS}
+ dev-python/future[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="
+ ${RDEPEND}
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.17-network-sandbox.patch
+)
+
+pkg_setup() {
+ use units_cur && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ econf \
+ --sharedstatedir="${EROOT}/var/lib" \
+ ac_cv_path_PYTHON=no
+}
+
+src_compile() {
+ emake ${PN}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc ChangeLog NEWS README
+
+ # we're intentionally delaying this since 'make install' would
+ # get confused if we shove 'units_cur' there, and there is no real
+ # need to add more complexity for it
+ if use units_cur; then
+ sed \
+ -e "/^outfile/s|'.*'|'/usr/share/units/currency.units'|g" \
+ -e 's|^#!|&/usr/bin/python|g' \
+ units_cur_inst > units_cur || die
+ python_fix_shebang units_cur
+ python_doscript units_cur
+ fi
+}