summaryrefslogtreecommitdiff
path: root/sci-calculators/transcalc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /sci-calculators/transcalc
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'sci-calculators/transcalc')
-rw-r--r--sci-calculators/transcalc/Manifest3
-rw-r--r--sci-calculators/transcalc/files/transcalc-0.14-fno-common.patch70
-rw-r--r--sci-calculators/transcalc/transcalc-0.14-r2.ebuild14
3 files changed, 80 insertions, 7 deletions
diff --git a/sci-calculators/transcalc/Manifest b/sci-calculators/transcalc/Manifest
index 2c553bf23bee..03af049400e2 100644
--- a/sci-calculators/transcalc/Manifest
+++ b/sci-calculators/transcalc/Manifest
@@ -1,4 +1,5 @@
AUX transcalc-0.14-fd-perm.patch 596 BLAKE2B 4da82546d0c26e22dbed1817cefee3184bb41b7655636deeef929267422cf3ab283f2ed22f65713ae1c36b98b46ed7ac359fb8339b9443aec5f191788e03b07d SHA512 d63e4d8d5da77e97037d6014aa10a392778bdd1dfe0074ee61af94c3349c529ec965d2774e50c4ffae0fd76003429b64776fa7378d01e7a9608d1d4581b65eb5
+AUX transcalc-0.14-fno-common.patch 1529 BLAKE2B 89c6363d2846b6619b9e6b286076674b6cfeb75fbce9de4c016b8f0516fe0776854b1c5cc3af4a892553afaa67e46719cd54758f3e8dfc7a773075d775c1db54 SHA512 ee5f54c3b8c5df59acfb006f6baf849419a9c308170fd372e4d4ee82ed4f527ebfa9c72be38b78ff27ace89ca71ae51c66ebc49f973995155c2f975ccad6d07b
DIST transcalc-0.14.tar.gz 186434 BLAKE2B 7c2a031f34ab4b64af5be6203fca350356b75502ebdd94cce0f8338c266ff09a2cd68de80960f477228ddc4ffdd1acff84d6124506f52fd282ae0b28c949706e SHA512 b8c2cfbe3ea9787a2c694732baaf0e7c734f9a58c825f3791f21527f54398fcc79e24570d4f5f5c942b138b164cc6dc39744e0a66bafd888122608b641dcfa05
-EBUILD transcalc-0.14-r2.ebuild 688 BLAKE2B f2ec22a4018cc035074d1565d9ea2149623452a1e1ff8cd5fdc38554c5a46c691611bc09e30b9916f28b9885f2934f0c06efd84c39acf205764e6fecbc7e53bb SHA512 d0ecb26f7a8fdac51d853862e887df791504c2b60e83e206c7fcc540a4a80338ae2e5c353bb097635fd5ba5c0f1dc2b23699944fe3440662d7ef0ea2d1844ebe
+EBUILD transcalc-0.14-r2.ebuild 715 BLAKE2B a05a2e6d4f797b057ff10c5fd896f70b497753c14a5846beb07f6af27db8ed3fe42606a23e0d686f7a746fc20d11c02b7458ecfad00f5db40544bd982848d0b8 SHA512 ece5b6274621967c0e1ef92451a290e6cf707f3762d7144924d22c322d1bfac067ae86e70177a4278dd6934243191915d4017e34ca9752ae7623309ef1c53276
MISC metadata.xml 1350 BLAKE2B 61a9ea60e474c9cae8ba2d2e46da1e621fe352fd2c024a7ceea58067ed2fbe695e04706bb8601b28957b72d779b0f04f9a5cca70a16688c934725b57be4bb4b8 SHA512 b61dda04f6f3c913c381a201f1acd1c9bca0e73f690c2b65a279558cec6d88541611b02640cb7329b9f9f157d3bdc77106ef01c85a0cb9e3b6cd9e6c6fdcb7b7
diff --git a/sci-calculators/transcalc/files/transcalc-0.14-fno-common.patch b/sci-calculators/transcalc/files/transcalc-0.14-fno-common.patch
new file mode 100644
index 000000000000..1e9288c74b93
--- /dev/null
+++ b/sci-calculators/transcalc/files/transcalc-0.14-fno-common.patch
@@ -0,0 +1,70 @@
+--- a/src/transcalc.c
++++ b/src/transcalc.c
+@@ -37,6 +37,15 @@
+ extern gint trc_file_load (FILE *, short);
+
+ char version[] = "transcalc " VERSION;
++GtkWidget *main_body_window;
++GtkWidget *transtype_combo;
++
++short current_transtype;
++trans_win *twin;
++short statusint;
++trans_gui *tgui;
++gboolean statusexists;
++int main_window_width, main_window_height;
+
+
+ /*
+--- a/src/transcalc.h
++++ b/src/transcalc.h
+@@ -53,8 +53,8 @@
+ #endif /* HAVE_STRCPY */
+
+
+-GtkWidget *main_body_window;
+-GtkWidget *transtype_combo;
++extern GtkWidget *main_body_window;
++extern GtkWidget *transtype_combo;
+ /*GtkWidget *status;*/
+
+ #define MICROSTRIP 0
+@@ -163,12 +163,12 @@
+ gfloat electrical_params_value[NUMELECPARS];
+ } trans_value;
+
+-short current_transtype;
+-trans_win *twin;
+-short statusint;
+-trans_gui *tgui;
+-gboolean statusexists;
+-int main_window_width, main_window_height;
++extern short current_transtype;
++extern trans_win *twin;
++extern short statusint;
++extern trans_gui *tgui;
++extern gboolean statusexists;
++extern int main_window_width, main_window_height;
+
+ void error_mes(gchar * text);
+
+--- a/src/unitscombo.c
++++ b/src/unitscombo.c
+@@ -33,6 +33,7 @@
+ #include "transcalc.h"
+ #include "body.h"
+
++short length_unit, freq_unit, res_unit, ang_unit;
+
+ gchar *length_unit_name[] = { "mil",
+ "cm",
+--- a/src/units.h
++++ b/src/units.h
+@@ -77,6 +77,6 @@
+ #define ohm_to_kohm(a) (a/1000.0)
+ */
+
+-short length_unit, freq_unit, res_unit, ang_unit;
++extern short length_unit, freq_unit, res_unit, ang_unit;
+
+ #endif
diff --git a/sci-calculators/transcalc/transcalc-0.14-r2.ebuild b/sci-calculators/transcalc/transcalc-0.14-r2.ebuild
index 02376bc9ed7a..b6c144a8b7ff 100644
--- a/sci-calculators/transcalc/transcalc-0.14-r2.ebuild
+++ b/sci-calculators/transcalc/transcalc-0.14-r2.ebuild
@@ -1,28 +1,30 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
DESCRIPTION="Microwave and RF transmission line calculator"
HOMEPAGE="http://transcalc.sourceforge.net"
SRC_URI="http://transcalc.sourceforge.net/${P}.tar.gz"
LICENSE="GPL-2"
-
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
RDEPEND="x11-libs/gtk+:2"
DEPEND="${RDEPEND}"
# patch from debian
-PATCHES=( "${FILESDIR}"/${P}-fd-perm.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-fd-perm.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+)
src_prepare() {
+ default
+
# respect flags
sed -i -e 's|^CFLAGS=|#CFLAGS=|g' configure || die
- default
# syntax errors
sed -i \
-e 's/ythesize/ynthesize/g' \