summaryrefslogtreecommitdiff
path: root/sci-calculators/bc-gh
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-08 12:25:04 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-08 12:25:04 +0100
commita5442e2318cb4df55867389654e322dbac82067e (patch)
tree6ee33490658219395df804dbba0ea77f8b0d8c3b /sci-calculators/bc-gh
parent5d8ffbc273ca664e15618d557ced3e02de1a884b (diff)
gentoo auto-resync : 08:07:2024 - 12:25:03
Diffstat (limited to 'sci-calculators/bc-gh')
-rw-r--r--sci-calculators/bc-gh/Manifest2
-rw-r--r--sci-calculators/bc-gh/bc-gh-6.7.6.ebuild77
2 files changed, 79 insertions, 0 deletions
diff --git a/sci-calculators/bc-gh/Manifest b/sci-calculators/bc-gh/Manifest
index 2a8a4d7af5a1..73cca15419e7 100644
--- a/sci-calculators/bc-gh/Manifest
+++ b/sci-calculators/bc-gh/Manifest
@@ -1,5 +1,7 @@
DIST bc-6.5.0.tar.xz 461380 BLAKE2B e4aa633162d03fc5723e967ba81f985ab1b16e47b3c9a3ca1c32e9a717db682ce88cc6ba453d5e9b09539dcb8ddbb258b7b7dbdd2e27279355e3c35028d56130 SHA512 1cb03038d828a0b10734c29931777add8b22f194c507b8ff538ec1aa52a2a97a4ac2733d72cdb0710fdc6937807074e929f7918c56aaf5be8fbe908ea7c5a401
DIST bc-6.7.5.tar.xz 468572 BLAKE2B 3942cfbbc2b8a307bc24b9f7c3e037bce374bd17332b236a8c76ccacef1177e36669b7f61944a5c5791b0a436dec171991cfc821526865a816fba91e65aa1f04 SHA512 5f689fd20801ea7ede725ae5dc4e8744bdf2d72424bffef99c53193a950f4bd83b6eb4c5a07556576d0b3f5b6cd7f9fc7cbcb41d27891f488bb2e97a186f76a4
+DIST bc-6.7.6.tar.xz 473104 BLAKE2B 447cf15d94e8800ad81d734efef5a6b4dfdc4930eeb0bff3a4c093e31d65a8449cf3e685af077ae3397a1a730c4345fb7e95c82446d09b692f4fd6ef6e90ea88 SHA512 418ce61e8151a548627b794692325f48c68f8cedca7a0cb8d896bb74510f55b33486214af0af1b160c1f387f3d034300dff6fbc29c2d44d7b304a7a37c3c478b
EBUILD bc-gh-6.5.0.ebuild 2275 BLAKE2B ad96e10f0e974cf9dbe4465573334748618481e0698fc864741a55023a9df84270dd2e7584a7fe167039d1c66b1858f7a0662355e7368099dd2cdec089f343cd SHA512 41024e56641fd3e8304696298ead92602b8274661499768d06d0131858dcca3a030ccc6a72bd379a01e679fd8ef76422c5b084989606eff6c8314c6b67bf0613
EBUILD bc-gh-6.7.5.ebuild 2285 BLAKE2B 6296180189c3adc0670b9129522f5e58baa046d9c541a48d77ca4edae79c7767d3a952328c7a9d1448c04cd45b986299a2757d0a499eb573b46ac0fb0a8e631a SHA512 d1b2397ca110e6568c8cbd4dedc9b9aeb0ca32251d19c647a5364b4f519968ad6d9b72daa590eb85407ae75706f3c2fbf7d81f07ba6e5dbc25a373940564987c
+EBUILD bc-gh-6.7.6.ebuild 2293 BLAKE2B 0b8c96f18fa30eb0299fed4d645937727eadbc954528cf30154e3f927602686760d1e98b30467f858ec8fc4f6c946d6d3676387ee5d4dca94cb0ebb9e6252233 SHA512 3d6dcb98e91ec4f50a4a3e56f4abc6fdeb1d5def53c69797b0d60fc7e1a3d3bbd596403e0777c97a0b1ca27c389fb000d8556f5ca8d22566f4dca002a2ee2b3d
MISC metadata.xml 1050 BLAKE2B 4cf9aabd9e7abf20b857131ada67346f356135f329d8367753778cb406bfd337e695cdc0cbbcd2e237e1cd9ea9cfd8b80fa7458a64a68aec2b0f24882203af98 SHA512 492f8fa1f9abe2da452bc9a5a8ccc29fda87322832bddc1b9c4f55013e549cfaf34f11fa9ea6cc71566e670727bda1899eda598196f20a8931d327b4b4ae6dfb
diff --git a/sci-calculators/bc-gh/bc-gh-6.7.6.ebuild b/sci-calculators/bc-gh/bc-gh-6.7.6.ebuild
new file mode 100644
index 000000000000..f60e406b8630
--- /dev/null
+++ b/sci-calculators/bc-gh/bc-gh-6.7.6.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo
+
+MY_P="bc-${PV}"
+DESCRIPTION="Implementation of POSIX bc with GNU extensions"
+HOMEPAGE="
+ https://git.gavinhoward.com/gavin/bc/
+ https://github.com/gavinhoward/bc/
+"
+SRC_URI="
+ https://github.com/gavinhoward/bc/releases/download/${PV}/${MY_P}.tar.xz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="libedit readline"
+
+DEPEND="
+ !readline? (
+ libedit? ( dev-libs/libedit:= )
+ )
+ readline? (
+ sys-libs/readline:=
+ sys-libs/ncurses:=
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+src_configure() {
+ local myconf=(
+ # GNU and BSD bc's have slightly different behavior. This bc can act
+ # like both, changing at runtime with environment variables, but it
+ # needs defaults, which can be set at compile time. This option sets all
+ # of the defaults to match the GNU bc/dc since it's common on Linux.
+ -pGNU
+ # A lot of test results are generated first by a bc compatible with the
+ # GNU bc. If there is no GNU bc installed, then those tests should be
+ # skipped. That's what this option does. Without it, we would have a
+ # dependency cycle. Those tests are super long, anyway.
+ -G
+ # Disables the automatic stripping of binaries.
+ -T
+ # Enables installing all locales, which is important for packages.
+ -l
+ # Disables some "problematic" tests that need specific options on Linux
+ # to not trigger the OOM killer because malloc() lies.
+ -P
+ )
+ if use readline ; then
+ myconf+=( -r )
+ elif use libedit ; then
+ myconf+=( -e )
+ fi
+
+ local -x EXECSUFFIX="-gh"
+ local -x PREFIX="${EPREFIX}/usr"
+ edo ./configure.sh "${myconf[@]}"
+}
+
+src_test() {
+ # This is to fix a bug encountered on Arch. It is to ensure we don't get
+ # segfaults on `make check` when the error messages change because the error
+ # messages are passed to printf(); they have format specifiers. With these
+ # env vars, the internal error messages are used, instead of the installed
+ # locales, which might be different since the new locale files are not
+ # installed yet. (It is impossible to use uninstalled locales because of the
+ # poor design of POSIX locales.)
+ env LANG=C LC_ALL=C emake check
+}