summaryrefslogtreecommitdiff
path: root/sci-biology
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-29 03:22:09 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-29 03:22:09 +0100
commitd4bd6695641f6d2ec7ff8681913d304e995902f5 (patch)
tree6ec8d4c38152bb4f2bb4b93277236ebd9fbbd21d /sci-biology
parent22910f5d14da606bd7f06e19a2f61c5d1a8fc94b (diff)
gentoo resync : 29.05.2018
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/Manifest.gzbin25288 -> 25282 bytes
-rw-r--r--sci-biology/biopython/Manifest2
-rw-r--r--sci-biology/biopython/biopython-1.71.ebuild57
3 files changed, 59 insertions, 0 deletions
diff --git a/sci-biology/Manifest.gz b/sci-biology/Manifest.gz
index 4f957c1a1f3e..c4c1fe2b921e 100644
--- a/sci-biology/Manifest.gz
+++ b/sci-biology/Manifest.gz
Binary files differ
diff --git a/sci-biology/biopython/Manifest b/sci-biology/biopython/Manifest
index 86e017fc57d6..2296f9956824 100644
--- a/sci-biology/biopython/Manifest
+++ b/sci-biology/biopython/Manifest
@@ -1,3 +1,5 @@
DIST biopython-1.68.tar.gz 14445813 BLAKE2B 566931c4e522e95278f7f6a9dc07ecc091dc54b69cdea8bb07603339af4f1fd38e3df87482e97729acb776dd2df19a4e61d49ee7608ec5cb0f24966e28c2e3dd SHA512 0ca994475654bb68ff326c8e86cbd4547cd87b42e1633dda039ad668e1298884b22e169f6b25ab514e929861334a93b7db6d057a3486cea9997ca2de95c61a69
+DIST biopython-1.71.tar.gz 16031832 BLAKE2B 2062065b77fc35ea8a3f09ec967482c233a6e0bbfc7d09187ff5e892848b45fa7bd6d7b6027b38c3d4c9a9c601785521fa7edb91fa960b46c8e49aed91b1f5dc SHA512 003955e92295e98526c88abb573db9bdc37877fc41395551b541e7106ffa603327a36c6f4d999838c0be38b378901235c9dbd7cb7fc25c14a5d7001939fe23bd
EBUILD biopython-1.68.ebuild 1641 BLAKE2B a66e9c4a4c4987809faa18742b345fad45c6c6e536c1a87dfc552345637f1b7df28426a314df4b2f7e523002229395e978b75548b907f0a7aac6d80ee893d1b3 SHA512 e30c9f8b542ef0508a6fea508461521cbdc140a0c1e1f08eddfaef6dd73c10496f1d2fdc26261c26a5c860ffba845c1e6bb6f82d8722d0c7a1a89253c3a7a7f1
+EBUILD biopython-1.71.ebuild 1623 BLAKE2B 8e9b6b414402fa1317c13cee899a760a51bd45c9bedeff18785681229eceacc4e2e61a8ebe7d801b3716d1b11027cce3dfc16af237fa98c3bcf4bdce410d65bd SHA512 fc968c0003f23ca77244ff41a54cae9ad389a297f70a9ef9b04e79085120a5a5c963c13088140f30fbd971cde10574f6d3a94127acea78881242aa9e4c97b4eb
MISC metadata.xml 267 BLAKE2B 7cf386952842945148119de3263231db4d1046d5f54811f7e303ed8ec4d27cbc1960b99c92daf6f32e5b981c2fb9f50ec666be6193865d6e18541b7427a152a9 SHA512 91ab266d9ab24401bc0fec759c5b6cfcf44a3c5669fc31c7301d79770839bb5dfa0e155d949392ef06176b4a0b2c32b91b1b54b0027f972db61f0a5e54644403
diff --git a/sci-biology/biopython/biopython-1.71.ebuild b/sci-biology/biopython/biopython-1.71.ebuild
new file mode 100644
index 000000000000..f770b57a2a62
--- /dev/null
+++ b/sci-biology/biopython/biopython-1.71.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Python modules for computational molecular biology"
+HOMEPAGE="https://www.biopython.org/ https://pypi.org/project/biopython/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/rdflib[${PYTHON_USEDEP}]
+ dev-python/pygraphviz[${PYTHON_USEDEP}]
+ dev-python/reportlab[${PYTHON_USEDEP}]
+ dev-python/pydot[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ sys-devel/flex"
+
+DOCS=( CONTRIB DEPRECATED NEWS README Doc/. )
+
+python_test() {
+ distutils_install_for_testing
+ cp -r "${S}"/{Doc,Tests} "${TEST_DIR}"/lib/ || die
+ cd "${TEST_DIR}"/lib/Tests || die
+ rm test_BioSQL_{psycopg2.py,MySQLdb.py,mysql_connector.py} || die
+ "${EPYTHON}" run_tests.py --offline --verbose || die
+}
+
+python_install_all() {
+ # remove files causing ecompressdir to fail
+ rm Doc/examples/ls_orchid.gbk.bz2 || die
+
+ distutils-r1_python_install_all
+
+ dodir /usr/share/${PN}
+ cp -r --preserve=mode Scripts Tests "${ED}"/usr/share/${PN} || die
+}
+
+pkg_postinst() {
+ elog "For database support you need to install:"
+ optfeature "MySQL" dev-python/mysql-python
+ optfeature "PostGreSQL" dev-python/psycopg
+
+ elog "Some applications need extra packages:"
+ optfeature "EMBOSS (The European Molecular Biology Open Software Suite)" sci-biology/emboss
+}