summaryrefslogtreecommitdiff
path: root/sci-biology
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
commit8d5dbd847cbc704a6a06405856e94b461011afe3 (patch)
tree4d26462d027b14926335894749d2e01d982234d0 /sci-biology
parent5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (diff)
gentoo resync : 27.03.2021
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/Manifest.gzbin22459 -> 22464 bytes
-rw-r--r--sci-biology/bioperl-db/Manifest2
-rw-r--r--sci-biology/bioperl-db/bioperl-db-1.6.9-r1.ebuild43
3 files changed, 30 insertions, 15 deletions
diff --git a/sci-biology/Manifest.gz b/sci-biology/Manifest.gz
index 38ad9f401679..9a4bd8a29d2d 100644
--- a/sci-biology/Manifest.gz
+++ b/sci-biology/Manifest.gz
Binary files differ
diff --git a/sci-biology/bioperl-db/Manifest b/sci-biology/bioperl-db/Manifest
index 0366b2b51a3a..736dba951e3b 100644
--- a/sci-biology/bioperl-db/Manifest
+++ b/sci-biology/bioperl-db/Manifest
@@ -1,5 +1,5 @@
AUX bioperl-db-1.6.9-db.patch 1567 BLAKE2B 40a1ba874e745630d886d0531ab90385bb2207073bebc823c52f595fa4752b0b9bf310adf7148ba4c7c5c1ec19ddec226d28a34311c932a0f37da6af1c0dd422 SHA512 a0a2ca951645b70b2e4eb3390598b2a42d6631109500238d6fc482d97a616ec1881738e5dc9af118d37fdf50657916ff275124f409510cf15515dfbc829766c0
DIST BioPerl-DB-1.006900.tar.gz 492799 BLAKE2B fb923533ecdb74e868a3aef0c0c6ba8da419ae3c0e9d2e8c55297aad15563b135b6b00fd158481b31dcacd1125f7e10a557052bd4b04eed3a400c972653ff757 SHA512 e06b8b9aa4188a83128f910d7b4a031f69d36f75e4f2d7210357366379024ef39b58eca97112b5b419f141c82b7518086273cc97c9637382ee5e0ddb9ce28746
-EBUILD bioperl-db-1.6.9-r1.ebuild 2024 BLAKE2B ca465f670dae58a8deea0c1ef3ce9deb9a4fe5515ffae41850db8e20c41b57960a7fa0d7ddc0aace635fbf56f469c45604e9386639458590548e8fe3aa14b3b5 SHA512 91814c0b622e2390ac3db18bed47d4ea5f02f7fe493a668bab9a5de4ec3735c64385d4b11ca21d34a05f476e30b7fce7100b3fab77d51607b78804f9b23451e0
+EBUILD bioperl-db-1.6.9-r1.ebuild 2339 BLAKE2B bf75bec28a465d2bf74bf3ec7e136a9765a6a8941a32f74b32df08dcca200b3c3c165ed9347472fd525ecfece5eb3c4a240759c72fa2fa1e62e335e438256b05 SHA512 6fdb57934f91d44b07500abded74c10d0de01461176edf854547af56de2e2c80b4812a94a1b0f430265642a6273e6a013f78664e3ba61a85bd8ac099fab91d5c
EBUILD bioperl-db-1.6.9.ebuild 914 BLAKE2B 8c295e576c35b00754492c715255fd1816bde6d8477e068f2796b96dfa251d24f24f8f260362d89a8cda4881fd4fb1aba204315105422a6c024f0b6a9f083917 SHA512 0d555ef35d5a6e9fda3a48ffc3c7437ad52110c8c9f2a223f103c15c6a866c6c776b7c8d0b1c5c1848336263c64a6e79f80ba476d6205e8f3a90788236ff13e8
MISC metadata.xml 344 BLAKE2B 9a757119f1a9939d57a4f9517b8dd5d68732419d7365fda69af107719aa0dba15c79ac16c746cfe28ce36beb060aaa867bffb078175da25961f9f8b233634d34 SHA512 a477289255247669c332915665c4d414ba2857b5716a60e8aec1bf8d1c38009c9fcfb7421a02bdbd9ad566be32bf2b21f57fd21c745aa62185d5dcd13d78bf70
diff --git a/sci-biology/bioperl-db/bioperl-db-1.6.9-r1.ebuild b/sci-biology/bioperl-db/bioperl-db-1.6.9-r1.ebuild
index facab7d5ffbe..020fb2921745 100644
--- a/sci-biology/bioperl-db/bioperl-db-1.6.9-r1.ebuild
+++ b/sci-biology/bioperl-db/bioperl-db-1.6.9-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -49,6 +49,10 @@ src_test() {
ebegin "Setting up test database"
+ local mysql_install_db="${EPREFIX}/usr/share/mariadb/scripts/mysql_install_db"
+ [[ ! -x "${mysql_install_db}" ]] && mysql_install_db="${EPREFIX}/usr/bin/mysql_install_db"
+ [[ ! -x "${mysql_install_db}" ]] && die "mysql_install_db command not found!"
+
local mysqld="${EPREFIX}/usr/sbin/mysqld"
local socket="${T}/mysql.sock"
local pidfile="${T}/mysql.pid"
@@ -58,24 +62,35 @@ src_test() {
mkdir -p "${datadir}" || die "Can't make mysql database dir";
chmod 755 "${datadir}" || die "Can't fix mysql database dir perms";
- if $mysqld --help | grep -q MariaDB ; then
- "${EPREFIX}"/usr/share/mysql/scripts/mysql_install_db \
- --basedir="${EPREFIX}/usr" \
- --datadir="${datadir}" \
- --user=$(whoami) || die "Can't initalize database"
- fi
-
- ${mysqld} --no-defaults --user=$(whoami) --skip-networking \
- --socket="${socket}" \
- --pid-file="${pidfile}" \
- --datadir="${datadir}" &
- maxtry=20
+ "${mysql_install_db}" \
+ --basedir="${EPREFIX}/usr" \
+ --datadir="${datadir}" \
+ --user=$(whoami) \
+ || die "Failed to initalize test database"
+
+ "${mysqld}" \
+ --no-defaults \
+ --user=$(whoami) \
+ --skip-networking \
+ --skip-grant \
+ --socket="${socket}" \
+ --pid-file="${pidfile}" \
+ --datadir="${datadir}" &
+
+ local maxtry=20
while ! [[ -S "${socket}" || "${maxtry}" -lt 1 ]] ; do
maxtry=$((${maxtry}-1))
echo -n "."
sleep 1
done
- eend $?
+
+ local rc=1
+ [[ -S "${socket}" ]] && rc=0
+
+ eend ${rc}
+
+ [[ ${rc} -ne 0 ]] && die "Failed to start mysqld test instance"
+
export MYSQL_UNIX_PORT="${socket}"
perl-module_src_test
ebegin "Shutting down mysql test database"