summaryrefslogtreecommitdiff
path: root/sci-biology
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-17 20:03:52 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-17 20:03:52 +0000
commit4935506e9a5cbfabd37c64093eac5f36c2ff0017 (patch)
treeaf9dd93ea349eacaf28286c7c45c7a083b0b7c31 /sci-biology
parent434d713861b70f6c6563d6ee50a8e64f14c970d9 (diff)
gentoo resync : 17.02.2018
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/Manifest.gzbin25456 -> 25448 bytes
-rw-r--r--sci-biology/phylip/Manifest1
-rw-r--r--sci-biology/phylip/phylip-3.696-r2.ebuild55
3 files changed, 56 insertions, 0 deletions
diff --git a/sci-biology/Manifest.gz b/sci-biology/Manifest.gz
index 9a5f4f97aa06..ec4f5e09ff11 100644
--- a/sci-biology/Manifest.gz
+++ b/sci-biology/Manifest.gz
Binary files differ
diff --git a/sci-biology/phylip/Manifest b/sci-biology/phylip/Manifest
index a015a4f2496c..edaa0919bf69 100644
--- a/sci-biology/phylip/Manifest
+++ b/sci-biology/phylip/Manifest
@@ -3,4 +3,5 @@ DIST phylip-3.69.tar.gz 1511935 BLAKE2B 76aa5a79d2553c6f269c011f633d1101ee4d85ac
DIST phylip-3.696.tar.gz 3955721 BLAKE2B dc75fc442eb63e44bc2e68e5dc97b3ff8f741bfa53740ed57ca114b53dcb71db9baeb9a96c3e693f7fae92afbaa71c7b5acfb39e7770bacb6aafa8c33b355be6 SHA512 711a9a34be72b0f63c746733cd1384f091b7cc597dbd9a40c130e074efbf0a0ecc30e5a6b3452bb73dc69cddbdae2fc07d1c0a68f0be207471eab73ab876c6be
EBUILD phylip-3.69-r1.ebuild 1142 BLAKE2B 314baf63e3cf102ebe7d524fb1795ff9e1a85a4e5b0c2d54a11e7bb85d8cd0500a2e55c3c9ad46c74bdc0fbd0242afb2f7086ddb84891eb94918faf786e99d06 SHA512 b7d6638ddc1a035132507918dd49e82e41e450ca31b8e6afbf646e69ce29690b5be74795a108a03eaf79399bc909031d844f664e072861f4cc656aaa0b8946c7
EBUILD phylip-3.696-r1.ebuild 1134 BLAKE2B 4c7dd5c2f3c4d3a6df4f0894c7c59b962d7289ff720887e97e51410722c43949dca349f7b6b49407975fa53e149a919f9009799a9f30d6fb5a2043b51fff7955 SHA512 ef7196f540a1bf981dd1d2489fc2cba31fd0ea3135f060331f8f1ba43ce585ae4c6d33cc76f53d561c1c36059c631303caeaa20c28ada2c02ce218119a202872
+EBUILD phylip-3.696-r2.ebuild 1208 BLAKE2B 708b9651012a28d5f1d7b425364144cb6bbaf278245d4c46a9932b86020199d327456f62e57ba791dc39221d66e993166d6e39bb7a990c02ebbb7d97772ed4ce SHA512 e84c5b74d63d51d4151c097eaaea814d2ba0e25ea16aee1f30f9cf57d4ff3207a4090b942ca09f835f5fc81fd460b04623c8d49e2406f0f9ef7c210178be8dda
MISC metadata.xml 267 BLAKE2B 7cf386952842945148119de3263231db4d1046d5f54811f7e303ed8ec4d27cbc1960b99c92daf6f32e5b981c2fb9f50ec666be6193865d6e18541b7427a152a9 SHA512 91ab266d9ab24401bc0fec759c5b6cfcf44a3c5669fc31c7301d79770839bb5dfa0e155d949392ef06176b4a0b2c32b91b1b54b0027f972db61f0a5e54644403
diff --git a/sci-biology/phylip/phylip-3.696-r2.ebuild b/sci-biology/phylip/phylip-3.696-r2.ebuild
new file mode 100644
index 000000000000..c19085ed6cfe
--- /dev/null
+++ b/sci-biology/phylip/phylip-3.696-r2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION=" The PHYLogeny Inference Package"
+HOMEPAGE="http://evolution.genetics.washington.edu/phylip.html"
+SRC_URI="http://evolution.gs.washington.edu/${PN}/download/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD-2"
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+# 'mix' tool collides with dev-lang/elixir, bug #537514
+RDEPEND="x11-libs/libXaw
+ !!dev-lang/elixir"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+S="${WORKDIR}/${P}/src"
+
+src_prepare() {
+ mv Makefile.unx Makefile || die
+ sed \
+ -e "/ -o /s:\(\$(CC)\):\1 ${LDFLAGS}:g" \
+ -i Makefile || die "Patching Makefile failed."
+ mkdir ../fonts || die
+}
+
+src_compile() {
+ emake -j1 \
+ CC="$(tc-getCC)" \
+ DC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -Wno-unused-result" \
+ all put
+}
+
+src_install() {
+ cd "${WORKDIR}/${P}" || die
+
+ mv exe/font* fonts || die "Font move failed."
+ mv exe/factor exe/factor-${PN} || die "Renaming factor failed."
+
+ dolib.so exe/*so && rm exe/*so || die
+ dobin exe/*
+
+ dodoc "${FILESDIR}"/README.Gentoo
+
+ dohtml -r phylip.html doc
+
+ insinto /usr/share/${PN}/
+ doins -r fonts
+}