summaryrefslogtreecommitdiff
path: root/sci-biology/uchime/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
commit7218e1b46bceac05841e90472501742d905fb3fc (patch)
tree56fae051db521b8fce8014cbc8b11484885b14b3 /sci-biology/uchime/files
parent6d691ad5b6239929063441bbd14c489e92e7396e (diff)
gentoo resync : 12.03.2021
Diffstat (limited to 'sci-biology/uchime/files')
-rw-r--r--sci-biology/uchime/files/CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/sci-biology/uchime/files/CMakeLists.txt b/sci-biology/uchime/files/CMakeLists.txt
index 54b0a3ba0d30..a9319293e10b 100644
--- a/sci-biology/uchime/files/CMakeLists.txt
+++ b/sci-biology/uchime/files/CMakeLists.txt
@@ -1,11 +1,12 @@
-cmake_minimum_required(VERSION 2.6)
+cmake_minimum_required(VERSION 2.8.12)
project(UCHIME)
+include(GNUInstallDirs)
+
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -D_FILE_OFFSET_BITS=64 -DUCHIMES=1")
# Simply copy the source files from the mk script
add_executable(uchime
addtargets2.cpp alignchime.cpp alignchimel.cpp alnparams.cpp alpha.cpp alpha2.cpp fractid.cpp getparents.cpp globalalign2.cpp make3way.cpp mx.cpp myutils.cpp path.cpp searchchime.cpp seqdb.cpp setnucmx.cpp sfasta.cpp tracebackbit.cpp uchime_main.cpp usort.cpp viterbifast.cpp writechhit.cpp)
-INSTALL(TARGETS uchime
- DESTINATION bin)
+INSTALL(TARGETS uchime DESTINATION ${CMAKE_INSTALL_BINDIR})