summaryrefslogtreecommitdiff
path: root/sci-biology/psipred/psipred-3.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-biology/psipred/psipred-3.5.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-biology/psipred/psipred-3.5.ebuild')
-rw-r--r--sci-biology/psipred/psipred-3.5.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/sci-biology/psipred/psipred-3.5.ebuild b/sci-biology/psipred/psipred-3.5.ebuild
new file mode 100644
index 000000000000..7b71d435ae20
--- /dev/null
+++ b/sci-biology/psipred/psipred-3.5.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils prefix toolchain-funcs versionator
+
+#MY_P="${PN}$(delete_all_version_separators)"
+MY_P="${PN}${PV}"
+
+DESCRIPTION="Protein Secondary Structure Prediction"
+HOMEPAGE="http://bioinf.cs.ucl.ac.uk/psipred/"
+SRC_URI="
+ http://bioinf.cs.ucl.ac.uk/downloads/${PN}/${MY_P}.tar.gz
+ test? ( http://bioinfadmin.cs.ucl.ac.uk/downloads/psipred/old/data/tdbdata.tar.gz )"
+
+LICENSE="psipred"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ app-shells/tcsh
+ sci-biology/ncbi-tools
+ || ( sci-biology/update-blastdb sci-biology/ncbi-tools++ )"
+DEPEND=""
+
+S="${WORKDIR}"/${PN}
+
+src_prepare() {
+ rm -f bin/*
+ epatch \
+ "${FILESDIR}"/3.1-Makefile.patch \
+ "${FILESDIR}"/3.1-path.patch \
+ "${FILESDIR}"/3.2-fgets.patch
+ eprefixify runpsipred*
+ emake -C src clean
+}
+
+src_compile() {
+ emake -C src CC=$(tc-getCC)
+}
+
+src_install() {
+ emake -C src DESTDIR="${D}" install
+ dobin runpsipred* bin/* BLAST+/runpsipred*
+ insinto /usr/share/${PN}
+ doins -r data
+ dodoc README
+}
+
+pkg_postinst() {
+ elog "Please use the update_blastdb.pl in order to"
+ elog "maintain your own local blastdb"
+}