summaryrefslogtreecommitdiff
path: root/sci-biology/profphd/profphd-1.0.40.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-biology/profphd/profphd-1.0.40.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-biology/profphd/profphd-1.0.40.ebuild')
-rw-r--r--sci-biology/profphd/profphd-1.0.40.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sci-biology/profphd/profphd-1.0.40.ebuild b/sci-biology/profphd/profphd-1.0.40.ebuild
new file mode 100644
index 000000000000..8e24cebeb5f3
--- /dev/null
+++ b/sci-biology/profphd/profphd-1.0.40.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Secondary structure and solvent accessibility predictor"
+HOMEPAGE="https://rostlab.org/owiki/index.php/PROFphd_-_Secondary_Structure,_Solvent_Accessibility_and_Transmembrane_Helices_Prediction"
+SRC_URI="ftp://rostlab.org/profphd/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}
+ dev-perl/librg-utils-perl
+ sci-libs/profnet
+ sci-libs/profphd-utils
+"
+
+src_prepare() {
+ sed \
+ -e '/ln -s/s:prof$:profphd:g' \
+ -i src/prof/Makefile || die
+ epatch "${FILESDIR}"/${PN}-1.0.39-perl.patch
+}
+
+src_compile() {
+ emake prefix="${EPREFIX}/usr"
+}
+
+src_install() {
+ emake prefix="${EPREFIX}/usr" DESTDIR="${D}" install
+}