summaryrefslogtreecommitdiff
path: root/sci-biology/poa
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-23 21:50:52 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-23 21:50:52 +0100
commitba3d6ddada23eaa04f85228bee3438ab479b4442 (patch)
tree87c61faa67018943d552f24d91f0aeaece2b771e /sci-biology/poa
parent2e6d363c5e87569efc23848513e71f2233b7e9d9 (diff)
gentoo auto-resync : 23:10:2022 - 21:50:51
Diffstat (limited to 'sci-biology/poa')
-rw-r--r--sci-biology/poa/Manifest3
-rw-r--r--sci-biology/poa/files/poa-2-clang16.patch74
-rw-r--r--sci-biology/poa/poa-2-r1.ebuild3
3 files changed, 78 insertions, 2 deletions
diff --git a/sci-biology/poa/Manifest b/sci-biology/poa/Manifest
index b9b4d77ee43b..b867b628de1e 100644
--- a/sci-biology/poa/Manifest
+++ b/sci-biology/poa/Manifest
@@ -1,5 +1,6 @@
+AUX poa-2-clang16.patch 2406 BLAKE2B 24a49f9b9c3acc33541f7143250d871584c9bab2ec28a46cbaa7100377b9fcc3906490a4903b36d3f51e1fbcfd88f8182c477b3491a94dd3bdee3016be4e833d SHA512 dd2fd8e3e0f644648f93beea89784ee0008eeaae5231fd7c50f1cba2eb7327857c0be4cbc435d2dfd6834cf09b2f9d97d954a856142e06bfe44344ac80947477
AUX poa-2-fno-common.patch 357 BLAKE2B 5d239201e987f1fc45e82019a27b2c8e81015cd2b6b5b35f90838a8fff16bb08b51da5e6e9e1ac163bd6591341ba96a870fce4949a79e9ca558ce8c765d15ba4 SHA512 9d8f6552fd43a0f40da9cb7a5316e0e434df793fb9f7522b60e067061d14a7b27299feb02a8603cb4f6039b205723f562ea5c54c15ab3bd6582f2e6e7c223c43
AUX poa-2-respect-flags.patch 874 BLAKE2B ee278cdbc6ec0603bc28087bd008caa70fe39668360a1473891ed997bde93f31ef7586acc9137a23a4d3123047ce5b600c3d6418a89e1e62ca70545b99a3112b SHA512 95e2e7c43ba18f9238b379ea13d3a6004cf580c75d484dbe43f01c823484f84eb93c3d2fe1ae3c98583c51c660ab24e6dc580d132649adedbf30d8675d8107b0
DIST poaV2.tar.gz 62612 BLAKE2B 92f7b2926dd7fc93745411fc04c8dd3380c32e3e87cf89afa81aefe787a1aa0e7a416d08809cce531a21d5118398a9474a751a742ee1fca47e83bd907444e9c0 SHA512 2a54b025f0a74ff4c01828f3e4b9e8e135bffe26d08f651f981bc95a64196173b5d887ef988a25c1f5fbf89333b4771622d5dc93946d66e7ec9abacb6167595c
-EBUILD poa-2-r1.ebuild 857 BLAKE2B 436c6a4db2fa826ebb3f0a3d59df5d88f746a6c025f227be6b4916f7b6b34dde51013ae48355ea080dc19ba763972e62d3b1a87b17c19349ba0f3ed2df50409c SHA512 7fadf68dd86ac01c83eb65ef6e8512428b7c5fa84b1071f538458e46ff3116d02ff4f18a7d8e2bc32c360caee2bac2ca998a3a824442f662613a8808e893e7b7
+EBUILD poa-2-r1.ebuild 891 BLAKE2B 4c0e42af595a527f95ce4248146774a322fe7d1e2d309664c6dcd37c588511f0bfc33a1274dd96d89fd4780f69fc61641e6c1a7cdd4d03c6d445fb12dd7d58f0 SHA512 d89e34e9733879d1bce07d4d2f357cf1fa7b10461c407ba89640c674d4557d5e3ec34fc2537e1e31ce484bbe6ec898ce248b9de3243eca0c91e123d9969f8cc0
MISC metadata.xml 348 BLAKE2B a159034e493b50e7390db0516a4f478d14877323a256152eb9e596251cc71b161a38f9b740313f015ed2ef1757d0110d7e368eabf37b0e295d063d3770708ec7 SHA512 6452fa4eda03932e1ddfb7ac88b5b5dd4ea5429767ea06d1ac4db1df87e88159333a7c817f101b34975d20cb35d0b62f8947d658eba47ab917c0ecfa106f29d1
diff --git a/sci-biology/poa/files/poa-2-clang16.patch b/sci-biology/poa/files/poa-2-clang16.patch
new file mode 100644
index 000000000000..5399dd631f48
--- /dev/null
+++ b/sci-biology/poa/files/poa-2-clang16.patch
@@ -0,0 +1,74 @@
+--- a/black_flag.c
++++ b/black_flag.c
+@@ -82,7 +82,7 @@
+
+
+
+-int handle_crash_init(void (*crash_fun)())
++int handle_crash_init(void (*crash_fun)(int))
+ {
+ #define HANDLE_CRASH_MAX 5
+ int i,signal_type[HANDLE_CRASH_MAX]
+--- a/black_flag.h
++++ b/black_flag.h
+@@ -230,7 +230,7 @@
+ ((INDEX)<(MINIMUM_BOUND) || (INDEX)>=(MAXIMUM_BOUND))
+
+ void handle_crash(int sigcode);
+-int handle_crash_init(void (*crash_fun)());
++int handle_crash_init(void (*crash_fun)(int));
+ int black_flag(int bug_level,
+ char sourcefile[],
+ int sourceline,
+--- a/default.h
++++ b/default.h
+@@ -19,7 +19,6 @@
+
+ typedef void *voidptr; /* ~~e: should be moved out to generic typing header
+ --- */
+-typedef int (*funptr)();
+
+ #define LOOPB(i,size) for ((i)=(size);(i)-- >0;)
+ #define LOOP(i,size) for ((i)=(size);(i)-- >0;)
+@@ -152,7 +151,7 @@
+ else if (NULL == ((memptr)=(ATYPE *)calloc((size_t)(N),sizeof(ATYPE)))) { \
+ fprintf(stderr,"%s, line %d: *** out of memory \n",__FILE__,__LINE__); \
+ fprintf(stderr,"Unable to meet request: %s[%d]\n",STRINGIFY(memptr),(N)); \
+- fprintf(stderr,"requested %d x %d bytes \n",(N),sizeof(ATYPE)); \
++ fprintf(stderr,"requested %d x %zu bytes \n",(N),sizeof(ATYPE)); \
+ MALLOC_FAILURE_ACTION; \
+ }
+
+@@ -193,7 +192,7 @@
+ else { \
+ fprintf(stderr,"%s, line %d: *** out of memory \n",__FILE__,__LINE__); \
+ fprintf(stderr,"Unable to meet request: %s\n",STRINGIFY(memptr)); \
+- fprintf(stderr,"requested %d x %d bytes \n",(NUM),sizeof(ATYPE)); \
++ fprintf(stderr,"requested %d x %zu bytes \n",(NUM),sizeof(ATYPE)); \
+ REALLOC_FAILURE_ACTION; \
+ } \
+ }
+--- a/fasta_format.c
++++ b/fasta_format.c
+@@ -2,6 +2,7 @@
+ #include "default.h"
+ #include "seq_util.h"
+
++char *stringptr_cat_pos(stringptr *s1,const char s2[],int *pos);
+
+
+ /** reads FASTA formatted sequence file, and saves the sequences to
+--- a/msa_format.c
++++ b/msa_format.c
+@@ -16,6 +16,11 @@
+
+ #include "msa_format.h"
+
++void fuse_ring_identities(int len_x,LPOLetter_T seq_x[],
++ int len_y,LPOLetter_T seq_y[],
++ LPOLetterRef_T al_x[],
++ LPOLetterRef_T al_y[]);
++void build_seq_to_po_index(LPOSequence_T *seq);
+
+ /** is `ch' an allowed residue? (a-z OR A-Z OR ? OR [ OR ]) */
+ static int is_residue_char (char ch);
diff --git a/sci-biology/poa/poa-2-r1.ebuild b/sci-biology/poa/poa-2-r1.ebuild
index d87f2a638117..f6d9b756f3d5 100644
--- a/sci-biology/poa/poa-2-r1.ebuild
+++ b/sci-biology/poa/poa-2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -21,6 +21,7 @@ S="${WORKDIR}/${MY_P}"
PATCHES=(
"${FILESDIR}"/${P}-respect-flags.patch
"${FILESDIR}"/${P}-fno-common.patch
+ "${FILESDIR}"/${P}-clang16.patch
)
src_configure() {