summaryrefslogtreecommitdiff
path: root/sci-biology/piler/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-biology/piler/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-biology/piler/files')
-rw-r--r--sci-biology/piler/files/piler-1.0-fix-build-system.patch34
-rw-r--r--sci-biology/piler/files/piler-1.0-glibc-2.10.patch12
2 files changed, 46 insertions, 0 deletions
diff --git a/sci-biology/piler/files/piler-1.0-fix-build-system.patch b/sci-biology/piler/files/piler-1.0-fix-build-system.patch
new file mode 100644
index 000000000000..78a72f1b4850
--- /dev/null
+++ b/sci-biology/piler/files/piler-1.0-fix-build-system.patch
@@ -0,0 +1,34 @@
+Make build system honour user variables
+
+--- a/Makefile
++++ b/Makefile
+@@ -1,6 +1,4 @@
+-CFLAGS = -O3 -march=pentiumpro -mcpu=pentiumpro -funroll-loops -Winline -DNDEBUG=1
+-LDLIBS = -lm -static
+-# LDLIBS = -lm
++LDLIBS = -lm
+
+ OBJ = .o
+ EXE =
+@@ -8,18 +6,13 @@
+ RM = rm -f
+ CP = cp
+
+-GPP = g++
+-LD = $(GPP) $(CFLAGS)
+-CPP = $(GPP) -c $(CFLAGS)
+-CC = gcc -c $(CFLAGS)
+-
+ all: piler
+
+ CPPSRC = $(sort $(wildcard *.cpp))
+ CPPOBJ = $(subst .cpp,.o,$(CPPSRC))
+
+-$(CPPOBJ): %.o: %.cpp
+- $(CPP) $< -o $@
++%.o: %.cpp
++ $(CXX) $(CXXFLAGS) -DNDEBUG $(CPPFLAGS) -c $< -o $@
+
+ piler: $(CPPOBJ)
+- $(LD) -o piler $(CPPOBJ) $(LDLIBS)
++ $(CXX) $(LDFLAGS) $(CXXFLAGS) -o piler $(CPPOBJ) $(LDLIBS)
diff --git a/sci-biology/piler/files/piler-1.0-glibc-2.10.patch b/sci-biology/piler/files/piler-1.0-glibc-2.10.patch
new file mode 100644
index 000000000000..4c7f124c5e3d
--- /dev/null
+++ b/sci-biology/piler/files/piler-1.0-glibc-2.10.patch
@@ -0,0 +1,12 @@
+diff -ur piler.orig/gff.cpp piler/gff.cpp
+--- piler.orig/gff.cpp 2004-12-18 01:25:29.000000000 +0200
++++ piler/gff.cpp 2009-08-09 17:22:33.000000000 +0300
+@@ -70,7 +70,7 @@
+ const char *Attrs = Fields[8];
+
+ // Truncate attrs if comment found
+- char *Pound = strchr(Attrs, '#');
++ char *Pound = const_cast <char*> (strchr(Attrs, '#'));
+ if (0 != Pound)
+ *Pound = 0;
+