summaryrefslogtreecommitdiff
path: root/sci-biology/muscle/muscle-3.8.31.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-biology/muscle/muscle-3.8.31.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-biology/muscle/muscle-3.8.31.ebuild')
-rw-r--r--sci-biology/muscle/muscle-3.8.31.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-biology/muscle/muscle-3.8.31.ebuild b/sci-biology/muscle/muscle-3.8.31.ebuild
new file mode 100644
index 000000000000..1e62a9d28eee
--- /dev/null
+++ b/sci-biology/muscle/muscle-3.8.31.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+MY_P="${PN}${PV}_src"
+
+DESCRIPTION="Multiple sequence comparison by log-expectation"
+HOMEPAGE="http://www.drive5.com/muscle/"
+SRC_URI="http://www.drive5.com/muscle/downloads${PV}/${MY_P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="!sci-libs/libmuscle"
+DEPEND=""
+
+S="${WORKDIR}"/${PN}${PV}/src
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-make.patch
+ tc-export CXX
+}
+
+src_install() {
+ dobin "${PN}"
+ dodoc *.txt
+}