summaryrefslogtreecommitdiff
path: root/sci-biology/maq/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-biology/maq/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-biology/maq/files')
-rw-r--r--sci-biology/maq/files/maq-0.7.1-bfr-overfl.patch16
-rw-r--r--sci-biology/maq/files/maq-0.7.1-flags.patch24
-rw-r--r--sci-biology/maq/files/maq-0.7.1-gcc-4.7.patch34
-rw-r--r--sci-biology/maq/files/maq-0.7.1-remove-64bit-flag.patch19
4 files changed, 93 insertions, 0 deletions
diff --git a/sci-biology/maq/files/maq-0.7.1-bfr-overfl.patch b/sci-biology/maq/files/maq-0.7.1-bfr-overfl.patch
new file mode 100644
index 000000000000..9f4247d441f5
--- /dev/null
+++ b/sci-biology/maq/files/maq-0.7.1-bfr-overfl.patch
@@ -0,0 +1,16 @@
+ simulate.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/simulate.c b/simulate.c
+index 788c440..67ba2ba 100644
+--- a/simulate.c
++++ b/simulate.c
+@@ -383,7 +383,7 @@ static void simustat_core(gzFile fp, int Q_thres)
+ memset(wc_single, 0, 40); memset(tot_single, 0, 40);
+ memset(wc_pair, 0, 40); memset(tot_pair, 0, 40);
+ memset(abpair, 0, 4 * 256 * 10);
+- memset(tc[2], 0, 4 * sizeof(int));
++ memset(tc, 0, 4 * sizeof(int));
+ while (maqmap_read1(fp, m1)) {
+ int is_correct;
+ bit32_t p1, p2;
diff --git a/sci-biology/maq/files/maq-0.7.1-flags.patch b/sci-biology/maq/files/maq-0.7.1-flags.patch
new file mode 100644
index 000000000000..721e53248b7a
--- /dev/null
+++ b/sci-biology/maq/files/maq-0.7.1-flags.patch
@@ -0,0 +1,24 @@
+ configure.ac | 3 ++-
+ 1 files changed, 2 insertions(+), 1 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index ad2f1e6..4f9d7be 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -8,6 +8,7 @@ AC_PROG_CXX
+
+ # set CFLAGS and CXXFLAGS
+ user_CFLAGS=${CFLAGS}
++user_CXXFLAGS=${CXXFLAGS}
+ generic_CFLAGS="-Wall"
+ ext_CFLAGS=""
+ case "${host_cpu}-${host_os}" in
+@@ -37,7 +38,7 @@ AC_ARG_ENABLE(shortread, [ --enable-shortreads use shortread mode],
+ AC_ARG_ENABLE(intel64, [ --enable-intel64 optimize for Intel64 CPU such as Xeon and Core2],
+ [ext_CFLAGS="${ext_CFLAGS} -mtune=nocona"], [])
+ CFLAGS="${generic_CFLAGS} ${ext_CFLAGS} ${user_CFLAGS}"
+-CXXFLAGS=$CFLAGS
++CXXFLAGS="${generic_CFLAGS} ${ext_CFLAGS} ${user_CXXFLAGS}"
+
+ AC_STDC_HEADERS
+ AC_CHECK_HEADER(zlib.h)
diff --git a/sci-biology/maq/files/maq-0.7.1-gcc-4.7.patch b/sci-biology/maq/files/maq-0.7.1-gcc-4.7.patch
new file mode 100644
index 000000000000..4b97da89be48
--- /dev/null
+++ b/sci-biology/maq/files/maq-0.7.1-gcc-4.7.patch
@@ -0,0 +1,34 @@
+ stdhash.hh | 6 +++---
+ 1 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/stdhash.hh b/stdhash.hh
+index eaf98af..16cd1a3 100644
+--- a/stdhash.hh
++++ b/stdhash.hh
+@@ -412,7 +412,7 @@ public:
+ inline bool insert(const keytype_t &key) {
+ __lh3_hash_base_class<keytype_t>::rehash();
+ hashint_t i;
+- int ret = direct_insert_aux(key, this->n_capacity, this->keys, this->flags, &i);
++ int ret = this->direct_insert_aux(key, this->n_capacity, this->keys, this->flags, &i);
+ if (ret == 0) return true;
+ if (ret == 1) { ++(this->n_size); ++(this->n_occupied); }
+ else ++(this->n_size); // then ret == 2
+@@ -493,7 +493,7 @@ public:
+ inline bool insert(const keytype_t &key, const valtype_t &val) {
+ rehash();
+ hashint_t i;
+- int ret = direct_insert_aux(key, this->n_capacity, this->keys, this->flags, &i);
++ int ret = this->direct_insert_aux(key, this->n_capacity, this->keys, this->flags, &i);
+ vals[i] = val;
+ if (ret == 0) return true;
+ if (ret == 1) { ++(this->n_size); ++(this->n_occupied); }
+@@ -503,7 +503,7 @@ public:
+ inline bool insert(const keytype_t &key, valtype_t **q) {
+ rehash();
+ hashint_t i;
+- int ret = direct_insert_aux(key, this->n_capacity, this->keys, this->flags, &i);
++ int ret = this->direct_insert_aux(key, this->n_capacity, this->keys, this->flags, &i);
+ *q = vals + i;
+ if (ret == 0) return true;
+ if (ret == 1) { ++(this->n_size); ++(this->n_occupied); }
diff --git a/sci-biology/maq/files/maq-0.7.1-remove-64bit-flag.patch b/sci-biology/maq/files/maq-0.7.1-remove-64bit-flag.patch
new file mode 100644
index 000000000000..3bcbc2b5fd51
--- /dev/null
+++ b/sci-biology/maq/files/maq-0.7.1-remove-64bit-flag.patch
@@ -0,0 +1,19 @@
+Do not hardcode -m64 into the build system
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -21,12 +21,12 @@
+ [ext_CFLAGS="-arch x86_64 -arch i386 -arch ppc64 -arch ppc"],
+ [ext_CFLAGS="-arch i386 -arch ppc"]);;
+ 0) CFLAGS="-m64"
+- AC_COMPILE_IFELSE([AC_LANG_PROGRAM], [ext_CFLAGS="-m64"], []);;
++ AC_COMPILE_IFELSE([AC_LANG_PROGRAM], [ext_CFLAGS=""], []);;
+ esac;;
+ *)
+ AC_MSG_CHECKING([if gcc accepts -m64])
+ CFLAGS="-m64"
+- AC_COMPILE_IFELSE([AC_LANG_PROGRAM], [ext_CFLAGS="-m64"; AC_MSG_RESULT([yes])],
++ AC_COMPILE_IFELSE([AC_LANG_PROGRAM], [ext_CFLAGS=""; AC_MSG_RESULT([yes])],
+ [ext_CFLAGS="-D_FILE_OFFSET_BITS=64"; AC_MSG_RESULT([no])]);;
+ esac
+ AC_ARG_ENABLE(experimental, [ --enable-experimental enable experimental features],