summaryrefslogtreecommitdiff
path: root/sci-biology/lagan/lagan-2.0-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /sci-biology/lagan/lagan-2.0-r4.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'sci-biology/lagan/lagan-2.0-r4.ebuild')
-rw-r--r--sci-biology/lagan/lagan-2.0-r4.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/sci-biology/lagan/lagan-2.0-r4.ebuild b/sci-biology/lagan/lagan-2.0-r4.ebuild
new file mode 100644
index 000000000000..4582d8f1078e
--- /dev/null
+++ b/sci-biology/lagan/lagan-2.0-r4.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MY_P="lagan20"
+
+DESCRIPTION="The LAGAN suite of tools for whole-genome multiple alignment of genomic DNA"
+HOMEPAGE="http://lagan.stanford.edu/lagan_web/index.shtml"
+SRC_URI="http://lagan.stanford.edu/lagan_web/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-lang/perl"
+
+S="${WORKDIR}/${MY_P}"
+PATCHES=(
+ "${FILESDIR}"/${P}-makefile.patch
+ "${FILESDIR}"/${P}-conflicting-getline.patch
+ "${FILESDIR}"/${P}-gcc-4.8.patch
+ "${FILESDIR}"/${P}-ambiguous-end.patch
+ "${FILESDIR}"/${P}-gcc-9.patch
+ "${FILESDIR}"/${P}-gcc-10.patch
+ "${FILESDIR}"/${P}-C99-static-inline.patch
+ "${FILESDIR}"/${P}-qa-implicit-declarations.patch
+)
+
+src_prepare() {
+ default
+ sed -i "/use Getopt::Long;/ i use lib \"/usr/$(get_libdir)/lagan/lib\";" \
+ supermap.pl || die
+}
+
+src_configure() {
+ tc-export CC CXX
+}
+
+src_install() {
+ newbin lagan.pl lagan
+ newbin slagan.pl slagan
+ dobin mlagan
+ rm lagan.pl slagan.pl utils/Utils.pm || die
+
+ insinto /usr/$(get_libdir)/lagan/lib
+ doins Utils.pm
+
+ exeinto /usr/$(get_libdir)/lagan/utils
+ doexe utils/*
+
+ exeinto /usr/$(get_libdir)/lagan
+ doexe *.pl anchors chaos glocal order prolagan
+
+ insinto /usr/$(get_libdir)/lagan
+ doins *.txt
+
+ dosym ../$(get_libdir)/lagan/supermap.pl /usr/bin/supermap
+
+ newenvd - 99lagan <<- _EOF_
+ LAGAN_DIR="${EPREFIX}/usr/$(get_libdir)/lagan"
+ _EOF_
+
+ dodoc Readmes/README.*
+}