summaryrefslogtreecommitdiff
path: root/sci-biology/foldingathome
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /sci-biology/foldingathome
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'sci-biology/foldingathome')
-rw-r--r--sci-biology/foldingathome/Manifest2
-rw-r--r--sci-biology/foldingathome/foldingathome-7.6.21.ebuild138
2 files changed, 140 insertions, 0 deletions
diff --git a/sci-biology/foldingathome/Manifest b/sci-biology/foldingathome/Manifest
index f05ea2de4408..c7cb1fd9d18a 100644
--- a/sci-biology/foldingathome/Manifest
+++ b/sci-biology/foldingathome/Manifest
@@ -1,4 +1,6 @@
AUX 7.3/folding-conf.d 339 BLAKE2B 93a0b3672777ad737ce27694aaca547634c375e180ad3c28c3adb9cae2cb1c054ff9458ee1fe04b70fe9841ae67d41198bcecfc4826d05d5de8df2759bd80910 SHA512 6fd10dc938262c05831e68176e93a24869bb6991508bcc48ece487b701788026561d073025bd347cd77ede13ca26f6b284861f30b07becf72ea77e4db22867b3
DIST fahclient_7.6.13-64bit-release.tar.bz2 3951134 BLAKE2B 2748b7c1987d166bdda08caf5ff2f331523ff519e24768cd7e111c6d3a93f54c10c88d8adbf733230b6c51547360135dbcb272e5d43fd06d01918481601382a1 SHA512 f39f2990d78d075e1061ceaff9453b703a000770a3422965b7b8a91d1814f8804837628d8a34be5afd914228ef787f699f2488523baad295a8d9c1e3bb4f35cf
+DIST fahclient_7.6.21-64bit-release.tar.bz2 4081015 BLAKE2B b47f99bb2c568ee78dfb8998f6faa6c19aa78492a7882d128917596fa51ca7fb9f02dc0a822b6859ee4b333812f961cbcba504b9b188a3a16e7c5c9489cbfbdb SHA512 b52d97c0169eea8686ac3e52a713bb8513ae2b33a853fbf88a0311569aee22681e9ac87bcc01acdaf31d5af5c3641bd5611d34fcbdbb6c1f0ebbb3fc1efeabdb
EBUILD foldingathome-7.6.13-r1.ebuild 4368 BLAKE2B 987b6022e43c2a39338ec8269e3ac001f9c0667237384814183d100fa2191dd91aaf57cfa86407d3bac0e4cee7bd12e022a967d5045e6888ba57622873500d2d SHA512 5225fcec1fb2e5d29b6628a0b06ec1f9f588f74feee6282ff7ee910fb87fba29512880707219ef77e63d0c7584858f50d0a1262ee88eea624c8dedce7df5d873
+EBUILD foldingathome-7.6.21.ebuild 4389 BLAKE2B c06064b68a21d31445d946097f574d3a42d114682633b406ca672cfa65e83a6af9bd0cdce7e5d5c20757f8a65f44727bf72954bdcea2510cdec173ddcca1ce90 SHA512 4028dca370a7935ac03c3bb117f66a831c4ea57e058c21807a08adc58ede17a4649ab8db9e89bb18764fb50a6c05f35734c9be76b1aac14dd59906f83be05c31
MISC metadata.xml 258 BLAKE2B 51009df26b3682090e316b4cf4a3afad84001705063be6c74a28fb11bacde48b758dc280bf9d4d049c69e728d9660e737072674ad5ff8068da4f6a49f1f4e203 SHA512 05153e39b77e8b1437a0ba80b66b6bb1b4837d719765cb157b23d5425a625ddb4056422dcbf28d182e039583a0b3863e8429efe80da85a035c96f4c4788ced6d
diff --git a/sci-biology/foldingathome/foldingathome-7.6.21.ebuild b/sci-biology/foldingathome/foldingathome-7.6.21.ebuild
new file mode 100644
index 000000000000..04b1ff468a1e
--- /dev/null
+++ b/sci-biology/foldingathome/foldingathome-7.6.21.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd
+
+DESCRIPTION="Folding@Home is a distributed computing project for protein folding"
+HOMEPAGE="https://foldingathome.org/"
+SRC_URI="https://download.foldingathome.org/releases/public/release/fahclient/centos-6.7-64bit/v$(ver_cut 1-2)/fahclient_${PV}-64bit-release.tar.bz2"
+S="${WORKDIR}/fahclient_${PV}-64bit-release"
+
+LICENSE="FAH-EULA-2014 FAH-special-permission"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="mirror bindist strip"
+
+# Expressly listing all deps, as this is a binpkg and it is doubtful whether
+# i.e. uclibc or clang can provide what is necessary at runtime
+DEPEND="dev-util/patchelf"
+RDEPEND="
+ acct-group/foldingathome
+ acct-group/video
+ acct-user/foldingathome
+ app-arch/bzip2
+ || (
+ dev-libs/openssl-compat:1.0.0
+ =dev-libs/openssl-1.0*:*
+ )
+ sys-devel/gcc
+ sys-libs/glibc
+ sys-libs/zlib
+"
+
+QA_PREBUILT="opt/foldingathome/*"
+
+pkg_setup() {
+ elog ""
+ elog "Special permission is hereby granted to the Gentoo project to provide an"
+ elog "automated installer package which downloads and installs the Folding@home client"
+ elog "software. Permission is also granted for future Gentoo installer packages on the"
+ elog "condition that they continue to adhere to all of the terms of the accompanying"
+ elog "Folding@home license agreements and display this notice."
+ elog "-- Vijay S. Pande, Stanford University, 07 May 2013"
+ elog ""
+ elog "(ref: http://foldingforum.org/viewtopic.php?f=16&t=22524&p=241992#p241992 )"
+ elog ""
+}
+
+src_install() {
+ patchelf --set-rpath "${EPREFIX}/opt/foldingathome" FAHClient || die
+ patchelf --set-rpath "${EPREFIX}/opt/foldingathome" FAHCoreWrapper || die
+
+ dosym "../../usr/$(get_libdir)/libssl.so.1.0.0" /opt/foldingathome/libssl.so.10
+ dosym "../../usr/$(get_libdir)/libcrypto.so.1.0.0" /opt/foldingathome/libcrypto.so.10
+
+ exeinto /opt/foldingathome
+ doexe {FAHClient,FAHCoreWrapper}
+
+ insinto /opt/foldingathome
+ doins sample-config.xml
+
+ newconfd "${FILESDIR}"/7.3/folding-conf.d foldingathome
+ cat <<EOF >"${T}"/fah-init || die
+#!/sbin/openrc-run
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+start_stop_daemon_args="--chdir \"${EPREFIX}/opt/foldingathome\""
+command="${EPREFIX}/opt/foldingathome/FAHClient"
+command_args="\${FOLD_OPTS}"
+command_user=foldingathome
+command_background=1
+pidfile="\${PIDFILE}"
+EOF
+ newinitd "${T}"/fah-init foldingathome
+
+ cat <<EOF >"${T}"/fah-init.service || die
+[Unit]
+Description=Folding@Home V7 Client
+Documentation=https://foldingathome.org
+
+[Service]
+Type=simple
+User=foldingathome
+Group=foldingathome
+Nice=19
+WorkingDirectory=${EPREFIX}/opt/foldingathome
+ExecStart=${EPREFIX}/opt/foldingathome/FAHClient --fork=false --pid=false --respawn=false --service=false
+NoNewPrivileges=yes
+PrivateTmp=yes
+ProtectControlGroups=yes
+ProtectSystem=full
+RestrictRealtime=true
+ProtectControlGroups=yes
+
+[Install]
+WantedBy=multi-user.target
+EOF
+ systemd_newunit "${T}"/fah-init.service foldingathome.service
+
+ fowners -R foldingathome:foldingathome /opt/foldingathome
+}
+
+pkg_postinst() {
+ elog "To run Folding@home in the background at boot:"
+ elog "(openrc)\trc-update add foldingathome default"
+ elog "(systemd)\tsystemctl enable foldingathome"
+ elog ""
+ if [ ! -e "${EPREFIX}"/opt/foldingathome/config.xml ]; then
+ elog "No config.xml file found -- please run"
+ elog "emerge --config ${P} to configure your client, or specify"
+ elog "all necessary runtime options in FOLD_OPTS within"
+ elog "${EPREFIX}/etc/conf.d/foldingathome"
+ elog ""
+ fi
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ elog "NOTE, the 'initfolding' helper script has been dropped, please"
+ elog "use emerge --config ${P} or run FAHClient --configure directly"
+ elog "and adjust file permissions and ownership yourself"
+ elog ""
+ fi
+ elog "Please see ${EPREFIX}/opt/foldingathome/FAHClient --help for more details."
+ einfo ""
+ einfo "The original package maintainer encourages you to acquire a username and join team 36480."
+ einfo "http://folding.stanford.edu/English/Download#ntoc2"
+ einfo ""
+}
+
+pkg_postrm() {
+ elog "Folding@home data files were not removed."
+ elog "Remove them manually from ${EPREFIX}/opt/foldingathome"
+}
+
+pkg_config() {
+ cd "${EPREFIX}"/opt/foldingathome || die
+ su foldingathome -s /bin/sh -c "./FAHClient --configure" || die
+}