summaryrefslogtreecommitdiff
path: root/sci-biology/foldingathome
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /sci-biology/foldingathome
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'sci-biology/foldingathome')
-rw-r--r--sci-biology/foldingathome/Manifest2
-rw-r--r--sci-biology/foldingathome/foldingathome-7.6.9.ebuild140
2 files changed, 142 insertions, 0 deletions
diff --git a/sci-biology/foldingathome/Manifest b/sci-biology/foldingathome/Manifest
index 71fe4a3400d5..a3762634a224 100644
--- a/sci-biology/foldingathome/Manifest
+++ b/sci-biology/foldingathome/Manifest
@@ -1,4 +1,6 @@
AUX 7.3/folding-conf.d 339 BLAKE2B 93a0b3672777ad737ce27694aaca547634c375e180ad3c28c3adb9cae2cb1c054ff9458ee1fe04b70fe9841ae67d41198bcecfc4826d05d5de8df2759bd80910 SHA512 6fd10dc938262c05831e68176e93a24869bb6991508bcc48ece487b701788026561d073025bd347cd77ede13ca26f6b284861f30b07becf72ea77e4db22867b3
DIST fahclient_7.5.1-64bit-release.tar.bz2 3438239 BLAKE2B 69fb60cdd5356fe4f5ad1f106b67d078baf0394c5d3c474dff2f1ac840bcb31bfd9ca9a9c6112b9ee9497dcdc223732627a21c50b455e46c096a52587d5d229b SHA512 5f6f2f882d57fe53ad0a55b48f09fc3803af6aebbbf0e92be39477d4c4da92237d6edabec61dd8183678bdcfe3923ff9b0938647a77edc2c69ce8958defcfdf1
+DIST fahclient_7.6.9-64bit-release.tar.bz2 3962851 BLAKE2B 896ca7cdd1357bb37cd8a5c438223c398c5f8c6bde7f7302d0e62ccff603b9a3dd3fb348bd021b9654867eb8f2579c91cfe87e3229b365620b383a4f261ae5f4 SHA512 0a360d8a985d3d538922a2d9519b70845a568f7d052c3047e7f847865165e9cd6e741016ee00496161ca3c2115beef34e95ab594d0f864bccc0fe12de6886f19
EBUILD foldingathome-7.5.1-r3.ebuild 4454 BLAKE2B 9103461fe2614c5494648827b461cc488e7345f3ad12d45ccda6c44c81de7f700120d582b3ab4371974a5a25a62626b535849e8bafa13ac577c59364102cb7a3 SHA512 4c1a451a5df2e2015594f266761d51b9ac0978711ce93f4bc922937a0fa474bdead787926541ad42d554130cf6168e367f8c090648d52951ca6b7f1533c042f2
+EBUILD foldingathome-7.6.9.ebuild 4422 BLAKE2B 50f39d12b3c1bf23e94119a7d3a1434f7f44e1765ab77550e4561875be2e1b5b8ca1e00393ba1b218ebb12f54b4cc27721ee46586986b8771b8216ab6fe20e33 SHA512 1be3543d064a478e22abf386bdc634f5e63710aaada32fd035b4f5c1ef02bc01521a084430e9cc4fed17a677b51a62d811f5c74b1dca1b581b489f585d5d58ee
MISC metadata.xml 360 BLAKE2B c0ef2b11cc9e6498a420dcd2e6c83ee71f7e286c3e78218257c56350bd2c0921732d48cc4207a31bcfd965a4a9dca65e9bdc4d62831dc430e86541d36fc691f8 SHA512 687f1516a8ec80270fa173b0a7d7c259f3f02ffefa69d3175b72e170bd11aeb786563edb43214390a83b6b61b1231e2734124e50bb2a523d1a564bc3b143f00b
diff --git a/sci-biology/foldingathome/foldingathome-7.6.9.ebuild b/sci-biology/foldingathome/foldingathome-7.6.9.ebuild
new file mode 100644
index 000000000000..ca477a6d6b77
--- /dev/null
+++ b/sci-biology/foldingathome/foldingathome-7.6.9.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit user systemd
+
+DESCRIPTION="Folding@Home is a distributed computing project for protein folding"
+HOMEPAGE="https://foldingathome.org/"
+SRC_URI="https://download.foldingathome.org/releases/public/release/fahclient/centos-6.7-64bit/v$(ver_cut 1-2)/fahclient_${PV}-64bit-release.tar.bz2"
+
+RESTRICT="mirror bindist strip"
+
+LICENSE="FAH-EULA-2014 FAH-special-permission"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+# Expressly listing all deps, as this is a binpkg and it is doubtful whether
+# i.e. uclibc or clang can provide what is necessary at runtime
+DEPEND="dev-util/patchelf"
+RDEPEND="app-arch/bzip2
+ || (
+ dev-libs/openssl-compat:1.0.0
+ =dev-libs/openssl-1.0*:*
+ )
+ sys-devel/gcc
+ sys-libs/glibc
+ sys-libs/zlib
+ acct-group/video
+"
+
+S="${WORKDIR}/fahclient_${PV}-64bit-release"
+
+QA_PREBUILT="opt/foldingathome/*"
+
+pkg_setup() {
+ elog ""
+ elog "Special permission is hereby granted to the Gentoo project to provide an"
+ elog "automated installer package which downloads and installs the Folding@home client"
+ elog "software. Permission is also granted for future Gentoo installer packages on the"
+ elog "condition that they continue to adhere to all of the terms of the accompanying"
+ elog "Folding@home license agreements and display this notice."
+ elog "-- Vijay S. Pande, Stanford University, 07 May 2013"
+ elog ""
+ elog "(ref: http://foldingforum.org/viewtopic.php?f=16&t=22524&p=241992#p241992 )"
+ elog ""
+
+ enewgroup foldingathome
+ enewuser foldingathome -1 -1 "${EPREFIX}"/opt/foldingathome video
+}
+
+src_install() {
+ patchelf --set-rpath "${EPREFIX}/opt/foldingathome" FAHClient || die
+ patchelf --set-rpath "${EPREFIX}/opt/foldingathome" FAHCoreWrapper || die
+
+ dosym "../../usr/$(get_libdir)/libssl.so.1.0.0" /opt/foldingathome/libssl.so.10
+ dosym "../../usr/$(get_libdir)/libcrypto.so.1.0.0" /opt/foldingathome/libcrypto.so.10
+
+ exeinto /opt/foldingathome
+ doexe {FAHClient,FAHCoreWrapper}
+
+ insinto /opt/foldingathome
+ doins sample-config.xml
+
+ newconfd "${FILESDIR}"/7.3/folding-conf.d foldingathome
+ cat <<EOF >"${T}"/fah-init
+#!/sbin/openrc-run
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+start_stop_daemon_args="--chdir \"${EPREFIX}/opt/foldingathome\""
+command="${EPREFIX}/opt/foldingathome/FAHClient"
+command_args="\${FOLD_OPTS}"
+command_user=foldingathome
+command_background=1
+pidfile="\${PIDFILE}"
+EOF
+ newinitd "${T}"/fah-init foldingathome
+
+ cat <<EOF >"${T}"/fah-init.service
+[Unit]
+Description=Folding@Home V7 Client
+Documentation=https://foldingathome.org
+
+[Service]
+Type=simple
+User=foldingathome
+Group=foldingathome
+Nice=19
+WorkingDirectory=${EPREFIX}/opt/foldingathome
+ExecStart=${EPREFIX}/opt/foldingathome/FAHClient --fork=false --pid=false --respawn=false --service=false
+NoNewPrivileges=yes
+PrivateTmp=yes
+ProtectControlGroups=yes
+ProtectSystem=full
+RestrictRealtime=true
+ProtectControlGroups=yes
+
+[Install]
+WantedBy=multi-user.target
+EOF
+ systemd_newunit "${T}"/fah-init.service foldingathome.service
+
+ fowners -R foldingathome:foldingathome /opt/foldingathome
+}
+
+pkg_postinst() {
+ elog "To run Folding@home in the background at boot:"
+ elog "(openrc)\trc-update add foldingathome default"
+ elog "(systemd)\tsystemctl enable foldingathome"
+ elog ""
+ if [ ! -e "${EPREFIX}"/opt/foldingathome/config.xml ]; then
+ elog "No config.xml file found -- please run"
+ elog "emerge --config ${P} to configure your client, or specify"
+ elog "all necessary runtime options in FOLD_OPTS within"
+ elog "${EPREFIX}/etc/conf.d/foldingathome"
+ elog ""
+ fi
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ elog "NOTE, the 'initfolding' helper script has been dropped, please"
+ elog "use emerge --config ${P} or run FAHClient --configure directly"
+ elog "and adjust file permissions and ownership yourself"
+ elog ""
+ fi
+ elog "Please see ${EPREFIX}/opt/foldingathome/FAHClient --help for more details."
+ einfo ""
+ einfo "The original package maintainer encourages you to acquire a username and join team 36480."
+ einfo "http://folding.stanford.edu/English/Download#ntoc2"
+ einfo ""
+}
+
+pkg_postrm() {
+ elog "Folding@home data files were not removed."
+ elog "Remove them manually from ${EPREFIX}/opt/foldingathome"
+}
+
+pkg_config() {
+ cd "${EPREFIX}"/opt/foldingathome || die
+ su foldingathome -s /bin/sh -c "./FAHClient --configure"
+}