summaryrefslogtreecommitdiff
path: root/sci-biology/fastx_toolkit/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-11 09:12:41 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-11 09:12:41 +0000
commit343a7272d559a21a0e0ed13cb743fabb2bfcc479 (patch)
treedb03f20672a6244296ccc2aa27e70757937eb9f7 /sci-biology/fastx_toolkit/files
parent456dbeaab3e2f71f527eae542ab44d1e372b0655 (diff)
gentoo resync : 11.01.2018
Diffstat (limited to 'sci-biology/fastx_toolkit/files')
-rw-r--r--sci-biology/fastx_toolkit/files/fastx_toolkit-0.0.14-fix-build-system.patch63
-rw-r--r--sci-biology/fastx_toolkit/files/fastx_toolkit-0.0.14-gcc7.patch10
2 files changed, 73 insertions, 0 deletions
diff --git a/sci-biology/fastx_toolkit/files/fastx_toolkit-0.0.14-fix-build-system.patch b/sci-biology/fastx_toolkit/files/fastx_toolkit-0.0.14-fix-build-system.patch
new file mode 100644
index 000000000000..a8b22579f737
--- /dev/null
+++ b/sci-biology/fastx_toolkit/files/fastx_toolkit-0.0.14-fix-build-system.patch
@@ -0,0 +1,63 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -14,12 +14,12 @@
+ [fastx_toolkit])
+ AC_CONFIG_AUX_DIR(config)
+ AC_CONFIG_MACRO_DIR([m4])
+-AM_CONFIG_HEADER(config.h)
++AC_CONFIG_HEADERS([config.h])
+ AM_INIT_AUTOMAKE([dist-bzip2])
+
+ AC_PROG_CC
+ AC_PROG_CXX
+-AC_PROG_LIBTOOL
++LT_INIT
+ AX_C_LONG_LONG
+ AX_CXX_HEADER_STDCXX_TR1
+ AX_CXX_COMPILE_STDCXX_11([noext],[optional])
+@@ -31,9 +31,9 @@
+ PKG_CHECK_MODULES([GTEXTUTILS],[gtextutils])
+
+ dnl --enable-wall
+-EXTRA_CHECKS="-Wall -Wextra -Wformat-nonliteral -Wformat-security -Wswitch-default -Wswitch-enum -Wunused-parameter -Wfloat-equal -Werror"
++EXTRA_CHECKS="-Wall -Wextra -Wformat-nonliteral -Wformat-security -Wswitch-default -Wswitch-enum -Wunused-parameter -Wfloat-equal"
+ AC_ARG_ENABLE(wall,
+-[ --enable-wall Enable many common GCC warnings (-Wall,-Wextra, -Werror etc., default enabled)],
++[ --enable-wall Enable many common GCC warnings (-Wall,-Wextra etc., default enabled)],
+ [case "${enableval}" in
+ yes) wall=true ;;
+ no) wall=false ;;
+@@ -45,22 +45,6 @@
+ CXXFLAGS="${CXXFLAGS} ${EXTRA_CHECKS}"
+ fi
+
+-dnl --enable-debug
+-AC_ARG_ENABLE(debug,
+-[ --enable-debug Enable debug mode (default enabled)],
+-[case "${enableval}" in
+- yes) debug=true ;;
+- no) debug=false ;;
+- *) AC_MSG_ERROR(bad value ${enableval} for --enable-debug) ;;
+-esac],[debug=true])
+-if test "$debug" = "true"
+-then
+- CFLAGS="${CFLAGS} -DDEBUG -g -O1"
+- CXXFLAGS="${CXXFLAGS} -DDEBUG -g -O1"
+-else
+- CFLAGS="${CFLAGS} -O3"
+- CXXFLAGS="${CXXFLAGS} -O3"
+-fi
+
+ dnl 'all-static' marco copied from subversion's configure.ac
+ dnl Check for --enable-all-static option
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -10,7 +10,7 @@
+
+ EXTRA_DIST = reconf configure README install_galaxy_files.sh
+
+-SUBDIRS = m4 src doc galaxy scripts build_scripts
++SUBDIRS = src doc galaxy scripts build_scripts
+
+ ACLOCAL_AMFLAGS = -I m4
+
diff --git a/sci-biology/fastx_toolkit/files/fastx_toolkit-0.0.14-gcc7.patch b/sci-biology/fastx_toolkit/files/fastx_toolkit-0.0.14-gcc7.patch
new file mode 100644
index 000000000000..e47717785517
--- /dev/null
+++ b/sci-biology/fastx_toolkit/files/fastx_toolkit-0.0.14-gcc7.patch
@@ -0,0 +1,10 @@
+--- a/src/fasta_formatter/fasta_formatter.cpp
++++ b/src/fasta_formatter/fasta_formatter.cpp
+@@ -103,6 +103,7 @@
+ switch(opt) {
+ case 'h':
+ usage();
++ exit(EXIT_SUCCESS);
+
+ case 'i':
+ input_filename = optarg;