summaryrefslogtreecommitdiff
path: root/sci-biology/elph/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-biology/elph/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-biology/elph/files')
-rw-r--r--sci-biology/elph/files/elph-1.0.1-fix-build-system.patch55
1 files changed, 55 insertions, 0 deletions
diff --git a/sci-biology/elph/files/elph-1.0.1-fix-build-system.patch b/sci-biology/elph/files/elph-1.0.1-fix-build-system.patch
new file mode 100644
index 000000000000..9afbb68666d6
--- /dev/null
+++ b/sci-biology/elph/files/elph-1.0.1-fix-build-system.patch
@@ -0,0 +1,55 @@
+Make build system respect user variables
+
+--- a/Makefile
++++ b/Makefile
+@@ -1,42 +1,26 @@
+-CLASSDIR := .
+-
+-# Directories to search for header files
+-SEARCHDIRS := -I- -I${CLASSDIR}
+-
+-
+-SYSTYPE := $(shell uname)
+-
+-# C compiler
+-
+-CC := g++
+-CFLAGS = -Wall ${SEARCHDIRS} -fno-exceptions -fno-rtti -D_REENTRANT -g
++my_CPPFLAGS = -D_REENTRANT -I.
+
+ %.o : %.c
+- ${CC} ${CFLAGS} -c $< -o $@
++ $(CC) -Wall $(CFLAGS) $(my_CPPFLAGS) $(CPPFLAGS) -c $< -o $@
+
+ %.o : %.cc
+- ${CC} ${CFLAGS} -c $< -o $@
++ $(CXX) -Wall $(CXXFLAGS) $(my_CPPFLAGS) $(CPPFLAGS) -c $< -o $@
+
+ %.o : %.C
+- ${CC} ${CFLAGS} -c $< -o $@
++ $(CXX) -Wall $(CXXFLAGS) $(my_CPPFLAGS) $(CPPFLAGS) -c $< -o $@
+
+ %.o : %.cpp
+- ${CC} ${CFLAGS} -c $< -o $@
++ $(CXX) -Wall $(CXXFLAGS) $(my_CPPFLAGS) $(CPPFLAGS) -c $< -o $@
+
+ %.o : %.cxx
+- ${CC} ${CFLAGS} -c $< -o $@
++ $(CXX) -Wall $(CXXFLAGS) $(my_CPPFLAGS) $(CPPFLAGS) -c $< -o $@
+
+ # C/C++ linker
+-
+-LINKER := g++
+-LDFLAGS =
+-LOADLIBES :=
+-
+ .PHONY : all
+ all: elph
+
+-elph: ./elph.o ${CLASSDIR}/motif.o ${CLASSDIR}/GBase.o ${CLASSDIR}/GString.o ${CLASSDIR}/GArgs.o
+- ${LINKER} ${LDFLAGS} -o $@ ${filter-out %.a %.so, $^} ${LOADLIBES}
++elph: elph.o motif.o GBase.o GString.o GArgs.o
++ $(CXX) $(LDFLAGS) $(CXXFLAGS) -o $@ $^
+
+ # target for removing all object files
+