summaryrefslogtreecommitdiff
path: root/sci-biology/biopython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /sci-biology/biopython
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'sci-biology/biopython')
-rw-r--r--sci-biology/biopython/Manifest2
-rw-r--r--sci-biology/biopython/biopython-1.79.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/sci-biology/biopython/Manifest b/sci-biology/biopython/Manifest
index f56dc658f127..aac147b18635 100644
--- a/sci-biology/biopython/Manifest
+++ b/sci-biology/biopython/Manifest
@@ -1,3 +1,5 @@
DIST biopython-1.77.tar.gz 16837021 BLAKE2B b5586f0ea3e476b11801dcc98039d5eea7b191e11d390192c0cf348018ded005fe2ad5dc9ba71c83aebc9cdde20c97244905dcc3aeb5436a97588da9f8c79c3e SHA512 6f4b03d46c591e1f49dd1e76bcc4ac5c9aaa2bf748c9dd37ffc5de5a613fbeed38f89b418c01601dd99c65b13b2e294bc8d81ffafc42a9ff1b309c84f840d0d5
+DIST biopython-1.79.tar.gz 16738730 BLAKE2B 8c97fc23e458f7bc98b0ed0226bd6fb42f6c6f3ce03d562b13fac66c5061451595cd5bd01cad07bbe1fc6b20f4de21b0f03766b5a20e602545da888047a57185 SHA512 81e2718f4015bb038637b4d1181e6bea48018fec1e769c5f0ab75442a769336899191f1222e82e1b9569c1fac470500d7582420e5cbe9bce0056b41751adeaaa
EBUILD biopython-1.77.ebuild 1918 BLAKE2B 61915c04855bfa88044c7f25f36d10ab774768b8ba2df5591ce6ede34dc90a4553c0331ab85fc12139a724e6fa6a0e40e1b584892f903bcd66b038677ffd843a SHA512 13e0bd3a5bb1ef8c76d8df5d6d2d3d659b48870472c7a8a82a14e19cdae484e19bb9a3e7e2870b0e5a75c056816965e7f5e106d1c910131eefb5c206874901d1
+EBUILD biopython-1.79.ebuild 1887 BLAKE2B b3f3f50434e77dae22a744a0eeb795690a8e828167aeb0755081286de38ca4f61e661536547405cc9026ba52466c678ee1f0af291c26658eba9afec36322bb9e SHA512 74feee0feff9df45fc16f512bc48ec6c0934608783def71fd5f1373a2ad57379e77c8dd6bdd94fbe755033e5a5f9881a64e106cb1f8be738137a77584d2c83fe
MISC metadata.xml 334 BLAKE2B 4d97c23444fdddcca57631fa2ddf4a11cfcef0accf91db65071d520f6601c0626e290e67cbf162abdefe7a74f4b410f8366a23186fc417e1fab7e9ce157d7610 SHA512 a870bd044d0e0d4e2a0c48b50f710845c6269e038790243f1d1de65b1252fd653f0f403fc55b98946df8eb27f24dfae5c84f52fcc38c969afcbdb548ccbb7a59
diff --git a/sci-biology/biopython/biopython-1.79.ebuild b/sci-biology/biopython/biopython-1.79.ebuild
new file mode 100644
index 000000000000..cef9a670130a
--- /dev/null
+++ b/sci-biology/biopython/biopython-1.79.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python modules for computational molecular biology"
+HOMEPAGE="https://www.biopython.org/ https://pypi.org/project/biopython/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/rdflib[${PYTHON_USEDEP}]
+ dev-python/pygraphviz[${PYTHON_USEDEP}]
+ >=dev-python/reportlab-3.5.13-r1[${PYTHON_USEDEP}]
+ dev-python/pydot[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/flex"
+
+DOCS=( {CONTRIB,DEPRECATED,NEWS,README}.rst Doc/. )
+
+python_test() {
+ distutils_install_for_testing
+ cp -r {Doc,Tests} "${TEST_DIR}"/lib/ || die
+
+ # need to create symlinks for doctests
+ mkdir -p "${TEST_DIR}"/lib/Bio/Align || die
+ ln -r -s "${S}"/Bio/Align/substitution_matrices \
+ "${TEST_DIR}"/lib/Bio/Align/substitution_matrices || die
+
+ cd "${TEST_DIR}"/lib/Tests || die
+ rm test_BioSQL_{psycopg2.py,MySQLdb.py,mysql_connector.py} || die
+ "${EPYTHON}" run_tests.py --offline --verbose || die
+}
+
+python_install_all() {
+ # remove files causing ecompressdir to fail
+ rm Doc/examples/ls_orchid.gbk.{gz,bz2} || die
+
+ distutils-r1_python_install_all
+
+ dodir /usr/share/${PN}
+ cp -r --preserve=mode Scripts Tests "${ED}"/usr/share/${PN} || die
+}
+
+pkg_postinst() {
+ optfeature_header "For database support you need to install:"
+ optfeature "MySQL database support" dev-python/mysqlclient
+ optfeature "PostgreSQL database support" dev-python/psycopg
+
+ optfeature_header "Some applications need extra packages:"
+ optfeature "EMBOSS (The European Molecular Biology Open Software Suite)" sci-biology/emboss
+}